Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 696936 - sys-apps/ucspi-ssl-0.94-r1 - ssl_env.c:53:46: error: dereferencing pointer to incomplete type ‘X509_NAME’ {aka ‘struct X509_name_st’}
Summary: sys-apps/ucspi-ssl-0.94-r1 - ssl_env.c:53:46: error: dereferencing pointer to...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on: 686430
Blocks: openssl-1.1
  Show dependency tree
 
Reported: 2019-10-08 07:10 UTC by Agostino Sarubbo
Modified: 2020-08-03 18:58 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log and emerge --info (file_696936.txt,13.93 KB, text/plain)
2019-10-08 07:16 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2019-10-08 07:10:50 UTC
This is an auto-filled bug because  fails to compile on amd64. Attached build log and emerge --info
Comment 1 Agostino Sarubbo gentoo-dev 2019-10-08 07:16:36 UTC
Created attachment 592114 [details]
build log and emerge --info
Comment 2 Alex Efros 2019-10-08 19:30:39 UTC
sys-apps/ucspi-ssl-0.94-r1 is not going to be fixed. sys-apps/ucspi-ssl-0.99e should be stabilized instead. And then we should update to sys-apps/ucspi-ssl-0.10.11.
Comment 3 Anthony Lieuallen 2019-10-25 23:58:01 UTC
FWIW, this bit me today.  Ended up going with sys-apps/ucspi-ssl-0.99e .
Comment 4 Anthony Lieuallen 2019-10-26 03:02:00 UTC
Actually, worse.  Every version before 0.99 currently in portage fails to build. With either 0.99 or 0.99e of ucspi-ssl installed, netqmail(-1.06-r4) fails to build.  And something wants to rebuild it, so today I can't update world.
Comment 5 Alex Efros 2019-10-26 08:50:12 UTC
Sorry to hear that. I've 2 PRs opened 17 days ago, still waiting for review/merge. I didn't like to request stabilization of 0.99e because this version should be removed right after merging these PRs… but if they're going to not being reviewed/merged on next week, then probably I should give up and request stabilization for 0.99e instead. :(
Comment 6 Aidan Marks 2019-11-06 23:11:39 UTC
Same build issues here with my ucspi-ssl/netqmail systems :(
Comment 7 Rolf Eike Beer 2020-08-03 18:58:42 UTC
For those that would like to get rid of this when using netqmail: rebuild with USE=-pop3 and use a different POP3 server instead if you need one. ucspi-ssl is only used for POP3S.