Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 695652 - x11-base/xorg-server USE=libglvnd : Package requirements (glproto >= 1.4.17 gl >= 9.2.0) were not met
Summary: x11-base/xorg-server USE=libglvnd : Package requirements (glproto >= 1.4.17 g...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
Depends on:
Blocks: use-libglvnd
  Show dependency tree
Reported: 2019-09-25 22:46 UTC by Alexander Tsoy
Modified: 2019-09-25 23:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

xorg-server-1.20.5:20190925-222544.log (xorg-server-1.20.5:20190925-222544.log,19.65 KB, text/plain)
2019-09-25 22:46 UTC, Alexander Tsoy

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Tsoy 2019-09-25 22:46:33 UTC
Created attachment 591098 [details]

With libglvnd-provided pkgconfig files:
$ pkg-config --modversion gl

Upstream bug report:
Comment 1 Matt Turner gentoo-dev 2019-09-25 22:53:33 UTC
Fixed by

commit 5a6deca6e403ca195b255bf78d41a5da4819d617
Author: Matt Turner <>
Date:   Wed Sep 25 14:50:06 2019 -0700

    x11-base/xorg-server: Allow building against libglvnd
    Mesa's gl.pc contains a version that matches the Mesa version, but
    libglvnd's gl.pc version is the SO version (1.2). The Xserver checks for
    gl >= 7.1.0 and gl >= 9.2.0 which are very old versions of Mesa at this
    point, so removing the version dependency doesn't negatively affect
    anything and allows the Xserver to build against libglvnd.
    Signed-off-by: Matt Turner <>