Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 695574 - net-dns/mydns-1.2.8.31-r2 : configure: error: OpenSSL libraries (libssl.so/libcrypto.so) not found!
Summary: net-dns/mydns-1.2.8.31-r2 : configure: error: OpenSSL libraries (libssl.so/li...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: PATCH
: 716174 (view as bug list)
Depends on:
Blocks: 763438
  Show dependency tree
 
Reported: 2019-09-24 16:38 UTC by Toralf Förster
Modified: 2021-03-09 11:44 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.59 KB, text/plain)
2019-09-24 16:38 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,167.50 KB, text/plain)
2019-09-24 16:38 UTC, Toralf Förster
Details
environment (environment,60.07 KB, text/plain)
2019-09-24 16:38 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,19.96 KB, application/x-bzip)
2019-09-24 16:38 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,14.85 KB, application/x-bzip)
2019-09-24 16:38 UTC, Toralf Förster
Details
net-dns:mydns-1.2.8.31-r2:20190924-014650.log (net-dns:mydns-1.2.8.31-r2:20190924-014650.log,17.39 KB, text/plain)
2019-09-24 16:38 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,21.14 KB, application/x-bzip)
2019-09-24 16:39 UTC, Toralf Förster
Details
Patch for /usr/lib64 path for libssl.so (lib64.patch,507 bytes, patch)
2019-10-09 12:20 UTC, Xepher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-09-24 16:38:41 UTC
checking for /usr/ssl/lib/libssl.so... no
checking for /usr/local/ssl/lib/libssl.so... no
configure: error: 

  ###
  ###  OpenSSL libraries (libssl.so/libcrypto.so) not found!

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-20190920-192958

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

clang:
clang version 9.0.0 (tags/RELEASE_900/final)
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/9/bin
llvm:
9.0.0
Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.37.0 *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.13.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Tue, 24 Sep 2019 00:47:34 +0000

emerge -qpvO net-dns/mydns
[ebuild  N    ] net-dns/mydns-1.2.8.31-r2  USE="mysql nls ssl -alias -debug -postgres -static -status"
Comment 1 Toralf Förster gentoo-dev 2019-09-24 16:38:44 UTC
Created attachment 590898 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-09-24 16:38:47 UTC
Created attachment 590900 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2019-09-24 16:38:50 UTC
Created attachment 590902 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2019-09-24 16:38:53 UTC
Created attachment 590904 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-09-24 16:38:56 UTC
Created attachment 590906 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-09-24 16:38:58 UTC
Created attachment 590908 [details]
net-dns:mydns-1.2.8.31-r2:20190924-014650.log
Comment 7 Toralf Förster gentoo-dev 2019-09-24 16:39:01 UTC
Created attachment 590910 [details]
temp.tbz2
Comment 8 Xepher 2019-10-09 12:20:15 UTC
Created attachment 592278 [details, diff]
Patch for /usr/lib64 path for libssl.so

Not really volunteering to be a maintainer, but here's a patch for the immediate problem on 64-bit.
Comment 9 Sam James archtester gentoo-dev Security 2021-03-09 11:37:10 UTC
*** Bug 716174 has been marked as a duplicate of this bug. ***
Comment 10 Larry the Git Cow gentoo-dev 2021-03-09 11:44:57 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c75f1a32274c3e88845fa7c6e4e0ca432bad6bd3

commit c75f1a32274c3e88845fa7c6e4e0ca432bad6bd3
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-03-09 11:37:18 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-03-09 11:44:49 +0000

    net-dns/mydns: fix openssl libdir search path
    
    Thanks-to: Xepher <xepher@xepher.net>
    Closes: https://bugs.gentoo.org/695574
    Signed-off-by: Sam James <sam@gentoo.org>

 net-dns/mydns/files/mydns-1.2.8.31-ssl-libdir.patch | 12 ++++++++++++
 net-dns/mydns/mydns-1.2.8.31-r2.ebuild              |  1 +
 2 files changed, 13 insertions(+)

Additionally, it has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b63f030857c045cdc7d7bc65e8f0c85055859332

commit b63f030857c045cdc7d7bc65e8f0c85055859332
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-03-09 11:43:54 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-03-09 11:44:50 +0000

    net-dns/mydns: add extended libdir patch for postgresql, zlib, etc
    
    Bug: https://bugs.gentoo.org/695574
    Signed-off-by: Sam James <sam@gentoo.org>

 .../mydns/files/mydns-1.2.8.31-misc-libdir.patch   | 41 ++++++++++++++++++++++
 net-dns/mydns/mydns-1.2.8.31-r2.ebuild             |  1 +
 2 files changed, 42 insertions(+)