Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 695446 - dev-qt/qtwebengine-5.12.5 - make[3]: *** [Makefile.core_module:87: ../../lib/] Error 1
Summary: dev-qt/qtwebengine-5.12.5 - make[3]: *** [Makefile.core_module:87: ../../lib/...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
Whiteboard: drop x86 keyword from dev-qt/qtwebeng...
Keywords: PullRequest
: 698190 (view as bug list)
Depends on:
Blocks: qt-5.13.2-stable 699328
  Show dependency tree
Reported: 2019-09-23 11:21 UTC by Andrew
Modified: 2020-02-10 06:47 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log.7z (build.log.7z,558.19 KB, application/x-7z-compressed)
2019-09-23 11:23 UTC, Andrew
emerge --info (,5.89 KB, application/x-info)
2019-09-23 11:23 UTC, Andrew

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew 2019-09-23 11:21:16 UTC
dev-qt/qtwebengine-5.12.5 compilation fails with error ld returned 1 "exit status". A search by the log of the strings "error:", "undefined reference", "No such file" did not lead to any results. The amount of RAM is 8GB. Free disk space of approximately 44GB. Swap partition size - 3.9GB. The error was repeated on two computers with ~ x86 architectures

Reproducible: Always
Comment 1 Andrew 2019-09-23 11:23:09 UTC
Created attachment 590676 [details]
Comment 2 Andrew 2019-09-23 11:23:38 UTC
Created attachment 590678 [details]
emerge --info
Comment 3 Michele Ciacci 2019-09-25 14:02:29 UTC
same issue here
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2019-09-28 05:15:49 UTC
Comment on attachment 590676 [details]

Did you know that you can compress singular files without bothering with an archiver?
Comment 5 Andreas Sturmlechner gentoo-dev 2019-09-29 09:34:37 UTC
Try to reduce makeopts value.
Comment 6 Andrew 2019-10-05 11:03:49 UTC
Compilation with "makeopts=-j1" ended with the same error
Comment 7 Viktor Yu. Kovalskii 2019-10-10 12:22:04 UTC
I have the same problem.
Compilation =dev-qt/qtwebengine-5.12.5 with MAKEOPTS="-j1" fails.

After switching to linker from =sys-devel/binutils-2.32-r1 =dev-qt/qtwebengine-5.12.5 with MAKEOPTS="-j1" compiles fine.

emerge --info
Portage 2.3.76 (python 3.6.9-final-0, default/linux/x86/17.0/desktop/plasma, gcc-7.4.0, glibc-2.29-r5, 4.14.142-gentoo i686)
System uname: Linux-4.14.142-gentoo-i686-Intel-R-_Core-TM-_Duo_CPU_T2350_@_1.86GHz-with-gentoo-2.6
KiB Mem:     3092740 total,    345060 free
KiB Swap:    2104508 total,   1774276 free
Timestamp of repository gentoo: Thu, 10 Oct 2019 08:25:54 +0000
Head commit of repository gentoo: a68287d8b9f63cb2666169bf7fc52d7798fc618a

Timestamp of repository flying: Wed, 18 Sep 2019 16:56:48 +0000
Timestamp of repository oschtan: Wed, 01 Aug 2018 15:39:26 +0000
Head commit of repository deadbeef-overlay: 53e0a41db6e7193bd83ef117f8055457f0990cb7

Head commit of repository jorgicio: 751d38110fe6383c60c26b80647cc4263339bd88

Head commit of repository kde: d6e938de77155f50611c534c81f748e61f5ef118

Head commit of repository mozilla: 5fc50e6dfbce4a970ae1cfc0cf4275ee93565d5b

Head commit of repository rion: 1620edac429e81a966a4dafc5d928b66d075dc62

Head commit of repository science: 85c146f1b5cdc1ac126b798e40b73b180a8c57cd

Head commit of repository stuff: 36f5f9ac6dd228d85cbcbc90af47a06d1218c4c5

sh bash 5.0_p11
ld GNU ld (Gentoo 2.32 p2) 2.32.0
ccache version 3.7.4 [enabled]
app-shells/bash:          5.0_p11::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.0::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.9::gentoo
dev-util/ccache:          3.7.4::gentoo
dev-util/cmake:           3.15.4::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            7.4.0-r2::gentoo, 9.2.0-r1::gentoo
sys-devel/gcc-config:     2.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.14-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r5::gentoo

    location: /mnt/slag/gentoo-tree
    sync-type: git
    priority: -1000

    location: /mnt/slag/layman/flying
    masters: gentoo

    location: /mnt/slag/layman/oschtan
    sync-type: rsync
    sync-uri: rsync://
    masters: gentoo

    location: /mnt/slag/layman/deadbeef-overlay
    sync-type: git
    masters: gentoo
    priority: 50

    location: /mnt/slag/layman/jorgicio
    sync-type: git
    masters: gentoo
    priority: 50

    location: /mnt/slag/layman/kde
    sync-type: git
    sync-uri: git://
    masters: gentoo
    priority: 50

    location: /mnt/slag/layman/mozilla
    sync-type: git
    sync-uri: git://
    masters: gentoo
    priority: 50

    location: /mnt/slag/layman/rion
    sync-type: git
    masters: gentoo
    priority: 50

    location: /mnt/slag/layman/science
    sync-type: git
    sync-uri: git://
    masters: gentoo
    priority: 50

    location: /mnt/slag/layman/stuff
    sync-type: git
    masters: gentoo
    priority: 50

Installed sets: @toolchain
CFLAGS="-O2 -pipe -march=native -fomit-frame-pointer -mtune=native"
CONFIG_PROTECT="/etc /usr/lib/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CPPFLAGS="-O2 -pipe -march=native -fomit-frame-pointer -mtune=native"
CXXFLAGS="-O2 -pipe -march=native -fomit-frame-pointer -mtune=native"
EMERGE_DEFAULT_OPTS="--autounmask=n --quiet-build --with-bdeps=y"
FCFLAGS="-O2 -pipe -march=native -fomit-frame-pointer -mtune=native"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildpkg ccache collision-protect distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync metadata-transfer multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms split-elog split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe -march=native -fomit-frame-pointer -mtune=native"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru ru_RU"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac acl acpi alsa amr apng archive aspell bluetooth branding bzip2 cairo caps cdda cddb cdparanoia cdr cli consolekit curl cxx dbus declarative djvu dri dts dvd dvdnav dvdr emboss emf enca encode exceptions exif expat faac faad fam fbcondecor ffmpeg flac fontconfig fortran ftp fuse gif git glib gmp gnutls gpm harfbuzz http iconv icu idn imagemagick introspection jbig jemalloc jpeg jpeg2k kde kwallet lame latex lcms libass libnotify libsamplerate libtirpc lm-sensors lz4 lzma lzo mad man mime mng modemmanager mp3 mp4 mpeg mtp musepack natspec ncurses networkmanager nls nptl ogg opengl openmp orc osmesa pam pango pcre pdf phonon plasma plymouth png policykit postscript ppds pulseaudio qml qt5 rar readline rtc seccomp sndfile spell split-usr sqlite ssl startup-notification svg tcpd threads tiff truetype twolame udev udisks unicode upower usb utils vorbis wavpack webengine webp widgets wifi wmf wxwidgets x264 x86 xattr xcb xcomposite xml xmp xorg xv xvid zip zlib" ABI_X86="32" ADA_TARGET="gnat_2018" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3" CURL_SSL="openssl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="ru" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="X86" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python3_6 python2_7" RUBY_TARGETS="ruby25" USERLAND="GNU" VIDEO_CARDS="intel i915" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 8 Andrew 2019-10-20 08:59:28 UTC
In my case, after switching to linker from = sys-devel / binutils-2.32-r1 = dev-qt / qtwebengine-5.12.5 with MAKEOPTS = "-j1" it compiles with the same error
Comment 9 Thomas Deutschmann (RETIRED) gentoo-dev 2019-10-21 10:58:27 UTC
*** Bug 698190 has been marked as a duplicate of this bug. ***
Comment 10 Andreas Sturmlechner gentoo-dev 2019-10-21 11:27:42 UTC
Please try again after upgrade to qtcore-5.12.5-r1.
Comment 11 Andrew 2019-10-28 04:44:45 UTC
After upgrading to qtcore-5.12.5-r1, the error was repeated with MAKEOPTS="-j5" and MAKEOPTS="-j1"
Comment 12 Thomas Deutschmann (RETIRED) gentoo-dev 2019-10-28 11:41:38 UTC
x86 is still unable to build:

/usr/lib/gcc/i686-pc-linux-gnu/8.3.0/../../../../i686-pc-linux-gnu/bin/ld: /var/tmp/portage/dev-qt/qtwebengine-5.12.5/wo
rk/qtwebengine-everywhere-src-5.12.5/src/core/release/obj/third_party/openh264/openh264_common_yasm/dct.o: warning: relo
cation in read-only section `.text'
/usr/lib/gcc/i686-pc-linux-gnu/8.3.0/../../../../i686-pc-linux-gnu/bin/ld: warning: creating a DT_TEXTREL in object
collect2: error: ld returned 1 exit status
make[3]: *** [Makefile.core_module:87: ../../lib/] Error 1
make[3]: Leaving directory '/var/tmp/portage/dev-qt/qtwebengine-5.12.5/work/qtwebengine-everywhere-src-5.12.5/src/core'
make[2]: *** [Makefile:124: sub-core_module-pro-make_first] Error 2
make[2]: Leaving directory '/var/tmp/portage/dev-qt/qtwebengine-5.12.5/work/qtwebengine-everywhere-src-5.12.5/src/core'
make[1]: *** [Makefile:81: sub-core-make_first] Error 2
make[1]: Leaving directory '/var/tmp/portage/dev-qt/qtwebengine-5.12.5/work/qtwebengine-everywhere-src-5.12.5/src'
make: *** [Makefile:49: sub-src-make_first] Error 2
 * ERROR: dev-qt/qtwebengine-5.12.5::gentoo failed (compile phase):
 *   emake failed
Comment 13 Peter Levine 2019-11-06 05:18:23 UTC
Maybe similar to

Maybe try building media-video/ffmpeg with USE="pic" and see if dev-qt/qtwebengine can successfully link, or try building dev-qt/qtwebengine with USE="-system-ffmpeg" and see if it succeeds.
Comment 14 Andrew 2019-11-07 09:31:39 UTC
Compiling dev-qt/qtwebengine with USE = "-system-ffmpeg" ended with the same error
Comment 15 toms.ozols5 2019-11-09 22:37:53 UTC
Worked for Me after removing system-ffmpeg

dev-qt/qtwebengine-5.12.5::gentoo was built with the following:
USE="alsa pulseaudio system-icu widgets -bindist -debug -designer -jumbo-build -pax_kernel -system-ffmpeg -test" ABI_X86="(64)"
FEATURES="assume-digests unmerge-logs usersandbox merge-sync pid-sandbox unknown-features-warn binpkg-docompress ipc-sandbox sandbox sfperms fixlafiles parallel-fetch config-protect-if-modified binpkg-dostrip userfetch binpkg-logs usersync unmerge-orphans network-sandbox xattr strict news preserve-libs protect-owned multilib-strict ebuild-locks userpriv distlocks"
Comment 16 Andrew 2019-11-15 09:26:02 UTC
Compiling dev-qt/qtwebengine with USE="-system-ffmpeg" failed with the same error. The error is reproduced when MAKEOPTS="-j1" and MAKEOPTS="-j5". Platform ~x86
Comment 17 Andrew 2020-01-24 00:14:03 UTC
Error repeated for dev-qt/qtwebengine-5.14.0.
Comment 18 Larry the Git Cow gentoo-dev 2020-02-10 06:42:12 UTC
The bug has been closed via the following commit(s):

commit c5eefaf080581309a9d4c6dd03c55a84957aa3b5
Author:     Stephan Hartmann <>
AuthorDate: 2020-02-08 21:35:41 +0000
Commit:     Andreas Sturmlechner <>
CommitDate: 2020-02-10 06:41:45 +0000

    dev-qt/qtwebengine: fix building on x86
    Package-Manager: Portage-2.3.76, Repoman-2.3.16
    Signed-off-by: Stephan Hartmann <>
    Signed-off-by: Andreas Sturmlechner <>

 .../files/qtwebengine-5.14.1-disable-fatal-warnings.patch    | 12 ++++++++++++
 dev-qt/qtwebengine/qtwebengine-5.14.1.ebuild                 |  4 ++++
 2 files changed, 16 insertions(+)
Comment 19 Larry the Git Cow gentoo-dev 2020-02-10 06:47:30 UTC
The bug has been closed via the following commit(s):

commit c451f62d808f3642fa25778a9d7895e1710b69f6
Author:     Stephan Hartmann <>
AuthorDate: 2020-02-08 21:35:41 +0000
Commit:     Andreas Sturmlechner <>
CommitDate: 2020-02-10 06:47:05 +0000

    dev-qt/qtwebengine: fix building on x86
    Package-Manager: Portage-2.3.76, Repoman-2.3.16
    Signed-off-by: Stephan Hartmann <>
    Signed-off-by: Andreas Sturmlechner <>

 .../files/qtwebengine-5.14.1-disable-fatal-warnings.patch    | 12 ++++++++++++
 dev-qt/qtwebengine/qtwebengine-5.14.9999.ebuild              |  2 ++
 2 files changed, 14 insertions(+)