Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 69512 - mpg123-0.59s-r6 has the problem of decoding, and a problem on a play on PPC64
Summary: mpg123-0.59s-r6 has the problem of decoding, and a problem on a play on PPC64
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC64 Linux
: High normal (vote)
Assignee: ppc64 architecture team
Depends on:
Reported: 2004-10-30 08:53 UTC by Yuta SATOH (RETIRED)
Modified: 2005-01-07 07:10 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

patch for mpg123-0.59s-r6.ebuild (mpg123-0.59s-r6.ebuild.patch,447 bytes, patch)
2004-10-30 08:56 UTC, Yuta SATOH (RETIRED)
Details | Diff
patch for mpg123-0.59s-r6.ebuild (mpg123-0.59s-r6.ebuild.patch,624 bytes, patch)
2004-11-02 07:51 UTC, Yuta SATOH (RETIRED)
Details | Diff
patch for mpg123-0.59s-r6.ebuild (mpg123-0.59s-r6.ebuild.patch,621 bytes, patch)
2004-11-03 01:03 UTC, Yuta SATOH (RETIRED)
Details | Diff
patch for mpg123 on ppc64 (mpg123-0.59s-ppc64.patch,437 bytes, patch)
2004-11-03 01:04 UTC, Yuta SATOH (RETIRED)
Details | Diff
patch for 001_all_Makefile.patch (001_all_Makefile.patch.patch,713 bytes, patch)
2004-11-14 03:58 UTC, Yuta SATOH (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuta SATOH (RETIRED) gentoo-dev 2004-10-30 08:53:49 UTC
On ppc64 If 010_all_long2int.patch is applied, it cannot decode normally.
Please do not apply on ppc64.

010_all_long2int.patch is contained in mpg123-0.59s-gentoo-1.1.tar.bz2.

Reproducible: Always
Steps to Reproduce:

1. ACCEPT_KEYWORDS=~ppc64 emerge mpg123
2. mpg123 -w test.wav test.mp3
3. play a wav file.
Comment 1 Yuta SATOH (RETIRED) gentoo-dev 2004-10-30 08:56:12 UTC
Created attachment 42914 [details, diff]
patch for mpg123-0.59s-r6.ebuild

mpg123-0.59s-r6 has the problem which plays only a noise.
The appended patch fixes the problem.
Comment 2 Yuta SATOH (RETIRED) gentoo-dev 2004-10-30 09:11:02 UTC
emerge info output:

Portage 2.0.50-r11 (default-ppc64-2004.2, gcc-3.4.1, glibc-, 2.6.8-gentoo-r3)
System uname: 2.6.8-gentoo-r3 ppc64 PPC970, altivec supported
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -pipe"
FEATURES="autoaddcvs buildpkg ccache noclean sandbox"
USE="X Xaw3d aalib alsa altivec apache2 arts berkdb bitmap-fonts cdr cjk crypt cups dga dvd dvdr emacs encode esd f77 flash foomaticdb gdbm gif gnome gpm gtk gtk2 imap imlib joystick jpeg kde libwww mad mitshm motif mozilla mpeg mule ncurses nls nogcj oggvorbis opengl oss pam pdflib perl png ppc64 python qt quicktime readline samba sdl slang ssl tcpd tetex tiff truetype usb xml xml2 xmms xprint xv zlib"

Comment 3 Yuta SATOH (RETIRED) gentoo-dev 2004-11-02 07:51:43 UTC
Created attachment 43167 [details, diff]
patch for mpg123-0.59s-r6.ebuild

mpg123-0.59s-r6 has the problem which plays only a noise.
The appended patch fixes the problem.
And in the case of PPC64, 010_all_long2int.patch is delete.
Comment 4 Jeremy Huddleston (RETIRED) gentoo-dev 2004-11-02 13:48:14 UTC
Use EPATCH_EXCLUDE rather than removing the patch... but this is not the proper correction...  that patch is correct, but if it causes you problems, then it means that there are more log/int bugs in the source that need to be fixed.

I wonder if this is related to bug #56765.  Can youu try different output options to see if this is limited to just a couple please?
Comment 5 Yuta SATOH (RETIRED) gentoo-dev 2004-11-03 01:02:19 UTC
Thank you for your hint.
I created the new patch to source.

I think that "mpg123 -s hoge.mp3" is working normally on PPC64.
Because, PPC64 is the architecture of big endian and the output raw data is also byte order of big endian.
(mpg123 is output by the host byte order. Please see man if necessary.)

The procedure which I checked is as follows.

1. mpg123 -s test.mp3 > mpg123.raw
2. oggenc -r --raw-endianness 1 mpg123.raw
3. ogg123 mpg123.ogg

Also, mpg321 seems output by the byte order of little endian.

1. mpg321 -s test.mp3 > mpg321.raw
2. oggenc -r --raw-endianness 0 mpg321.raw
3. ogg123 mpg321.ogg

About option raw-endianness of oggenc...
When set to 1 : big endian
When set to 0 : little endian

Please see man for details.

Thank you.
Comment 6 Yuta SATOH (RETIRED) gentoo-dev 2004-11-03 01:03:26 UTC
Created attachment 43206 [details, diff]
patch for mpg123-0.59s-r6.ebuild
Comment 7 Yuta SATOH (RETIRED) gentoo-dev 2004-11-03 01:04:54 UTC
Created attachment 43207 [details, diff]
patch for mpg123 on ppc64

A file name is mpg123-0.59s-ppc64.patch .
Comment 8 Jeremy Huddleston (RETIRED) gentoo-dev 2004-11-03 02:38:37 UTC
ok, I'll take a look at that on my archs (x86, amd64, sparc)... well... just amd64 as it changes nothing on the other two...
Comment 9 Markus Rothe (RETIRED) gentoo-dev 2004-11-03 08:45:44 UTC
commited that patch.

@eradicator: Does this also affect amd64? If yes and you fixed that, please close.

Comment 10 Jeremy Huddleston (RETIRED) gentoo-dev 2004-11-03 14:27:50 UTC
fixed in cvs.

corsair, please make sure to test an ebuild before committing.  Your patch name didn't match what was being used by the ebuild  (you committed ${PF}-... whereas youu epatched ${P}-...)

I revbumped instead and kept it stable on amd64 and ppc64.
Comment 11 Yuta SATOH (RETIRED) gentoo-dev 2004-11-03 23:34:10 UTC
Although I tried the new version -r7, the following errors occurred.
Would you upload the new patch?

Thank you.

>>> Downloading
           => `/usr/portage/distfiles/mpg123-0.59s-gentoo-1.2.tar.bz2'
Connecting to[]:80... connected.
HTTP request sent, awaiting response... 404 Not Found
16:27:44 ERROR 404: Not Found.

!!! Couldn't download mpg123-0.59s-gentoo-1.2.tar.bz2. Aborting.

Comment 12 Markus Rothe (RETIRED) gentoo-dev 2004-11-03 23:47:49 UTC
damn.. I tested it, but I think didn't copied the ebuild (to update it in CVS) or that is to say I modified it once more.. :-/ sry..

Have to leave now.. school. I'll fix that this afternoon.

Comment 13 Jeremy Huddleston (RETIRED) gentoo-dev 2004-11-04 02:22:57 UTC
yuta: sorry about that... should be there now.
Comment 14 Yuta SATOH (RETIRED) gentoo-dev 2004-11-04 02:44:33 UTC
Thank you!
I tried the new version and it confirmed that these problems did not occur.
Comment 15 Markus Rothe (RETIRED) gentoo-dev 2004-11-04 09:05:56 UTC
So this bug is finaly closed?

Comment 16 Jeremy Huddleston (RETIRED) gentoo-dev 2004-11-04 13:02:17 UTC
Comment 17 Yuta SATOH (RETIRED) gentoo-dev 2004-11-14 03:56:28 UTC
The problem of the sound in a wide range package was solved by Bug #71119 on PPC64.
Consequently, the necessity of using the code for big endian contained in this package itself was lost.

And the problem has occurred again now owing to the code.
Comment 18 Yuta SATOH (RETIRED) gentoo-dev 2004-11-14 03:58:00 UTC
Created attachment 43923 [details, diff]
patch for 001_all_Makefile.patch

This patch solves the above-mentioned problem.

I am sorry to trouble you, but could you apply this patch?
Comment 19 Jeremy Huddleston (RETIRED) gentoo-dev 2005-01-07 00:54:07 UTC
fixed in cvs.
Comment 20 Markus Rothe (RETIRED) gentoo-dev 2005-01-07 07:10:06 UTC