Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 694744 - app-admin/calamares-3.2.12 wrongly depends on dev-libs/libpwquality[${PYTHON_USEDEP}]
Summary: app-admin/calamares-3.2.12 wrongly depends on dev-libs/libpwquality[${PYTHON_...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Johannes Huber
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-17 17:08 UTC by Mart Raudsepp
Modified: 2020-03-19 07:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mart Raudsepp gentoo-dev 2019-09-17 17:08:03 UTC
calamares depends on dev-libs/libpwquality[${PYTHON_USEDEP}].
I suppose it does need the python bindings, but then it must also depend on USE=python with dev-libs/libpwquality[python,${PYTHON_USEDEP}], or python bindings may still be missing and things are broken.
tl;dr: $PYTHON_USEDEP without USE=python dep don't make sense for a libpwquality dependency atom.
Comment 1 Johannes Huber gentoo-dev 2020-03-19 07:05:54 UTC
Looks fixed by someone in the meantime.