Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 694576 - app-portage/distpatch - please add support for Python 3
Summary: app-portage/distpatch - please add support for Python 3
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Rafael Martins
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: python-3
  Show dependency tree
 
Reported: 2019-09-16 20:36 UTC by Sławomir Nizio
Modified: 2019-09-18 14:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sławomir Nizio 2019-09-16 20:36:56 UTC
app-portage/distpatch-0.1.2-r1 has PYTHON_COMPAT=( python2_7 )
some other packages that depend on dev-python/snakeoil, such as sys-apps/pkgcore-0.10.3 have something like: PYTHON_COMPAT=( python3_{6,7} )

now, dev-python/snakeoil-0.7.5 has PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
^ works with both

but newer version: dev-python/snakeoil/snakeoil-0.8.3 supports only Python 3: PYTHON_COMPAT=( python3_{6,7} )


So it's not possible to have distpatch and (for example) pkgcore with new version of snakeoil on the same system.

Also, it's 2019 already. ;)

Reproducible: Always