Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 694102 - =net-misc/dhcp-4.4.1 depends on openssl:0
Summary: =net-misc/dhcp-4.4.1 depends on openssl:0
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-11 20:36 UTC by OzTiram
Modified: 2019-09-11 20:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description OzTiram 2019-09-11 20:36:07 UTC
This package is blocking upgrade to openssl-1.1.1 because it's got a requirement to slot :0, but I see nowhere in the code of isc-dhcp a requirement for this to be built with openssl versions smaller than 1.1.
Also, I looked at the yocto package and archlinux, and they only specify openssl.

Can this slotting be removed?
Comment 1 Andreas Sturmlechner gentoo-dev 2019-09-11 20:47:29 UTC
First appearance without mentioning why this was introduced:

> commit 6b532c76877acec05f5a2a51a664550bb482a87f
> Author: Julian Ospald <hasufell@gentoo.org>
> Date:   Sun Oct 4 23:41:58 2015 +0200
> 
>     net-misc/dhcp: add libressl support