Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 693958 - gnome-extra/nm-applet should configure --without-libnm-gtk
Summary: gnome-extra/nm-applet should configure --without-libnm-gtk
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-09 20:51 UTC by Olof Kindgren
Modified: 2019-09-10 06:37 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olof Kindgren 2019-09-09 20:51:24 UTC
nm-applet is built with --with-libnm-gtk. According to upstream (https://gitlab.gnome.org/GNOME/network-manager-applet/blob/master/NEWS), this library is deprecated since 1.8.20 and shouldn't be used. It also pulls in dbus-glib, which is also deprecated.

Does libnm-gtk have any users in gentoo? In that case maybe hide it behind a use flag.