Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 693726 - kde-apps/kdepim-runtime-19.08.1 - .../work/kdepim-runtime-19.08.1/resources/mbox/compactpage.h:25:10: fatal error: ui_compactpage.h: No such file or directory
Summary: kde-apps/kdepim-runtime-19.08.1 - .../work/kdepim-runtime-19.08.1/resources/m...
Status: RESOLVED DUPLICATE of bug 691938
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-08 01:32 UTC by jms
Modified: 2019-09-08 16:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (kde-apps:kdepim-runtime-19.08.1:20190908-011653.log,755.47 KB, text/plain)
2019-09-08 01:32 UTC, jms
Details
emerge--info (emerge-info.txt,7.56 KB, text/plain)
2019-09-08 01:35 UTC, jms
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jms 2019-09-08 01:32:29 UTC
Created attachment 589382 [details]
build log

fail to compile

In file included from ^[[01m^[[K/var/tmp/portage/kde-apps/kdepim-runtime-19.08.1/work/kdepim-runtime-19.08.1/resources/mbox/mboxresource.cpp:34^[[m^[[K:
^[[01m^[[K/var/tmp/portage/kde-apps/kdepim-runtime-19.08.1/work/kdepim-runtime-19.08.1/resources/mbox/compactpage.h:25:10:^[[m^[[K ^[[01;31m^[[Kfatal error: ^[[m^[[Kui_compactpage.h: No such file or directory
   25 | #include ^[[01;31m^[[K"ui_compactpage.h"^[[m^[[K
      |          ^[[01;31m^[[K^~~~~~~~~~~~~~~~~~^[[m^[[K
compilation terminated.
[352/722] cd /var/tmp/portage/kde-apps/kdepim-runtime-19.08.1/work/kdepim-runtime-19.08.1_build/resources/mixedmaildir && /usr/bin/cmake -E cmake_autogen /var/tmp/portage/kde-apps/kdepim-runtime-19.08.1/work/kdepim-runtime-19.08.1_build/resources/mixedmaildir/CMakeFiles/akonadi_mixedmaildir_resource_autogen.dir/AutogenInfo.cmake Gentoo
[353/722] /usr/bin/x86_64-pc-linux-gnu-g++ -DHAVE_QCA -DKCOREADDONS_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_CAST_FROM_ASCII -DQT_NO_CAST_FROM_BYTEARRAY -DQT_NO_CAST_TO_ASCII -DQT_NO_DEBUG -DQT_NO_NARROWING_CONVERSIONS_IN_CONNECT -DQT_NO_SIGNALS_SLOTS_KEYWORDS -DQT_NO_URL_CAST_FROM_STRING -DQT_STRICT_ITERATORS -DQT_USE_QSTRINGBUILDER -DQT_WIDGETS_LIB -DQT_XML_LIB -DTRANSLATION_DOMAIN=\"akonadi_mbox_resource\" -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -Iresources/mbox -I/var/tmp/portage/kde-apps/kdepim-runtime-19.08.1/work/kdepim-runtime-19.08.1/resources/mbox -Iresources/mbox/akonadi_mbox_resource_autogen/include -I/var/tmp/portage/kde-apps/kdepim-runtime-19.08.1/work/kdepim-runtime-19.08.1/resources/shared/singlefileresource -Iresources/shared/singlefileresource -I/var/tmp/portage/kde-apps/kdepim-runtime-19.08.1/work/kdepim-runtime-19.08.1/resources/folderarchivesettings -isystem /usr/include/KF5/KI18n -isystem /usr/include/KF5 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtCore -isystem /usr/lib64/qt5/mkspecs/linux-g++ -isystem /usr/include/KF5/KMbox -isystem /usr/include/KF5/KMime -isystem /usr/include/KF5/AkonadiCore -isystem /usr/include/KF5/KCoreAddons -isystem /usr/include/KF5/KItemModels -isystem /usr/include/qt5/QtGui -isystem /usr/include/KF5/Akonadi/KMime -isystem /usr/include/KF5/akonadi/kmime -isystem /usr/include/KF5/KIOCore -isystem /usr/include/KF5/KService -isystem /usr/include/KF5/KConfigCore -isystem /usr/include/qt5/QtNetwork -isystem /usr/include/qt5/QtConcurrent -isystem /usr/include/qt5/QtDBus -isystem /usr/include/KF5/AkonadiAgentBase -isystem /usr/include/qt5/QtWidgets -isystem /usr/include/KF5/KConfigGui -isystem /usr/include/qt5/QtXml -isystem /usr/include/KF5/KDBusAddons -isystem /usr/include/KF5/KCompletion -isystem /usr/include/KF5/KIOWidgets -isystem /usr/include/KF5/KJobWidgets -isystem /usr/include/KF5/KWidgetsAddons -isystem /usr/include/KF5/KConfigWidgets -isystem /usr/include/KF5/KCodecs -isystem /usr/include/KF5/KAuth  -DQT_NO_DEBUG -DNDEBUG -march=native -O2 -pipe -fno-delete-null-pointer-checks -std=c++0x -fno-operator-names -fno-exceptions -Wall -Wextra -Wcast-align -Wchar-subscripts -Wformat-security -Wno-long-long -Wpointer-arith -Wundef -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type -Wvla -Wdate-time -Wsuggest-override -Wlogical-op -fdiagnostics-color=always -pedantic -Wzero-as-null-pointer-constant -fvisibility=hidden -fvisibility-inlines-hidden   -fPIC -fexceptions -std=gnu++11 -MD -MT resources/mbox/CMakeFiles/akonadi_mbox_resource.dir/akonadi_mbox_resource_autogen/mocs_compilation.cpp.o -MF resources/mbox/CMakeFiles/akonadi_mbox_resource.dir/akonadi_mbox_resource_autogen/mocs_compilation.cpp.o.d -o resources/mbox/CMakeFiles/akonadi_mbox_resource.dir/akonadi_mbox_resource_autogen/mocs_compilation.cpp.o -c resources/mbox/akonadi_mbox_resource_autogen/mocs_compilation.cpp
ninja: build stopped: subcommand failed.
 ^[[31;01m*^[[0m ERROR: kde-apps/kdepim-runtime-19.08.1::gentoo failed (compile phase):
 ^[[31;01m*^[[0m   ninja -v -j3 -l0 failed
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m Call stack:
 ^[[31;01m*^[[0m     ebuild.sh, line  125:  Called src_compile
 ^[[31;01m*^[[0m   environment, line 2735:  Called kde5_src_compile
 ^[[31;01m*^[[0m   environment, line 2153:  Called cmake-utils_src_compile
 ^[[31;01m*^[[0m   environment, line 1114:  Called cmake-utils_src_make
 ^[[31;01m*^[[0m   environment, line 1295:  Called _cmake_ninja_src_make
 ^[[31;01m*^[[0m   environment, line  770:  Called eninja
 ^[[31;01m*^[[0m   environment, line 1594:  Called die
Comment 1 jms 2019-09-08 01:35:29 UTC
Created attachment 589384 [details]
emerge--info

emerge --info '=kde-apps/kdepim-runtime-19.08.1::gentoo'
Comment 2 jms 2019-09-08 01:37:54 UTC
eix -I ninja
[I] dev-util/ninja
     Available versions:  1.8.2 (~)1.8.2-r1 (~)1.8.2-r2 (~)1.9.0 **9999*l {doc emacs test vim-syntax}
     Installed versions:  1.9.0(14:56:27 09/05/19)(-doc -emacs -test -vim-syntax)
     Homepage:            https://ninja-build.org/
     Description:         A small build system similar to make
Comment 3 jms 2019-09-08 01:53:22 UTC
I don't get it I just tried compiling again and now it works.
Parallel compiling?
Computer humour?

I'll leave the bug open a few days in case.
Otherwise I'll close it down or if I forget please do so.
Comment 4 Andreas Sturmlechner gentoo-dev 2019-09-08 16:08:19 UTC

*** This bug has been marked as a duplicate of bug 691938 ***