Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 693590 - dev-ruby/facter-3.14.3 should not depend on <dev-libs/boost-1.70.0
Summary: dev-ruby/facter-3.14.3 should not depend on <dev-libs/boost-1.70.0
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Matthew Thode ( prometheanfire )
URL:
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2019-09-06 04:06 UTC by Matt McAdoo
Modified: 2019-11-08 20:14 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
facter-3.14.3-r1.ebuild (facter-3.14.3-r1.ebuild,2.40 KB, text/plain)
2019-09-06 04:06 UTC, Matt McAdoo
Details
3.14.15 patch (factor-patch-3.14.5-r1.patch,379 bytes, patch)
2019-10-12 16:18 UTC, Matt McAdoo
Details | Diff
Attaching build log of failed tests (facter-3.14.5-testfails.log,261.27 KB, text/x-log)
2019-10-12 16:25 UTC, Matt McAdoo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt McAdoo 2019-09-06 04:06:15 UTC
Created attachment 589158 [details]
facter-3.14.3-r1.ebuild

Ever since this commit[1], dev-ruby/facter has capped off the dev-libs/boost version to be less than 1.70.0.  https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=fa42c8d85f693a0ac72d0543d8e6435d874fee3e

I was able to compile it on my system without a problem.
Comment 1 Matt McAdoo 2019-09-06 04:06:50 UTC
Portage 2.3.73 (python 3.7.4-final-0, default/linux/amd64/17.1/desktop/gnome/systemd, gcc-9.2.0, glibc-2.29-r5, 5.2.10-gentoo x86_64)
=================================================================
System uname: Linux-5.2.10-gentoo-x86_64-Intel-R-_Core-TM-_i7-4800MQ_CPU_@_2.70GHz-with-gentoo-2.6
KiB Mem:    32576000 total,  11088752 free
KiB Swap:    3999740 total,   3999740 free
Timestamp of repository gentoo: Fri, 06 Sep 2019 00:30:01 +0000
Head commit of repository gentoo: 343b06df253e9335e5bfbd2b726a54b2d189ea7a
sh bash 5.0_p11
ld GNU ld (Gentoo 2.32 p2) 2.32.0
app-shells/bash:          5.0_p11::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.0::gentoo
dev-lang/python:          2.7.16::gentoo, 3.5.7::gentoo, 3.6.9::gentoo, 3.7.4-r1::gentoo
dev-util/cmake:           3.15.3::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.10.3-r3::gentoo, 1.11.6-r3::gentoo, 1.12.6-r2::gentoo, 1.13.4-r2::gentoo, 1.14.1-r2::gentoo, 1.15.1-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.31.1-r6::gentoo, 2.32-r1::gentoo
sys-devel/gcc:            8.3.0-r1::gentoo, 9.1.0-r1::gentoo, 9.2.0::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.2::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r5::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-max-age: 24
    sync-rsync-extra-opts: 
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1

Local-Grotto
    location: /usr/local/portage
    masters: gentoo
    priority: 0

cg
    location: /var/lib/layman/cg
    masters: gentoo
    priority: 50

freeswitch
    location: /var/lib/layman/freeswitch
    masters: gentoo
    priority: 50

sirjaren
    location: /var/lib/layman/sirjaren
    masters: gentoo
    priority: 50

steam-overlay
    location: /var/lib/layman/steam-overlay
    masters: gentoo
    priority: 50

torbrowser
    location: /var/lib/layman/torbrowser
    masters: gentoo
    priority: 50

wine
    location: /var/lib/layman/wine
    masters: gentoo
    priority: 50

zugaina
    location: /var/lib/layman/zugaina
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.2/ext-active/ /etc/php/apache2-php7.3/ext-active/ /etc/php/cgi-php7.2/ext-active/ /etc/php/cgi-php7.3/ext-active/ /etc/php/cli-php7.2/ext-active/ /etc/php/cli-php7.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j12"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi addc alsa amd64 ao apache2 appindicator archive atasmart awt berkdb bluetooth boto branding bzip2 cairo calendar caps cdda cddb cdr cgroup-hybrid chromium cli cluster colord context crypt cups curl cxx d3d9 dbus development device-mapper dhclient dia down-root dri drm dts dvd dvdr eds elfutils emboss encode epspdf evo exif extensions extra extraengine fam fdk ffmpge flac fortran fpm freerdp games gcj gd gdata gdbm geckodriver gentoo-vm gif gimp git glamor gles gles1 gltf gnome gnome-keyring gnome-online-accounts google gpg gpm graph graphics gstreamer gtk gtk3 hddtemp highlight http humanities hwaccel iconv icu imagemagick introspection iproute2 ipv6 jack javascript jemalloc jpeg jpeg2k json lcms ldap libkms libnotify libsecret libtirpc lm_sensors login lto lua lxc lz4 lzma mad matroska maxminddb mediaplayer mms mmx mmxext mng mod modplug mp3 mp4 mpeg mtp multilib music mysql mysqli mysqlnd nautilus ncat ncurses ndiff network networkmanager nfs nfsv4 nfsv41 nls notification nping nptl nvenc odf offensive ofx ogg omega opencl opengl openmp opus osmesa pam pango pcre pda pdf pdfannotextractor pdfimport pdo pgo php png policykit postgres postproc ppds printsupport profiling pstricks publishers pulseaudio qt5 raw readline redis rrdcgi s3tc samba science sdl seccomp sendto sensord slib soap sockets speex spell spice split-usr sqlite sse sse2 sse3 sse4.1 sse4.2 ssh ssl ssse3 staging startup-notification svc svg syntax-check system-ffmpeg system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-sqlite systemd systemtap sysv-utils sysvipc tcpd telepathy terminal tex4ht texi2html tfshark theora threads thunar tiff tokudb tools tor-hardening tproxy tray truetype udev udisks unicode update_drivedb upower usb user-session uvm v4l vaapi vdpau vim vim-syntax virtualbox visio vkd3d vlc vnc vorbis vpx vte vulkan wayland webp widevine winbind wireshark-plugins wxwidgets x264 x265 xa xattr xcb xcomposite xetex xface xinerama xml xmlwriter xrandr xsl xslt xv xvfb xvid xvmc zenmap zip zlib zsh-completion zsh-completions" ABI_X86="64 32" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_core authn_dbm authn_file authz_core authz_dbm authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir env expires ext_filter file_cache filter headers include info log_config logio mime mime_magic negotiation proxy proxy_balancer proxy_connect proxy_fdpass proxy_fcgi proxy_http proxy_scgi proxy_wstunnel ratelimit rewrite setenvif slotmem_shm socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" APACHE2_MPMS="event" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" CURL_SSL="openssl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="mouse keyboard evdev synaptics" KERNEL="linux" L10N="en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher" NETBEANS_MODULES="apisupport java javafx mobility php profiler websvccommon" NGINX_MODULES_HTTP="access auth_basic autoindex browser charset empty_gif fastcgi geo gzip limit_conn limit_req map memcached proxy referer rewrite scgi split_clients ssi upstream_ip_hash userid uwsgi gunzip gzip_static metrics mp4 naxsi security realip stub_status pcre-jit" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6 python3_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby25 ruby26" USERLAND="GNU" VIDEO_CARDS="intel nouveau i965 nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Jeroen Roovers gentoo-dev 2019-09-06 05:23:50 UTC
Comment on attachment 589158 [details]
facter-3.14.3-r1.ebuild

--- a/facter-3.14.3.ebuild
+++ b/facter-3.14.3-r1.ebuild
@@ -33,7 +33,6 @@
        app-emulation/virt-what
        net-misc/curl
        >=dev-libs/boost-1.54:=[nls]
-       <dev-libs/boost-1.70.0
        >=dev-cpp/yaml-cpp-0.5.1
        !<app-admin/puppet-4.0.0"
Comment 3 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2019-09-06 23:04:47 UTC
Matt:
Can you please confirm what version of boost was on your system?
This did used to fail, but seems to work now, so need to figure out what changed.
Comment 4 Matt McAdoo 2019-09-07 01:25:15 UTC
[I] dev-libs/boost
     Available versions:  1.65.0(0/1.65.0)^t (~)1.70.0(0/1.70.0)^t {bzip2 context debug doc icu lzma mpi +nls numpy python static-libs +threads tools zlib zstd ABI_MIPS="n32 n64 o32" ABI_RISCV="lp64 lp64d" ABI_S390="32 64" ABI_X86="32 64 x32" PYTHON_TARGETS="python2_7 python3_5 python3_6 python3_7"}
     Installed versions:  1.70.0(0/1.70.0)^t(03:35:59 AM 08/26/2019)(bzip2 context icu lzma nls threads tools zlib -debug -doc -mpi -numpy -python -static-libs -zstd ABI_MIPS="-n32 -n64 -o32" ABI_RISCV="-lp64 -lp64d" ABI_S390="-32 -64" ABI_X86="32 64 -x32" PYTHON_TARGETS="python2_7 python3_6 python3_7 -python3_5")


[I] dev-ruby/facter
     Available versions:  3.9.2-r1 3.13.2-r1 3.14.2 (~)3.14.3 (~)3.14.3-r1[1] **9999*l {debug test RUBY_TARGETS="ruby24 ruby25 ruby26"}
     Installed versions:  3.14.3-r1[?](11:00:29 PM 09/05/2019)(-debug -test RUBY_TARGETS="ruby25 ruby26 -ruby24")
Comment 5 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-09-19 08:05:39 UTC
Ping.  I'm using facter with new boost for a few months now, and this silly restriction causes horrible conflicts on every upgrade.
Comment 6 Matthew Thode ( prometheanfire ) archtester Gentoo Infrastructure gentoo-dev Security 2019-09-19 15:16:40 UTC
mgorny, if you've tested facter with newer boost, feel free to change the deps on the versions you tested (I assume 3.14.4 and 9999?).
Comment 7 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-09-19 15:31:27 UTC
Regarding testing: is it expected that tests fail?  I'm wondering if boost version is relevant to that.
Comment 8 Matthew Thode ( prometheanfire ) archtester Gentoo Infrastructure gentoo-dev Security 2019-09-19 16:05:35 UTC
tests should pass

sudo ACCEPT_KEYWORDS=~amd64 USE=test FEATURES=test emerge -1 facter
Password:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-ruby/facter-3.14.4  USE="test -debug" RUBY_TARGETS="ruby24 -ruby25 -ruby26"

Would you like to merge these packages? [Yes/No]
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) dev-ruby/facter-3.14.4::gentoo
>>> Installing (1 of 1) dev-ruby/facter-3.14.4::gentoo

eix boost -Ic
[I] dev-libs/boost (1.65.0(0/1.65.0){xpak}@06/07/2019): Boost Libraries for C++
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-09-19 16:31:36 UTC
Well, they have never passed for me, so I suppose it'd be better if you tested it.
Comment 10 Matt McAdoo 2019-10-12 16:17:40 UTC
The tests fail for me, but does install.
Comment 11 Matt McAdoo 2019-10-12 16:18:53 UTC
Created attachment 592582 [details, diff]
3.14.15 patch
Comment 12 Matt McAdoo 2019-10-12 16:25:53 UTC
Created attachment 592584 [details]
Attaching build log of failed tests

Attaching build log of failed tests.

Ran with this:

ACCEPT_KEYWORDS=~amd64 USE=test FEATURES=test emerge -1a =dev-ruby/facter-3.14.5-r1