Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 692974 - dev-ruby/ferret-0.11.8.7 : index.h:595:25: error: width of is_compressed exceeds its type
Summary: dev-ruby/ferret-0.11.8.7 : index.h:595:25: error: width of is_compressed exce...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-27 18:39 UTC by Toralf Förster
Modified: 2019-12-04 08:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.25 KB, text/plain)
2019-08-27 18:39 UTC, Toralf Förster
Details
dev-ruby:ferret-0.11.8.7:20190827-092127.log (dev-ruby:ferret-0.11.8.7:20190827-092127.log,10.98 KB, text/plain)
2019-08-27 18:39 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,117.79 KB, text/plain)
2019-08-27 18:39 UTC, Toralf Förster
Details
environment (environment,96.51 KB, text/plain)
2019-08-27 18:39 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.65 KB, application/x-bzip)
2019-08-27 18:39 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-08-27 18:39:06 UTC
x86_64-pc-linux-gnu-gcc -I. -I/usr/include/ruby-2.4.0/x86_64-linux -I/usr/include/ruby-2.4.0/ruby/backward -I/usr/include/ruby-2.4.0 -I.   -O2 -pipe -march=native -fPIC -o compound_io.o -c compound_io.c
In file included from compound_io.c:1:
index.h:595:25: error: width of ‘is_compressed’ exceeds its type
  595 |     bool                is_compressed : 2; /* set to 2 after all data is loaded */
      |                         ^~~~~~~~~~~~~
make: *** [Makefile:242: compound_io.o] Error 1

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no-multilib-libressl-20190825-132447

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *




repository timestamp:

==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Tue, 27 Aug 2019 08:48:20 +0000

emerge -qpvO dev-ruby/ferret
[ebuild  N    ] dev-ruby/ferret-0.11.8.7  USE="-doc -test" RUBY_TARGETS="ruby24 ruby25 -ruby26"
Comment 1 Toralf Förster gentoo-dev 2019-08-27 18:39:09 UTC
Created attachment 588336 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-08-27 18:39:12 UTC
Created attachment 588338 [details]
dev-ruby:ferret-0.11.8.7:20190827-092127.log
Comment 3 Toralf Förster gentoo-dev 2019-08-27 18:39:14 UTC
Created attachment 588340 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2019-08-27 18:39:17 UTC
Created attachment 588342 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2019-08-27 18:39:20 UTC
Created attachment 588344 [details]
etc.portage.tbz2
Comment 6 Hans de Graaff gentoo-dev 2019-12-04 08:13:34 UTC
I can't reproduce this with gcc 9.2.0. I have not been able yet to test with glibc 2.30 so I'll leave this open for now.