Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 692932 - Gnome maintained packages stabilization for August 2019
Summary: Gnome maintained packages stabilization for August 2019
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: gnome-3.30-stable
Blocks: gnome-3.32-stable
  Show dependency tree
 
Reported: 2019-08-27 07:32 UTC by Mart Raudsepp
Modified: 2020-01-11 20:21 UTC (History)
2 users (show)

See Also:
Package list:
dev-lang/vala-0.36.20 ia64 dev-lang/vala-0.40.16 ia64 dev-libs/glib-2.60.7 ia64 dev-libs/gobject-introspection-1.60.2 ia64 dev-libs/gobject-introspection-common-1.60.2 ia64 dev-libs/libgee-0.20.2 ia64 dev-libs/libgudev-233-r1 ia64 dev-util/gdbus-codegen-2.60.7 ia64 dev-util/glade-3.22.1 ia64 dev-util/glib-utils-2.60.7 ia64 gnome-base/gvfs-1.40.2 ia64 gnome-extra/libgsf-1.14.45 ia64 media-sound/pulseaudio-13.0 ia64 net-libs/glib-networking-2.60.3 ia64 x11-libs/gtk+-3.24.11 ia64
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mart Raudsepp gentoo-dev 2019-08-27 07:32:34 UTC
Various stabilization of stuff that should be fine with GNOME 3.30 and has been in ~arch long enough. Most notable would be glib-2.60 and co, networkmanager-1.18 and gvfs-1.40
Comment 1 Stabilization helper bot gentoo-dev 2019-08-27 08:15:06 UTC
An automated check of this bug failed - repoman reported dependency errors (95 lines truncated): 

> dependency.bad dev-util/glade/glade-3.22.1.ebuild: DEPEND: arm(default/linux/arm/17.0) ['>=net-libs/webkit-gtk-2.12.0:4']
> dependency.bad dev-util/glade/glade-3.22.1.ebuild: RDEPEND: arm(default/linux/arm/17.0) ['>=net-libs/webkit-gtk-2.12.0:4']
> dependency.bad dev-util/glade/glade-3.22.1.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/17.0) ['>=net-libs/webkit-gtk-2.12.0:4']
Comment 2 Larry the Git Cow gentoo-dev 2019-08-27 09:08:25 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=fe2ee348dbe821b072997639351d46518912fae3

commit fe2ee348dbe821b072997639351d46518912fae3
Author:     Mart Raudsepp <leio@gentoo.org>
AuthorDate: 2019-08-27 09:05:36 +0000
Commit:     Mart Raudsepp <leio@gentoo.org>
CommitDate: 2019-08-27 09:08:06 +0000

    profiles: arm: stable mask dev-util/glade[webkit] in preparation
    
    Bug: https://bugs.gentoo.org/692932
    Signed-off-by: Mart Raudsepp <leio@gentoo.org>

 profiles/arch/arm/package.use.stable.mask | 4 ++++
 1 file changed, 4 insertions(+)
Comment 3 Stabilization helper bot gentoo-dev 2019-08-27 10:14:12 UTC
An automated check of this bug failed - repoman reported dependency errors (31 lines truncated): 

> dependency.bad dev-util/glade/glade-3.22.1.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/17.0) ['>=net-libs/webkit-gtk-2.12.0:4']
> dependency.bad dev-util/glade/glade-3.22.1.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/17.0) ['>=net-libs/webkit-gtk-2.12.0:4']
> dependency.bad dev-util/glade/glade-3.22.1.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/17.0/desktop) ['>=net-libs/webkit-gtk-2.12.0:4']
Comment 4 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-08-31 05:25:33 UTC
amd64 stable
Comment 5 Stabilization helper bot gentoo-dev 2019-08-31 06:11:03 UTC
An automated check of this bug failed - repoman reported dependency errors (31 lines truncated): 

> dependency.bad dev-util/glade/glade-3.22.1.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/17.0) ['>=net-libs/webkit-gtk-2.12.0:4']
> dependency.bad dev-util/glade/glade-3.22.1.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/17.0) ['>=net-libs/webkit-gtk-2.12.0:4']
> dependency.bad dev-util/glade/glade-3.22.1.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/17.0/desktop) ['>=net-libs/webkit-gtk-2.12.0:4']
Comment 6 Larry the Git Cow gentoo-dev 2019-08-31 07:58:46 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=593b5d5beabd40ea1ad16e64df90a28a6ff5dff0

commit 593b5d5beabd40ea1ad16e64df90a28a6ff5dff0
Author:     Mart Raudsepp <leio@gentoo.org>
AuthorDate: 2019-08-31 07:58:09 +0000
Commit:     Mart Raudsepp <leio@gentoo.org>
CommitDate: 2019-08-31 07:58:09 +0000

    profiles: powerpc: stable mask dev-util/glade[webkit] in preparation
    
    Bug: https://bugs.gentoo.org/692932
    Signed-off-by: Mart Raudsepp <leio@gentoo.org>

 profiles/arch/powerpc/package.use.stable.mask | 1 +
 1 file changed, 1 insertion(+)
Comment 7 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-09-01 18:20:26 UTC
arm stable
Comment 8 Agostino Sarubbo gentoo-dev 2019-09-02 07:25:44 UTC
s390 stable
Comment 9 Agostino Sarubbo gentoo-dev 2019-09-02 09:33:12 UTC
ppc64 stable
Comment 10 Agostino Sarubbo gentoo-dev 2019-09-02 10:12:07 UTC
ppc stable
Comment 11 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2019-09-03 00:16:25 UTC
arm64 stable
Comment 12 Thomas Deutschmann gentoo-dev Security 2019-09-08 01:14:23 UTC
x86 stable
Comment 13 Rolf Eike Beer archtester 2019-09-14 15:42:18 UTC
What about bug 682696?
Comment 14 Matt Turner gentoo-dev 2019-09-22 02:39:45 UTC
most of alpha done
Comment 15 Agostino Sarubbo gentoo-dev 2019-10-09 09:29:25 UTC
sparc stable
Comment 16 Matt Turner gentoo-dev 2019-10-13 19:05:35 UTC
(In reply to Matt Turner from comment #14)
> most of alpha done

more of alpha done. just pulseaudio remaining.
Comment 17 Matt Turner gentoo-dev 2019-10-16 23:55:19 UTC
pulseaudio alpha stable

volume-test fails (https://bugs.gentoo.org/682696) as does thread-test (timeout)
Comment 18 Émeric Maschino 2019-11-02 20:41:01 UTC
All packages emerged and passed tests successfully on ia64, but =dev-utils/glib-2.60.6 (bug #699180).
Comment 19 Stabilization helper bot gentoo-dev 2019-11-02 21:00:50 UTC
An automated check of this bug failed - the following atom is unknown:

dev-libs/libgudev-233

Please verify the atom list.
Comment 20 Émeric Maschino 2020-01-05 21:57:53 UTC
Everything now emerge successfully on ia64, including tests.

Bug #699180 fixed for =dev-utils/glib-2.60.7 with upgrade to =sys-devel/binutils-2.32-r2.
Comment 21 Mart Raudsepp gentoo-dev 2020-01-11 20:21:12 UTC
should be all marked from here now, thanks