Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 692420 - dev-java/oracle-jdk-bin: modifies oracle classes and possibly violates license by doing that.
Summary: dev-java/oracle-jdk-bin: modifies oracle classes and possibly violates licens...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-18 07:07 UTC by Georgy Yakovlev
Modified: 2020-09-19 08:06 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Georgy Yakovlev gentoo-dev 2019-08-18 07:07:40 UTC
ebuild modifies jvm

zip -d jre/lib/rt.jar sun/misc/PostVMInitHook.class || die


License[1] clearly states:
"
You may not:

create, modify, or change the behavior of, classes, interfaces, or subpackages that are in any way identified as "java", "javax", "sun", “oracle” or similar convention as specified by Oracle in any naming convention designation.
"

https://www.oracle.com/downloads/licenses/javase-license1.html



this may mean legal trouble.


according to my research this may be no longer required.
previously it was breaking sandbox as jvm was trying to write files outside of sandbox.
Comment 1 Ulrich Müller gentoo-dev 2019-08-18 09:54:24 UTC
I don't think that deleting a class would qualify as "create, modify, or change".


(In reply to Georgy Yakovlev from comment #0)
> https://www.oracle.com/downloads/licenses/javase-license1.html

The ebuild has "Oracle-BCLA-JavaSE" (corresponding to https://www.oracle.com/downloads/licenses/binary-code-license.html). Is that no longer accurate?
Comment 2 Georgy Yakovlev gentoo-dev 2019-08-18 10:47:31 UTC
summary of IRC discussion:

oracle-jdk-1.8 versions <=1.8.0.202 seem still to be under Oracle-BCLA-JavaSE
oracle-jdk-1.8 >=1.8.222 are under new license (we don't have those in tree as of now)

>=oracle-jdk-11 seem to be under new license, but I can't reliably verify.
Comment 3 Georgy Yakovlev gentoo-dev 2019-08-18 10:51:50 UTC
as for class deletion, usage tracker seems to be disabled by default with recent versions, so probably it's better to delete the hack. I could not reproduce sandbox faulures with 1.8.0.202 and class removal line deleted from ebuild.
Comment 4 Larry the Git Cow gentoo-dev 2020-09-19 08:06:58 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6a7faaad2f8c5312dfb8d6e539b5a7346652e98b

commit 6a7faaad2f8c5312dfb8d6e539b5a7346652e98b
Author:     Georgy Yakovlev <gyakovlev@gentoo.org>
AuthorDate: 2020-09-18 22:36:24 +0000
Commit:     Georgy Yakovlev <gyakovlev@gentoo.org>
CommitDate: 2020-09-19 08:05:29 +0000

    dev-java/oracle-jdk-bin: remove last rited pkg
    
    Bug: https://bugs.gentoo.org/732630
    Bug: https://bugs.gentoo.org/717638
    Closes: https://bugs.gentoo.org/575978
    Closes: https://bugs.gentoo.org/686672
    Closes: https://bugs.gentoo.org/684306
    Closes: https://bugs.gentoo.org/692420
    Closes: https://bugs.gentoo.org/684120
    Closes: https://bugs.gentoo.org/681828
    Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
    Closes: https://github.com/gentoo/gentoo/pull/17594
    Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>

 dev-java/oracle-jdk-bin/Manifest                   |  15 --
 .../oracle-jdk-bin/files/fontconfig.properties     | 161 -----------
 .../oracle-jdk-bin/files/oracle-jdk-bin-9.env.sh   |  16 --
 .../oracle-jdk-bin/files/oracle-jdk-bin.env.sh     |  16 --
 dev-java/oracle-jdk-bin/metadata.xml               |  16 --
 .../oracle-jdk-bin/oracle-jdk-bin-1.8.0.202.ebuild | 297 ---------------------
 .../oracle-jdk-bin/oracle-jdk-bin-11.0.2.ebuild    | 247 -----------------
 7 files changed, 768 deletions(-)