Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 692418 (CVE-2019-12730) - media-video/ffmpeg <3.2.14 and <4.1.4 have a vulnerability.
Summary: media-video/ffmpeg <3.2.14 and <4.1.4 have a vulnerability.
Status: CONFIRMED
Alias: CVE-2019-12730
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo Security
URL:
Whiteboard: B3 [glsa? cve]
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-18 07:05 UTC by Teika kazura
Modified: 2019-08-21 17:37 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Teika kazura 2019-08-18 07:05:39 UTC
aa_read_header in libavformat/aadec.c in FFmpeg before 3.2.14 and 4.x before 4.1.4 does not check for sscanf failure and consequently allows use of uninitialized variables.

See e.g. https://security-tracker.debian.org/tracker/CVE-2019-12730, https://nvd.nist.gov/vuln/detail/CVE-2019-12730.

Impact: Critical (cvss v3.0) / high (cvss v2.0)

Best regards.