Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 692 - new -r15.iso freezes when booting (due to empty memorystick-slot)
Summary: new -r15.iso freezes when booting (due to empty memorystick-slot)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Daniel Robbins (RETIRED)
Depends on:
Reported: 2002-02-14 09:50 UTC by Arnold de Bruijn
Modified: 2003-02-04 19:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Arnold de Bruijn 2002-02-14 09:50:35 UTC
This week I tried the new -r15.iso to test the added preliminary PCI device
autodetection and the USB-HID support. 

My laptop (Sony VAIO PCG-Z600TEK, running Gentoo-1.0-rc6-r14) has an internal
memorystick-slot (i.e. a device to put a memorystick/flashcard in). Internally
this memorystick slot is usb-connected and recognised as a scsi (??)

When booting from the new (-r15.iso) CD, all the hardware is correctly
recognised, but when the kernel tries to boot the memorystick it freezes. 
The kernel tries to mount the device (just like any other harddisks) but since
there is no memorystick in the slot, there is nothing to be mounted. That's
where it goes wrong, the kernel freezes.

I had this same problem with -r14, not when booting from cd, but later, on the
first reboot after finishing the base install en compiling the kernel. Then I
solved this problem by adding the following line to my /etc/fstab: 
0 0
which prevents the device from mounting at boot time.

I don't really think this is a bug, but I can't use the new iso for this reason.
Hope this can be fixed on the next iso.
Comment 1 Arnold de Bruijn 2002-02-16 09:30:18 UTC
Don't know what I did wrong, but when I tried to boot with the -r15.iso cd again
it didn't freeze: However, dmesg gives an error about missing an active driver
for my memorystick-slot. 

usb.c: USB device 4 (vend/prod 0x54c/0x32) is not claimed by any active driver.

I assume that it was me that made some mistake, apparantly this bug doesn't even
exist! :) 

Apologies for that. 

Arnold de Bruijn