Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 69090 - ez-ipupdate 3322.net patch
Summary: ez-ipupdate 3322.net patch
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Stefan Briesenick (RETIRED)
URL: http://www.magiclinux.org
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-26 19:54 UTC by Jackey Yang ("timeout" in forum)
Modified: 2006-06-24 04:41 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
3322.diff (3322.diff,1.84 KB, patch)
2004-10-26 19:54 UTC, Jackey Yang ("timeout" in forum)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jackey Yang ("timeout" in forum) 2004-10-26 19:54:14 UTC
a patch for www.3322.net

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Jackey Yang ("timeout" in forum) 2004-10-26 19:54:44 UTC
Created attachment 42656 [details, diff]
3322.diff

patch for www.3322.net
Comment 2 Jackey Yang ("timeout" in forum) 2004-10-26 19:55:23 UTC
Following Script is a fix for people using NAT, since ez-ipupdate do not like ddclient support web interface. 

#!/bin/sh 
 # Copyright 1999-2004 Gentoo Technologies, Inc. 
 # Distributed under the terms of the GNU General Public License v2 
 
 INTERFACE=eth0 
 INTERNAL_IP=`/sbin/ifconfig $INTERFACE | grep inet | cut -d ":" -f 2 | cut -d " " -f 1` 
 EXTERNAL_IP=`lynx -source www.whatismyip.org` 
 CONFIG=/etc/ez-ipupdate/dyndns.conf 
 
 if [ ! -e /tmp/ez-ipupdate.cache ] ; then 
         echo "$CONFIG does not exist" 
 else 
         if [ ! -e /tmp/ez-ipupdate.cache ] ; then 
                 rm /tmp/ez-ipupdate.cache 
         fi 
 
         if [ $INTERNAL_IP != $EXTERNAL_IP ] ; then 
                 /usr/bin/ez-ipupdate -a $EXTERNAL_IP -c $CONFIG 
         else 
                 /usr/bin/ez-ipupdate -c $CONFIG 
         fi 
 fi 
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2005-08-23 11:02:28 UTC
Re-assign, this package needs a maintainer.
Comment 4 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2006-06-21 22:09:17 UTC
(In reply to comment #3)
> Re-assign, this package needs a maintainer.
> 

<pkgmetadata>
        <herd>no-herd</herd>
        <maintainer>
                <email>sbriesen@gentoo.org</email>
                <name>Stefan Briesenick</name>
        </maintainer>
Comment 5 Stefan Briesenick (RETIRED) gentoo-dev 2006-06-24 04:41:41 UTC
in CVS as ez-ipupdate-3.0.11_beta8-r4.