Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 690700 - >=dev-python/docker-py-3.6.0 needs >=dev-python/paramiko-2.4.2 but depends on plain dev-python/paramiko
Summary: >=dev-python/docker-py-3.6.0 needs >=dev-python/paramiko-2.4.2 but depends on...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Manuel Rüger
Depends on:
Reported: 2019-07-25 16:52 UTC by Domonkos Lezsák
Modified: 2019-08-04 14:31 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Trace of docker-compose up -d (file_690700.txt,1.78 KB, text/plain)
2019-07-25 16:52 UTC, Domonkos Lezsák

Note You need to log in before you can comment on or make changes to this bug.
Description Domonkos Lezsák 2019-07-25 16:52:42 UTC
Created attachment 584476 [details]
Trace of docker-compose up -d

I've upgraded docker-compose from 1.19 to 1.24.0, but I had to upgrade manually dev-python/paramiko from 2.4.1 to 2.4.1 else docker-compose up -d resulted in a dependency conflict error.
Comment 1 Sebastian Pipping gentoo-dev 2019-08-04 14:31:31 UTC
As far as I can see from the log this is an issue with dev-python/docker-py which needs paramiko >=2.4.2 from 3.6.0 on but depends on plain "dev-python/paramiko[${PYTHON_USEDEP}]" which is a problem with your old 2.4.1 around but sort-of-correct if one pulls the card that only in-tree dependencies are considered and supported.  So we have two options in my view:

 a) Encode >=2.4.2 in the dependencies of dev-python/docker-py

 b) Consider this case as unsupported as it affects outdated systems, only.

I'd be good with either, handing over to the maintainer of dev-python/docker-py for now.