Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 690330 - app-admin/apachetop-0.18.4 : /.../ld: apachetop.o: undefined reference to symbol keypad
Summary: app-admin/apachetop-0.18.4 : /.../ld: apachetop.o: undefined reference to sym...
Status: RESOLVED DUPLICATE of bug 690082
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Oleksandr Trotsenko
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-21 08:53 UTC by Toralf Förster
Modified: 2019-07-31 13:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.69 KB, text/plain)
2019-07-21 08:53 UTC, Toralf Förster
Details
app-admin:apachetop-0.18.4:20190721-024459.log (app-admin:apachetop-0.18.4:20190721-024459.log,9.70 KB, text/plain)
2019-07-21 08:53 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,230.52 KB, text/plain)
2019-07-21 08:53 UTC, Toralf Förster
Details
environment (environment,58.24 KB, text/plain)
2019-07-21 08:53 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,19.47 KB, application/x-bzip)
2019-07-21 08:53 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,7.50 KB, application/x-bzip)
2019-07-21 08:53 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,17.84 KB, application/x-bzip)
2019-07-21 08:53 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-07-21 08:53:20 UTC
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I..   -I yes/include -I no/include -I no/include  -O2 -pipe -march=native -c -o resolver.o resolver.cc
x86_64-pc-linux-gnu-g++  -O2 -pipe -march=native  -Wl,-O1 -Wl,--as-needed -L yes/lib -L no/lib -L no/lib -o apachetop apachetop.o log.o inlines.o ohtbl.o map.o queue.o display.o hits_circle.o timed_circle.o filters.o resolver.o  -lreadline -lncurses -lfam -lpcre 
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: apachetop.o: undefined reference to symbol 'keypad'
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: /lib64/libtinfo.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:348: apachetop] Error 1

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-libressl-20190716-151745

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.36.0 *



emerge -qpvO app-admin/apachetop
[ebuild  N    ] app-admin/apachetop-0.18.4  USE="pcre -fam"
Comment 1 Toralf Förster gentoo-dev 2019-07-21 08:53:22 UTC
Created attachment 583828 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-07-21 08:53:25 UTC
Created attachment 583830 [details]
app-admin:apachetop-0.18.4:20190721-024459.log
Comment 3 Toralf Förster gentoo-dev 2019-07-21 08:53:28 UTC
Created attachment 583832 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2019-07-21 08:53:30 UTC
Created attachment 583834 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2019-07-21 08:53:33 UTC
Created attachment 583836 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-07-21 08:53:36 UTC
Created attachment 583838 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2019-07-21 08:53:38 UTC
Created attachment 583840 [details]
temp.tbz2
Comment 8 Lars Wendler (Polynomial-C) gentoo-dev 2019-07-31 13:17:29 UTC

*** This bug has been marked as a duplicate of bug 690082 ***