Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 690238 - sys-apps/conspy-1.10 : /.../ld: conspy.o: undefined reference to symbol putp
Summary: sys-apps/conspy-1.10 : /.../ld: conspy.o: undefined reference to symbol putp
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
: 693334 699008 (view as bug list)
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2019-07-19 18:11 UTC by Toralf Förster
Modified: 2019-10-31 10:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,17.85 KB, text/plain)
2019-07-19 18:11 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,197.71 KB, text/plain)
2019-07-19 18:11 UTC, Toralf Förster
Details
environment (environment,90.70 KB, text/plain)
2019-07-19 18:11 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.17 KB, application/x-bzip)
2019-07-19 18:11 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,4.79 KB, application/x-bzip)
2019-07-19 18:11 UTC, Toralf Förster
Details
sys-apps:conspy-1.10:20190719-172551.log (sys-apps:conspy-1.10:20190719-172551.log,6.18 KB, text/plain)
2019-07-19 18:11 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,23.54 KB, application/x-bzip)
2019-07-19 18:11 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-07-19 18:11:38 UTC
x86_64-pc-linux-gnu-gcc  -O2 -pipe -march=native  -Wl,-O1 -Wl,--as-needed -o conspy conspy.o  -lncurses 
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: conspy.o: undefined reference to symbol 'putp'
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: /lib64/libtinfo.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make: *** [Makefile:387: conspy] Error 1

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_gnome-libressl_abi32+64-20190714-070131

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.36.0 *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.12.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpvO sys-apps/conspy
[ebuild  N    ] sys-apps/conspy-1.10
Comment 1 Toralf Förster gentoo-dev 2019-07-19 18:11:41 UTC
Created attachment 583664 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-07-19 18:11:44 UTC
Created attachment 583666 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2019-07-19 18:11:46 UTC
Created attachment 583668 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2019-07-19 18:11:49 UTC
Created attachment 583670 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-07-19 18:11:51 UTC
Created attachment 583672 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-07-19 18:11:54 UTC
Created attachment 583674 [details]
sys-apps:conspy-1.10:20190719-172551.log
Comment 7 Toralf Förster gentoo-dev 2019-07-19 18:11:57 UTC
Created attachment 583676 [details]
temp.tbz2
Comment 8 Jeroen Roovers gentoo-dev 2019-10-31 10:34:56 UTC
*** Bug 699008 has been marked as a duplicate of this bug. ***
Comment 9 Jeroen Roovers gentoo-dev 2019-10-31 10:35:13 UTC
*** Bug 693334 has been marked as a duplicate of this bug. ***
Comment 10 Larry the Git Cow gentoo-dev 2019-10-31 10:38:08 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b4fd1e856700840d04a0ce75d6d339bac4f6391e

commit b4fd1e856700840d04a0ce75d6d339bac4f6391e
Author:     Jeroen Roovers <jer@gentoo.org>
AuthorDate: 2019-10-31 10:37:40 +0000
Commit:     Jeroen Roovers <jer@gentoo.org>
CommitDate: 2019-10-31 10:38:04 +0000

    sys-apps/conspy: Version 1.14
    
    Package-Manager: Portage-2.3.78, Repoman-2.3.17
    Fixes: https://bugs.gentoo.org/690238
    Signed-off-by: Jeroen Roovers <jer@gentoo.org>

 sys-apps/conspy/Manifest                      |  1 +
 sys-apps/conspy/conspy-1.14.ebuild            | 35 +++++++++++++++++++++++++++
 sys-apps/conspy/files/conspy-1.14-tinfo.patch | 10 ++++++++
 3 files changed, 46 insertions(+)