Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 690224 - net-news/snownews-1.6.10 : /.../ld: .o/ui-support.o: undefined reference to symbol keypad
Summary: net-news/snownews-1.6.10 : /.../ld: .o/ui-support.o: undefined reference to s...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Frederic Culot
URL:
Whiteboard:
Keywords: PATCH
: 691884 (view as bug list)
Depends on:
Blocks: tinfo 689870
  Show dependency tree
 
Reported: 2019-07-19 16:00 UTC by Toralf Förster
Modified: 2019-09-16 18:10 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.02 KB, text/plain)
2019-07-19 16:00 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,199.28 KB, text/plain)
2019-07-19 16:00 UTC, Toralf Förster
Details
environment (environment,61.16 KB, text/plain)
2019-07-19 16:00 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.49 KB, application/x-bzip)
2019-07-19 16:00 UTC, Toralf Förster
Details
net-news:snownews-1.6.10:20190719-012937.log (net-news:snownews-1.6.10:20190719-012937.log,4.16 KB, text/plain)
2019-07-19 16:00 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,16.86 KB, application/x-bzip)
2019-07-19 16:00 UTC, Toralf Förster
Details
snownews-1.6.10-tinfo-strip.patch (snownews-1.6.10-tinfo-strip.patch,1.19 KB, patch)
2019-09-13 07:25 UTC, Jeroen Roovers
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-07-19 16:00:41 UTC
    Compiling about.c ...
Linking .o/snownews ...
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: .o/ui-support.o: undefined reference to symbol 'keypad'
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: /lib64/libtinfo.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make: *** [Makefile:23: .o/snownews] Error 1

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no-multilib_hardened-20190715-113836

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.36.0 *



emerge -qpvO net-news/snownews
[ebuild  N    ] net-news/snownews-1.6.10  USE="unicode"
Comment 1 Toralf Förster gentoo-dev 2019-07-19 16:00:44 UTC
Created attachment 583590 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-07-19 16:00:48 UTC
Created attachment 583592 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2019-07-19 16:00:51 UTC
Created attachment 583594 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2019-07-19 16:00:53 UTC
Created attachment 583596 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-07-19 16:00:56 UTC
Created attachment 583598 [details]
net-news:snownews-1.6.10:20190719-012937.log
Comment 6 Toralf Förster gentoo-dev 2019-07-19 16:00:59 UTC
Created attachment 583600 [details]
temp.tbz2
Comment 7 Pacho Ramos gentoo-dev 2019-09-05 12:53:41 UTC
*** Bug 691884 has been marked as a duplicate of this bug. ***
Comment 8 Thomas Deutschmann gentoo-dev Security 2019-09-07 17:48:41 UTC
Same for x86.
Comment 9 Jeroen Roovers gentoo-dev 2019-09-08 06:52:00 UTC
I was quite sure I fixed this already.
Comment 10 Jeroen Roovers gentoo-dev 2019-09-13 07:25:02 UTC
Created attachment 589756 [details, diff]
snownews-1.6.10-tinfo-strip.patch
Comment 11 ernsteiswuerfel 2019-09-14 20:47:28 UTC
Happens also on ppc.

And snownews-1.6.10-tinfo-strip.patch fixes the problem.
Comment 12 Hans de Graaff gentoo-dev 2019-09-16 18:07:09 UTC
As far as I can tell the unicode support is now required and linking against tinfo always fails. Linking against tinfow on the other hand works as expected. I've dropped the unicode USE flag and fixed the PKG_CONFIG similar to what jer was doing in his patch. snownews-1.6.10 now compiles for me.

Fixed in place for 1.6.10 since this is a compile time fix.
Comment 13 Larry the Git Cow gentoo-dev 2019-09-16 18:10:02 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=13d728bc761b9c0350b7ccb32372e2234bb5a824

commit 13d728bc761b9c0350b7ccb32372e2234bb5a824
Author:     Hans de Graaff <graaff@gentoo.org>
AuthorDate: 2019-09-16 18:08:58 +0000
Commit:     Hans de Graaff <graaff@gentoo.org>
CommitDate: 2019-09-16 18:09:36 +0000

    net-news/snownews: fix compilation with ncurses
    
    This package now requires unicode support for ncurses,
    otherwise compilation will fails. Fix the pkgconfig handling,
    drop the unicode USE flag and always require unicode support.
    
    Fixes: https://bugs.gentoo.org/690224
    Package-Manager: Portage-2.3.69, Repoman-2.3.16
    Signed-off-by: Hans de Graaff <graaff@gentoo.org>

 net-news/snownews/snownews-1.6.10.ebuild | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)