Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 690082 - app-admin/apachetop-0.18.4 : /.../ld: apachetop.o: undefined reference to symbol nodelay
Summary: app-admin/apachetop-0.18.4 : /.../ld: apachetop.o: undefined reference to sym...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Oleksandr Trotsenko
URL:
Whiteboard:
Keywords:
: 690330 (view as bug list)
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2019-07-17 16:53 UTC by Toralf Förster
Modified: 2020-01-14 03:24 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,17.17 KB, text/plain)
2019-07-17 16:53 UTC, Toralf Förster
Details
app-admin:apachetop-0.18.4:20190717-120333.log (app-admin:apachetop-0.18.4:20190717-120333.log,9.77 KB, text/plain)
2019-07-17 16:53 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,216.32 KB, text/plain)
2019-07-17 16:53 UTC, Toralf Förster
Details
environment (environment,57.92 KB, text/plain)
2019-07-17 16:53 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,36.97 KB, application/x-bzip)
2019-07-17 16:53 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,7.52 KB, application/x-bzip)
2019-07-17 16:53 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,17.62 KB, application/x-bzip)
2019-07-17 16:53 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-07-17 16:53:16 UTC
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I..   -I yes/include -I yes/include -I no/include  -O2 -pipe -march=native -c -o resolver.o resolver.cc
x86_64-pc-linux-gnu-g++  -O2 -pipe -march=native  -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0 -L yes/lib -L yes/lib -L no/lib -o apachetop apachetop.o log.o inlines.o ohtbl.o map.o queue.o display.o hits_circle.o timed_circle.o filters.o resolver.o  -lreadline -lncurses -lfam -lpcre 
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: apachetop.o: undefined reference to symbol 'nodelay'
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: /lib64/libtinfo.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:348: apachetop] Error 1

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_developer-libressl-20190712-131800

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.36.0 *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.12.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpvO app-admin/apachetop
[ebuild  N    ] app-admin/apachetop-0.18.4  USE="fam pcre"
Comment 1 Toralf Förster gentoo-dev 2019-07-17 16:53:19 UTC
Created attachment 583248 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-07-17 16:53:22 UTC
Created attachment 583250 [details]
app-admin:apachetop-0.18.4:20190717-120333.log
Comment 3 Toralf Förster gentoo-dev 2019-07-17 16:53:24 UTC
Created attachment 583252 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2019-07-17 16:53:27 UTC
Created attachment 583254 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2019-07-17 16:53:30 UTC
Created attachment 583256 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-07-17 16:53:33 UTC
Created attachment 583258 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2019-07-17 16:53:36 UTC
Created attachment 583260 [details]
temp.tbz2
Comment 8 Lars Wendler (Polynomial-C) gentoo-dev 2019-07-20 09:09:33 UTC
apachetop-0.19.7 has been released containing a fix for this issue.
Comment 9 Lars Wendler (Polynomial-C) gentoo-dev 2019-07-31 13:17:29 UTC
*** Bug 690330 has been marked as a duplicate of this bug. ***
Comment 10 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-10-04 11:30:50 UTC
Ping.
Comment 11 Larry the Git Cow gentoo-dev 2020-01-14 02:43:21 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=73e2822bb656b80e296a1a2c18259a2988939f48

commit 73e2822bb656b80e296a1a2c18259a2988939f48
Author:     Jeroen Roovers <jer@gentoo.org>
AuthorDate: 2020-01-14 02:20:53 +0000
Commit:     Jeroen Roovers <jer@gentoo.org>
CommitDate: 2020-01-14 02:43:17 +0000

    app-admin/apachetop: Fix building against sys-libs/ncurses[tinfo]
    
    Package-Manager: Portage-2.3.84, Repoman-2.3.20
    Closes: https://bugs.gentoo.org/690082
    Signed-off-by: Jeroen Roovers <jer@gentoo.org>

 app-admin/apachetop/apachetop-0.18.4.ebuild            |  8 +++++---
 app-admin/apachetop/files/apachetop-0.18.4-tinfo.patch | 11 +++++++++++
 2 files changed, 16 insertions(+), 3 deletions(-)

Additionally, it has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=43556fcd77fcb72201aa762971203af560a7e899

commit 43556fcd77fcb72201aa762971203af560a7e899
Author:     Jeroen Roovers <jer@gentoo.org>
AuthorDate: 2020-01-14 02:25:46 +0000
Commit:     Jeroen Roovers <jer@gentoo.org>
CommitDate: 2020-01-14 02:43:17 +0000

    app-admin/apachetop: Version 0.19.7
    
    Uses pkg-config to find libncurses/libtinfo
    
    Package-Manager: Portage-2.3.84, Repoman-2.3.20
    Bug: https://bugs.gentoo.org/690082
    Signed-off-by: Jeroen Roovers <jer@gentoo.org>

 app-admin/apachetop/Manifest                |  1 +
 app-admin/apachetop/apachetop-0.19.7.ebuild | 29 +++++++++++++++++++++++++++++
 2 files changed, 30 insertions(+)
Comment 12 Jeroen Roovers gentoo-dev 2020-01-14 03:24:46 UTC
Note that this was already fixed once:

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=da532d475a2b5bcca6eed2dedcd4758fd535054f

commit da532d475a2b5bcca6eed2dedcd4758fd535054f
Author: David Seifert <soap@gentoo.org>
Date:   Fri Dec 29 20:50:09 2017 +0100

    app-admin/apachetop: Port to EAPI 6

    Package-Manager: Portage-2.3.19, Repoman-2.3.6


The tinfo related changes were not ported to later release versions upstream or downstream until 0.19.7.