Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 690080 - games-puzzle/galaxis-1.8-r1 : /.../ld: /.../ccQvc8e9.o: undefined reference to symbol keypad
Summary: games-puzzle/galaxis-1.8-r1 : /.../ld: /.../ccQvc8e9.o: undefined reference t...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
: 690086 (view as bug list)
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2019-07-17 16:52 UTC by Toralf Förster
Modified: 2019-07-18 12:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,14.77 KB, text/plain)
2019-07-17 16:52 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,102.52 KB, text/plain)
2019-07-17 16:53 UTC, Toralf Förster
Details
environment (environment,14.57 KB, text/plain)
2019-07-17 16:53 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.08 KB, application/x-bzip)
2019-07-17 16:53 UTC, Toralf Förster
Details
games-puzzle:galaxis-1.8-r1:20190717-054823.log (games-puzzle:galaxis-1.8-r1:20190717-054823.log,2.32 KB, text/plain)
2019-07-17 16:53 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,5.69 KB, application/x-bzip)
2019-07-17 16:53 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-07-17 16:52:54 UTC
      |             ^~~~~~~~~
galaxis.c:516:13: warning: type of ‘curx’ defaults to ‘int’ [-Wimplicit-int]
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: /var/tmp/portage/games-puzzle/galaxis-1.8-r1/temp/ccQvc8e9.o: undefined reference to symbol 'keypad'
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: /lib64/libtinfo.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make: *** [Makefile:15: galaxis] Error 1

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no-multilib_hardened-20190715-113836

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.36.0 *



emerge -qpvO games-puzzle/galaxis
[ebuild  N    ] games-puzzle/galaxis-1.8-r1
Comment 1 Toralf Förster gentoo-dev 2019-07-17 16:52:57 UTC
Created attachment 583236 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-07-17 16:53:00 UTC
Created attachment 583238 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2019-07-17 16:53:03 UTC
Created attachment 583240 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2019-07-17 16:53:05 UTC
Created attachment 583242 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-07-17 16:53:08 UTC
Created attachment 583244 [details]
games-puzzle:galaxis-1.8-r1:20190717-054823.log
Comment 6 Toralf Förster gentoo-dev 2019-07-17 16:53:11 UTC
Created attachment 583246 [details]
temp.tbz2
Comment 7 Lars Wendler (Polynomial-C) gentoo-dev 2019-07-17 20:24:37 UTC
*** Bug 690086 has been marked as a duplicate of this bug. ***
Comment 8 Larry the Git Cow gentoo-dev 2019-07-18 12:47:15 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=46955a32bc067d9550a3389271963e0a92b628c8

commit 46955a32bc067d9550a3389271963e0a92b628c8
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2019-07-18 12:47:01 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2019-07-18 12:47:01 +0000

    games-puzzle/galaxis: Fixed build with sys-libs/ncurses[tinfo]
    
    Closes: https://bugs.gentoo.org/690080
    Package-Manager: Portage-2.3.69, Repoman-2.3.16
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

 games-puzzle/galaxis/galaxis-1.8-r1.ebuild | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)