Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 690000 - net-analyzer/squidview-0.80 : /.../ld: squidview.o: undefined reference to symbol keypad
Summary: net-analyzer/squidview-0.80 : /.../ld: squidview.o: undefined reference to sy...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
: 701420 (view as bug list)
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2019-07-16 16:28 UTC by Toralf Förster
Modified: 2019-11-28 19:44 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,14.74 KB, text/plain)
2019-07-16 16:28 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,113.87 KB, text/plain)
2019-07-16 16:28 UTC, Toralf Förster
Details
environment (environment,8.50 KB, text/plain)
2019-07-16 16:29 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.55 KB, application/x-bzip)
2019-07-16 16:29 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,7.29 KB, application/x-bzip)
2019-07-16 16:29 UTC, Toralf Förster
Details
net-analyzer:squidview-0.80:20190716-161725.log (net-analyzer:squidview-0.80:20190716-161725.log,4.78 KB, text/plain)
2019-07-16 16:29 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,4.56 KB, application/x-bzip)
2019-07-16 16:29 UTC, Toralf Förster
Details
ltinfo-obs.patch (ltinfo-obs.patch,346 bytes, patch)
2019-11-13 07:41 UTC, Marco Genasci
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-07-16 16:28:53 UTC
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I.  -DSHAREDIR='"/usr/share/squidview"' -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE   -O2 -pipe -march=native -c -o squidview.o squidview.cpp
x86_64-pc-linux-gnu-g++  -O2 -pipe -march=native  -Wl,-O1 -Wl,--as-needed -o squidview squidview.o  -lncurses 
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: squidview.o: undefined reference to symbol 'keypad'
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: /lib64/libtinfo.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:335: squidview] Error 1

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_systemd-libressl-20190714-193026

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems) *




emerge -qpvO net-analyzer/squidview
[ebuild  N    ] net-analyzer/squidview-0.80
Comment 1 Toralf Förster gentoo-dev 2019-07-16 16:28:56 UTC
Created attachment 583090 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-07-16 16:28:59 UTC
Created attachment 583092 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2019-07-16 16:29:01 UTC
Created attachment 583094 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2019-07-16 16:29:04 UTC
Created attachment 583096 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-07-16 16:29:07 UTC
Created attachment 583098 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-07-16 16:29:09 UTC
Created attachment 583100 [details]
net-analyzer:squidview-0.80:20190716-161725.log
Comment 7 Toralf Förster gentoo-dev 2019-07-16 16:29:12 UTC
Created attachment 583102 [details]
temp.tbz2
Comment 8 Marco Genasci 2019-11-13 07:41:13 UTC
Created attachment 595942 [details, diff]
ltinfo-obs.patch

This patch seems to solve problem
Comment 9 Jeroen Roovers gentoo-dev 2019-11-28 19:16:15 UTC
*** Bug 701420 has been marked as a duplicate of this bug. ***
Comment 10 Larry the Git Cow gentoo-dev 2019-11-28 19:44:32 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5382eaa24f527ff13f2f02d6ccdd0fb8314e9929

commit 5382eaa24f527ff13f2f02d6ccdd0fb8314e9929
Author:     Jeroen Roovers <jer@gentoo.org>
AuthorDate: 2019-11-28 19:42:49 +0000
Commit:     Jeroen Roovers <jer@gentoo.org>
CommitDate: 2019-11-28 19:44:27 +0000

    net-analyzer/squidview: Version 0.86
    
    Package-Manager: Portage-2.3.80, Repoman-2.3.19
    Fixes: https://bugs.gentoo.org/690000
    Signed-off-by: Jeroen Roovers <jer@gentoo.org>

 net-analyzer/squidview/Manifest                    |  1 +
 .../squidview/files/squidview-0.86-tinfo.patch     | 43 ++++++++++++++++++++++
 net-analyzer/squidview/squidview-0.86.ebuild       | 32 ++++++++++++++++
 3 files changed, 76 insertions(+)