Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 689932 - dev-python/pycurl-7.43.0 should depend explicitly on dev-libs/openssl:=
Summary: dev-python/pycurl-7.43.0 should depend explicitly on dev-libs/openssl:=
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-15 19:15 UTC by Daniel M. Weeks
Modified: 2019-07-16 06:00 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel M. Weeks 2019-07-15 19:15:04 UTC
>>> package: dev-libs/openssl-1.1.0k
 *  - /usr/lib64/libcrypto.so.1.0.0
 *      used by /usr/lib64/python3.6/site-packages/pycurl.cpython-36m-x86_64-linux-gnu.so (dev-python/pycurl-7.43.0)

It seems that the openssl dependency for pycurl is implied through net-misc/curl based on its use flags. However, pycurl has an explicit linking and should directly depend on dev-libs/openssl:=.

Reproducible: Always