Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 689928 - =dev-games/openscenegraph-3.6.3: automagic dependency on sci-libs/dcmtk
Summary: =dev-games/openscenegraph-3.6.3: automagic dependency on sci-libs/dcmtk
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Maciej Mrozowski
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-15 18:30 UTC by Bernd
Modified: 2019-07-16 05:59 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,13.44 KB, text/plain)
2019-07-15 18:30 UTC, Bernd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd 2019-07-15 18:30:21 UTC
Created attachment 582936 [details]
emerge-info.txt

After sci-libs/dcmtk has been removed by an emerge --depclean I have preserved libs for the packages dev-games/openscenegraph and media-libs/openimageio:

!!! existing preserved libs:
>>> package: sci-libs/dcmtk-3.6.3
 *  - /usr/lib64/liboflog.so.13
 *  - /usr/lib64/liboflog.so.3.6.3
 *      used by /usr/lib64/libOpenImageIO.so.1.8.17 (media-libs/openimageio-1.8.17)
 *  - /usr/lib64/libdcmimage.so.13
 *  - /usr/lib64/libdcmimage.so.3.6.3
 *      used by /usr/lib64/libOpenImageIO.so.1.8.17 (media-libs/openimageio-1.8.17)
 *      used by /usr/lib64/osgPlugins-3.6.3/osgdb_dicom.so (dev-games/openscenegraph-3.6.3)
 *  - /usr/lib64/libdcmimgle.so.13
 *  - /usr/lib64/libdcmimgle.so.3.6.3
 *      used by /usr/lib64/libOpenImageIO.so.1.8.17 (media-libs/openimageio-1.8.17)
 *      used by /usr/lib64/osgPlugins-3.6.3/osgdb_dicom.so (dev-games/openscenegraph-3.6.3)
 *  - /usr/lib64/libdcmdata.so.13
 *  - /usr/lib64/libdcmdata.so.3.6.3
 *      used by /usr/lib64/libOpenImageIO.so.1.8.17 (media-libs/openimageio-1.8.17)
 *      used by /usr/lib64/osgPlugins-3.6.3/osgdb_dicom.so (dev-games/openscenegraph-3.6.3)
 *  - /usr/lib64/libofstd.so.13
 *  - /usr/lib64/libofstd.so.3.6.3
 *      used by /usr/lib64/libOpenImageIO.so.1.8.17 (media-libs/openimageio-1.8.17)
 *      used by /usr/lib64/osgPlugins-3.6.3/osgdb_dicom.so (dev-games/openscenegraph-3.6.3)

The package has no explicit dependency defined on sci-libs/dcmtk, so I'm assuming there's an automagic dep which got detected while the packages was still installed.