Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 688912 (kde-apps-19.04.3) - KDE Applications 19.04.3 stabilisation
Summary: KDE Applications 19.04.3 stabilisation
Status: RESOLVED FIXED
Alias: kde-apps-19.04.3
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard: scheduled for 2019-07-28
Keywords: STABLEREQ
Depends on: 688920 688938 frameworks-5.60-stable
Blocks: CVE-2019-10732 689156 CVE-2018-20097, CVE-2019-13114, CVE-2019-13504
  Show dependency tree
 
Reported: 2019-06-29 07:47 UTC by Andreas Sturmlechner
Modified: 2019-07-29 18:44 UTC (History)
2 users (show)

See Also:
Package list:
kde-apps/akonadi-19.04.3-r1 kde-apps/akonadi-calendar-19.04.3 kde-apps/akonadiconsole-19.04.3 kde-apps/akonadi-contacts-19.04.3 kde-apps/akonadi-import-wizard-19.04.3 kde-apps/akonadi-mime-19.04.3 kde-apps/akonadi-notes-19.04.3 kde-apps/akonadi-search-19.04.3 kde-apps/akregator-19.04.3 kde-apps/analitza-19.04.3 kde-apps/ark-19.04.3 kde-apps/artikulate-19.04.3 kde-apps/audiocd-kio-19.04.3 kde-apps/baloo-widgets-19.04.3 kde-apps/blinken-19.04.3 kde-apps/bomber-19.04.3 kde-apps/bovo-19.04.3 kde-apps/calendarjanitor-19.04.3 kde-apps/calendarsupport-19.04.3 kde-apps/cantor-19.04.3 kde-apps/cervisia-19.04.3 kde-apps/dolphin-19.04.3 kde-apps/dolphin-plugins-bazaar-19.04.3 kde-apps/dolphin-plugins-dropbox-19.04.3 kde-apps/dolphin-plugins-git-19.04.3 kde-apps/dolphin-plugins-mercurial-19.04.3 kde-apps/dolphin-plugins-subversion-19.04.3 kde-apps/dragon-19.04.3 kde-apps/eventviews-19.04.3 kde-apps/ffmpegthumbs-19.04.3 kde-apps/filelight-19.04.3 kde-apps/granatier-19.04.3 kde-apps/grantlee-editor-19.04.3 kde-apps/grantleetheme-19.04.3 kde-apps/gwenview-19.04.3 kde-apps/incidenceeditor-19.04.3 kde-apps/juk-19.04.3 kde-apps/k3b-19.04.3 kde-apps/kaccounts-integration-19.04.3 kde-apps/kaccounts-providers-19.04.3 kde-apps/kaddressbook-19.04.3 kde-apps/kajongg-19.04.3 kde-apps/kalarm-19.04.3 kde-apps/kalarmcal-19.04.3 kde-apps/kalgebra-19.04.3 kde-apps/kalzium-19.04.3 kde-apps/kamera-19.04.3 kde-apps/kamoso-19.04.3 kde-apps/kanagram-19.04.3 kde-apps/kapman-19.04.3 kde-apps/kapptemplate-19.04.3 kde-apps/kate-19.04.3 kde-apps/katomic-19.04.3 kde-apps/kbackup-19.04.3 kde-apps/kblackbox-19.04.3 kde-apps/kblocks-19.04.3 kde-apps/kblog-19.04.3 kde-apps/kbounce-19.04.3 kde-apps/kbreakout-19.04.3 kde-apps/kbruch-19.04.3 kde-apps/kcachegrind-19.04.3 kde-apps/kcalc-19.04.3 kde-apps/kcalcore-19.04.3 kde-apps/kcalutils-19.04.3 kde-apps/kcharselect-19.04.3 kde-apps/kcolorchooser-19.04.3 kde-apps/kcontacts-19.04.3 kde-apps/kcron-19.04.3 kde-apps/kdav-19.04.3 kde-apps/kdeaccessibility-meta-19.04.3 kde-apps/kdeadmin-meta-19.04.3 kde-apps/kde-apps-meta-19.04.3 kde-apps/kdebase-meta-19.04.3 kde-apps/kdebugsettings-19.04.3 kde-apps/kdecore-meta-19.04.3 kde-apps/kde-dev-scripts-19.04.3 kde-apps/kde-dev-utils-19.04.3 kde-apps/kdeedu-data-19.04.3 kde-apps/kdeedu-meta-19.04.3 kde-apps/kdegames-meta-19.04.3 kde-apps/kdegraphics-meta-19.04.3 kde-apps/kdegraphics-mobipocket-19.04.3 kde-apps/kde-meta-19.04.3 kde-apps/kdemultimedia-meta-19.04.3 kde-apps/kdenetwork-filesharing-19.04.3 kde-apps/kdenetwork-meta-19.04.3 kde-apps/kdenlive-19.04.3 kde-apps/kdepim-addons-19.04.3 kde-apps/kdepim-apps-libs-19.04.3 kde-apps/kdepim-meta-19.04.3 kde-apps/kdepim-runtime-19.04.3 kde-apps/kdesdk-kioslaves-19.04.3 kde-apps/kdesdk-meta-19.04.3 kde-apps/kdesdk-thumbnailers-19.04.3 kde-apps/kdeutils-meta-19.04.3 kde-apps/kdf-19.04.3 kde-apps/kdialog-19.04.3 kde-apps/kdiamond-19.04.3 kde-apps/keditbookmarks-19.04.3 kde-apps/kfind-19.04.3 kde-apps/kfloppy-19.04.3 kde-apps/kfourinline-19.04.3 kde-apps/kgeography-19.04.3 kde-apps/kget-19.04.3 kde-apps/kgoldrunner-19.04.3 kde-apps/kgpg-19.04.3 kde-apps/khangman-19.04.3 kde-apps/khelpcenter-19.04.3 kde-apps/kidentitymanagement-19.04.3 kde-apps/kig-19.04.3 kde-apps/kigo-19.04.3 kde-apps/killbots-19.04.3 kde-apps/kimagemapeditor-19.04.3 kde-apps/kimap-19.04.3 kde-apps/kio-extras-19.04.3 kde-apps/kiriki-19.04.3 kde-apps/kiten-19.04.3 kde-apps/kitinerary-19.04.3 kde-apps/kjumpingcube-19.04.3 kde-apps/kldap-19.04.3 kde-apps/kleopatra-19.04.3 kde-apps/klettres-19.04.3 kde-apps/klickety-19.04.3 kde-apps/klines-19.04.3 kde-apps/kmag-19.04.3 kde-apps/kmahjongg-19.04.3 kde-apps/kmail-19.04.3 kde-apps/kmail-account-wizard-19.04.3 kde-apps/kmailtransport-19.04.3 kde-apps/kmbox-19.04.3 kde-apps/kmime-19.04.3 kde-apps/kmines-19.04.3 kde-apps/kmix-19.04.3 kde-apps/kmousetool-19.04.3 kde-apps/kmouth-19.04.3 kde-apps/kmplot-19.04.3 kde-apps/knavalbattle-19.04.3 kde-apps/knetwalk-19.04.3 kde-apps/knights-19.04.3 kde-apps/knotes-19.04.3 kde-apps/kolf-19.04.3 kde-apps/kollision-19.04.3 kde-apps/kolourpaint-19.04.3 kde-apps/kompare-19.04.3 kde-apps/konqueror-19.04.3 kde-apps/konquest-19.04.3 kde-apps/konsole-19.04.3 kde-apps/konsolekalendar-19.04.3 kde-apps/kontact-19.04.3 kde-apps/kontactinterface-19.04.3 kde-apps/kopete-19.04.3 kde-apps/korganizer-19.04.3 kde-apps/kpat-19.04.3 kde-apps/kpimtextedit-19.04.3 kde-apps/kpkpass-19.04.3 kde-apps/kqtquickcharts-19.04.3 kde-apps/krdc-19.04.3 kde-apps/kreversi-19.04.3 kde-apps/krfb-19.04.3 kde-apps/kross-interpreters-19.04.3 kde-apps/kruler-19.04.3 kde-apps/kshisen-19.04.3 kde-apps/ksirk-19.04.3 kde-apps/ksmtp-19.04.3 kde-apps/ksnakeduel-19.04.3 kde-apps/kspaceduel-19.04.3 kde-apps/ksquares-19.04.3 kde-apps/ksudoku-19.04.3 kde-apps/ksystemlog-19.04.3 kde-apps/kteatime-19.04.3 kde-apps/ktimer-19.04.3 kde-apps/ktouch-19.04.3 kde-apps/ktp-accounts-kcm-19.04.3 kde-apps/ktp-approver-19.04.3 kde-apps/ktp-auth-handler-19.04.3 kde-apps/ktp-call-ui-19.04.3 kde-apps/ktp-common-internals-19.04.3 kde-apps/ktp-contact-list-19.04.3 kde-apps/ktp-contact-runner-19.04.3 kde-apps/ktp-desktop-applets-19.04.3 kde-apps/ktp-filetransfer-handler-19.04.3 kde-apps/ktp-kded-module-19.04.3 kde-apps/ktp-send-file-19.04.3 kde-apps/ktp-text-ui-19.04.3 kde-apps/ktuberling-19.04.3 kde-apps/kturtle-19.04.3 kde-apps/kubrick-19.04.3 kde-apps/kwalletmanager-19.04.3 kde-apps/kwave-19.04.3 kde-apps/kwordquiz-19.04.3 kde-apps/kwrite-19.04.3 kde-apps/libgravatar-19.04.3 kde-apps/libkcddb-19.04.3 kde-apps/libkcompactdisc-19.04.3 kde-apps/libkdcraw-19.04.3 kde-apps/libkdegames-19.04.3 kde-apps/libkdepim-19.04.3 kde-apps/libkeduvocdocument-19.04.3 kde-apps/libkexiv2-19.04.3 kde-apps/libkgapi-19.04.3 kde-apps/libkgeomap-19.04.3 kde-apps/libkipi-19.04.3 kde-apps/libkleo-19.04.3 kde-apps/libkmahjongg-19.04.3 kde-apps/libkomparediff2-19.04.3 kde-apps/libksane-19.04.3 kde-apps/libksieve-19.04.3 kde-apps/libktnef-19.04.3 kde-apps/lokalize-19.04.3 kde-apps/lskat-19.04.3 kde-apps/mailcommon-19.04.3 kde-apps/mailimporter-19.04.3 kde-apps/marble-19.04.3 kde-apps/mbox-importer-19.04.3 kde-apps/messagelib-19.04.3 kde-apps/minuet-19.04.3 kde-apps/okular-19.04.3 kde-apps/palapeli-19.04.3 kde-apps/parley-19.04.3 kde-apps/picmi-19.04.3 kde-apps/pimcommon-19.04.3 kde-apps/pim-data-exporter-19.04.3 kde-apps/pim-sieve-editor-19.04.3 kde-apps/plasma-telepathy-meta-19.04.3 kde-apps/poxml-19.04.3 kde-apps/print-manager-19.04.3 kde-apps/rocs-19.04.3 kde-apps/signon-kwallet-extension-19.04.3 kde-apps/spectacle-19.04.3 kde-apps/step-19.04.3 kde-apps/svgpart-19.04.3 kde-apps/sweeper-19.04.3 kde-apps/thumbnailers-19.04.3 kde-apps/umbrello-19.04.3 kde-apps/zeroconf-ioslave-19.04.3
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2019-06-29 07:47:18 UTC
Yes, it's only released on 2019-07-11, but we still got to plan with it already.
Comment 1 Aaron Bauman (RETIRED) gentoo-dev 2019-07-27 02:16:55 UTC
(In reply to Andreas Sturmlechner from comment #0)
> Yes, it's only released on 2019-07-11, but we still got to plan with it
> already.

Please CC arm64 when ready.  Running checks now against it (stable bot won't catch it when the time comes)
Comment 2 Frank Krömmelbein 2019-07-27 22:09:56 UTC
Only one real problem has occurred and this has been caused by the profile change to 17.1 and is not a KDE issue. kde-apps/ktp-call-ui-19.04.3 failed for me, error already known: 
"kde-apps/ktp-call-ui - ninja: error: '/usr/lib/libtelepathy-farstream.so', needed by 'src/ktp-call-ui', missing and no known rule to make it"
https://bugs.gentoo.org/683796
After "emerge -1 telepathy-qt telepathy-farstream", i could build kde-apps/ktp-call-ui-19.04.3.

I ignored some useflags -alsa, +libav, -pdf, +systemd, -xml and -xmp
Comment 3 Andreas Sturmlechner gentoo-dev 2019-07-27 22:12:43 UTC
Thank you very much for testing, as always!
Comment 4 Andreas Sturmlechner gentoo-dev 2019-07-27 22:17:26 UTC
No reason to any further delay then, arches please stabilise!
Comment 5 Frank Krömmelbein 2019-07-27 22:36:36 UTC
(In reply to Andreas Sturmlechner from comment #4)
> No reason to any further delay then, arches please stabilise!

KDE Frameworks 5.60 should be stabilized first.
https://bugs.gentoo.org/690096
Comment 6 Andreas Sturmlechner gentoo-dev 2019-07-27 22:37:51 UTC
Do you have any particular reason for that?
Comment 7 Frank Krömmelbein 2019-07-27 22:45:24 UTC
(In reply to Andreas Sturmlechner from comment #6)
> Do you have any particular reason for that?

I could not start the kde-apps update until after I had updated frameworks. 
Unfortunately I did not save the portage output.

Maybe that's the cause, from kde5-functions.eclass:

        kde-apps)
                if [[ ${PV} = 18.12.3 ]]; then
                        : ${FRAMEWORKS_MINIMAL:=5.57.0}
                        : ${PLASMA_MINIMAL:=5.14.5}
                        : ${QT_MINIMAL:=5.11.1}
                fi
                [[ ${PV} = 19.04.3 ]] && : ${FRAMEWORKS_MINIMAL:=5.60.0}
                ;;
Comment 8 Andreas Sturmlechner gentoo-dev 2019-07-27 22:48:19 UTC
(In reply to Frank Krömmelbein from comment #7)
> Maybe that's the cause, from kde5-functions.eclass:
Of course. Thanks for reminding me of my original plan ;)
Comment 9 Stabilization helper bot gentoo-dev 2019-07-28 00:12:47 UTC
An automated check of this bug failed - repoman reported dependency errors (95 lines truncated): 

> dependency.bad kde-apps/kross-interpreters/kross-interpreters-19.04.3.ebuild: DEPEND: amd64(default/linux/amd64/17.0) ['dev-lang/ruby:2.5']
> dependency.bad kde-apps/kross-interpreters/kross-interpreters-19.04.3.ebuild: RDEPEND: amd64(default/linux/amd64/17.0) ['dev-lang/ruby:2.5']
> dependency.bad kde-apps/kross-interpreters/kross-interpreters-19.04.3.ebuild: DEPEND: amd64(default/linux/amd64/17.0/desktop) ['dev-lang/ruby:2.5']
Comment 10 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-07-28 00:39:01 UTC
(In reply to Stabilization helper bot from comment #9)
> An automated check of this bug failed - repoman reported dependency errors
> (95 lines truncated): 
> 
> > dependency.bad kde-apps/kross-interpreters/kross-interpreters-19.04.3.ebuild: DEPEND: amd64(default/linux/amd64/17.0) ['dev-lang/ruby:2.5']
> > dependency.bad kde-apps/kross-interpreters/kross-interpreters-19.04.3.ebuild: RDEPEND: amd64(default/linux/amd64/17.0) ['dev-lang/ruby:2.5']
> > dependency.bad kde-apps/kross-interpreters/kross-interpreters-19.04.3.ebuild: DEPEND: amd64(default/linux/amd64/17.0/desktop) ['dev-lang/ruby:2.5']

^^ unccing amd64/x86, it is the single problem, will stabilize myself for both once fixed
Comment 11 Stabilization helper bot gentoo-dev 2019-07-28 00:58:41 UTC
An automated check of this bug succeeded - the previous repoman errors are now resolved.
Comment 12 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-07-28 01:12:21 UTC
(In reply to Stabilization helper bot from comment #11)
> An automated check of this bug succeeded - the previous repoman errors are
> now resolved.

^^ it is not
Comment 13 Larry the Git Cow gentoo-dev 2019-07-28 02:08:18 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7791a127ecc420788cdab49f0666f105dfe22f0b

commit 7791a127ecc420788cdab49f0666f105dfe22f0b
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2019-07-28 01:59:30 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2019-07-28 01:59:30 +0000

    kde-apps/kross-interpreters: Revbump to make room for ruby24-compat r0
    
    Bug: https://bugs.gentoo.org/688912
    Package-Manager: Portage-2.3.69, Repoman-2.3.16
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 .../kross-interpreters-19.04.3-r1.ebuild           | 37 ++++++++++++++++++++++
 .../kross-interpreters-19.04.3.ebuild              |  2 +-
 2 files changed, 38 insertions(+), 1 deletion(-)
Comment 14 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-07-28 02:31:29 UTC
amd64 stable
Comment 15 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-07-28 02:43:46 UTC
x86 stable
Comment 16 Aaron Bauman (RETIRED) gentoo-dev 2019-07-29 18:44:05 UTC
arm64 stable