Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 688314 - dev-ruby/pg_array_parser-0.0.9-r2 : sandbox issue
Summary: dev-ruby/pg_array_parser-0.0.9-r2 : sandbox issue
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Rick Farina (Zero_Chaos)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-18 19:22 UTC by Toralf Förster
Modified: 2019-10-13 21:14 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.64 KB, text/plain)
2019-06-18 19:22 UTC, Toralf Förster
Details
dev-ruby:pg_array_parser-0.0.9-r2:20190618-164531.log (dev-ruby:pg_array_parser-0.0.9-r2:20190618-164531.log,2.03 KB, text/plain)
2019-06-18 19:22 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,165.99 KB, text/plain)
2019-06-18 19:22 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.35 KB, application/x-bzip)
2019-06-18 19:22 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,781 bytes, application/x-bzip)
2019-06-18 19:22 UTC, Toralf Förster
Details
sandbox-4.log (sandbox-4.log,394 bytes, text/plain)
2019-06-18 19:22 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-06-18 19:22:27 UTC
VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: open_wr
S: deny

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-hardened_libressl_20190615-171927

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.35.0 *



emerge -qpvO dev-ruby/pg_array_parser
[ebuild  N    ] dev-ruby/pg_array_parser-0.0.9-r2  USE="-doc -test" RUBY_TARGETS="ruby24 -ruby25 -ruby26"
Comment 1 Toralf Förster gentoo-dev 2019-06-18 19:22:29 UTC
Created attachment 580130 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-06-18 19:22:32 UTC
Created attachment 580132 [details]
dev-ruby:pg_array_parser-0.0.9-r2:20190618-164531.log
Comment 3 Toralf Förster gentoo-dev 2019-06-18 19:22:35 UTC
Created attachment 580134 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2019-06-18 19:22:37 UTC
Created attachment 580136 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-06-18 19:22:40 UTC
Created attachment 580138 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-06-18 19:22:43 UTC
Created attachment 580140 [details]
sandbox-4.log
Comment 7 Willard Dawson 2019-09-03 03:01:22 UTC
Any ETA on a fix or workaround? I'm beset with this error on one of my VM instances...
Comment 8 Hank Leininger 2019-10-13 21:10:20 UTC
This is similar to https://bugs.gentoo.org/688310 , and the same workaround worked for me: mask >=dev-ruby/rubygems-3.0.4, re-emerge rubygems, and then pg_array_parser will build.