Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 688258 - dev-python/ipyparallel-6.3.0-r1 - installs to unexpected path - /usr/etc
Summary: dev-python/ipyparallel-6.3.0-r1 - installs to unexpected path - /usr/etc
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2019-06-17 22:08 UTC by Aliaksei Urbanski
Modified: 2022-03-15 08:13 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (ipyparallel-6.2.3:20190617-215454.log,47.96 KB, text/plain)
2019-06-17 22:08 UTC, Aliaksei Urbanski
Details
ipyparallel-6.2.4.ebuild (ipyparallel-6.2.4.ebuild,1.84 KB, text/plain)
2019-06-17 22:09 UTC, Aliaksei Urbanski
Details
ipyparallel-6.2.3.ebuild.patch (ipyparallel-6.2.3.ebuild.patch,427 bytes, text/plain)
2020-05-26 23:41 UTC, Alexander Tsoy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aliaksei Urbanski 2019-06-17 22:08:08 UTC
Created attachment 580064 [details]
build.log

Hello,

I'm getting this message when emerging ipyparallel-6.2.3:

 * The ebuild is installing to one or more unexpected paths:
 *
 *   /usr/etc
 *
 * Please fix the ebuild to use correct FHS/Gentoo policy paths.

I also tried to install 6.2.4 and got the same warning.
Is it expected or should it be fixed somehow?

Thanks!
Comment 1 Aliaksei Urbanski 2019-06-17 22:09:33 UTC
Created attachment 580066 [details]
ipyparallel-6.2.4.ebuild
Comment 2 Marius Brehler 2019-07-28 10:29:10 UTC
Reported this to upstream [1] and will fix after clarifying the intended location.

[1] https://github.com/ipython/ipyparallel/issues/377
Comment 3 Alexander Tsoy 2020-05-26 23:41:49 UTC
Created attachment 641984 [details]
ipyparallel-6.2.3.ebuild.patch
Comment 4 Stefan Strogin gentoo-dev 2020-08-13 22:36:06 UTC
Bug still present for 6.3.0
Comment 5 François Bissey 2020-08-13 22:40:40 UTC
I am wondering if this is a jupyter configuration thing that should be fixed in the jupyter package.

I just noticed recently (may be there was a message from portage but I missed it) that dev-python/widgetsnbextension is installing 
/usr/etc/jupyter/nbconfig/notebook.d/widegtsnbextension.json

which obviously feels wrong.
Comment 6 François Bissey 2020-08-13 22:53:33 UTC
I think it may originate from dev-python/jupyter_core.
https://github.com/jupyter/jupyter_core/blob/master/jupyter_core/paths.py#L181

this is present in the current version of jupyter_core
ENV_CONFIG_PATH = [os.path.join(sys.prefix, 'etc', 'jupyter')]

sys.prefix is ${EPREFIX}/usr normally.
Comment 7 François Bissey 2020-08-13 23:23:09 UTC
Turns out its just because those files are installed as part distutils "data_files" which puts stuff under sys.prefix and there is no python way to install stuff in a location like /etc - you are not supposed to do that.
Comment 8 Agostino Sarubbo gentoo-dev 2021-10-07 13:25:55 UTC
tinderbox has reproduced this issue with version 6.3.0-r1 - Updating summary.
Comment 9 Andrew Ammerlaan gentoo-dev 2021-10-25 12:47:35 UTC
> I am wondering if this is a jupyter configuration thing that should be fixed in the jupyter package.


(In reply to François Bissey from comment #7)
> Turns out its just because those files are installed as part distutils
> "data_files" which puts stuff under sys.prefix and there is no python way to
> install stuff in a location like /etc - you are not supposed to do that.

Yes indeed, many other jupyter related packages are effected by this. The easy workaround that I've used in other ebuilds is:

python_install_all() {
	distutils-r1_python_install_all
	# move /usr/etc stuff to /etc
	mv "${ED}/usr/etc" "${ED}/etc" || die
}

Which is not nice or pretty but it works.
Comment 10 Larry the Git Cow gentoo-dev 2021-10-25 12:56:22 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=18ee4b7bb4f66c8979528f952c045e75fb480754

commit 18ee4b7bb4f66c8979528f952c045e75fb480754
Author:     Andrew Ammerlaan <andrewammerlaan@gentoo.org>
AuthorDate: 2021-10-25 12:52:29 +0000
Commit:     Andrew Ammerlaan <andrewammerlaan@gentoo.org>
CommitDate: 2021-10-25 12:56:19 +0000

    dev-python/ipyparallel: add version 7.1.0
    
    Bug: https://bugs.gentoo.org/688258
    Closes: https://bugs.gentoo.org/820152
    Package-Manager: Portage-3.0.28, Repoman-3.0.3
    Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>

 dev-python/ipyparallel/Manifest                 |  1 +
 dev-python/ipyparallel/ipyparallel-7.1.0.ebuild | 73 +++++++++++++++++++++++++
 2 files changed, 74 insertions(+)