Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 688222 - net-misc/stunnel-5.55: restore USE=libressl
Summary: net-misc/stunnel-5.55: restore USE=libressl
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: libressl-support
  Show dependency tree
 
Reported: 2019-06-17 16:29 UTC by Stefan Strogin
Modified: 2019-06-18 18:25 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Strogin gentoo-dev 2019-06-17 16:29:23 UTC
stunnel-5.54-libressl.patch successfully applies on stunnel-5.55, and it compiles fine with the patch on a system with LibreSSL 2.9.2 (except with USE=stunnel3).

Please restore the USE flag and the dependency on libressl.

If you need the LibreSSL patch to be amended for stunnel-5.55[stunnel3], I will gladly do it.
Comment 1 Anthony Basile gentoo-dev 2019-06-17 19:43:23 UTC
(In reply to Stefan Strogin from comment #0)
> stunnel-5.54-libressl.patch successfully applies on stunnel-5.55, and it
> compiles fine with the patch on a system with LibreSSL 2.9.2 (except with
> USE=stunnel3).
> 
> Please restore the USE flag and the dependency on libressl.
> 
> If you need the LibreSSL patch to be amended for stunnel-5.55[stunnel3], I
> will gladly do it.

The patch applies, but the package doesn't built under libressl.  I hasn't for a while now.  If you like to come up with a working patch, please go ahead and do so.
Comment 2 Stefan Strogin gentoo-dev 2019-06-18 18:25:22 UTC
Sorry, I was wrong that USE=stunnel3 affects the build.

The package builds successfully for me with every combination of USE flags.

Why does not the package build for you? Could you send your build logs and USE flags?