Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 687998 - dev-python/pygpu-0.7.6 version bump
Summary: dev-python/pygpu-0.7.6 version bump
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-13 12:58 UTC by Ladislav Jech
Modified: 2019-06-13 15:34 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ladislav Jech 2019-06-13 12:58:31 UTC
We are behind upstream with this. I have updated existing ebuilds just to latest version 0.7.6 and looks working so far.
Comment 1 Ladislav Jech 2019-06-13 13:00:32 UTC
Actually not, I cannot build pygpu, but libgpuarray was success.

with pygpu I get:
ygpu/gpuarray.c: In function ‘__Pyx_modinit_function_export_code’:
pygpu/gpuarray.c:37466:58: error: ‘__pyx_f_5pygpu_8gpuarray_pygpu_init’ undeclared (first use in this function); did you mean ‘__pyx_f_5pygpu_8gpuarray_pygpu_index’?
   if (__Pyx_ExportFunction("pygpu_init", (void (*)(void))__pyx_f_5pygpu_8gpuarray_pygpu_init, "struct PyGpuContextObject *(PyObject *, gpucontext_props *)") < 0) __PYX_ERR(0, 1, __pyx_L1_error)
                                                          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                                                          __pyx_f_5pygpu_8gpuarray_pygpu_index

error: command 'x86_64-pc-linux-gnu-gcc' failed with exit status 1
Comment 2 Ladislav Jech 2019-06-13 13:06:40 UTC
I use gcc-8.2.*