Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 687746 - www-plugins/passff-host plugin not found by firefox
Summary: www-plugins/passff-host plugin not found by firefox
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Georgy Yakovlev
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: no-symlink-lib
  Show dependency tree
 
Reported: 2019-06-09 23:55 UTC by Cédric Krier
Modified: 2020-02-24 16:30 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cédric Krier gentoo-dev 2019-06-09 23:55:39 UTC
I'm using firefox-bin and since I switch no-symlink-lib firefox does not find it.
It seems it is looking in /usr/lib/mozilla instead of /usr/lib64/mozilla where passff-host is installed.
Comment 1 Haelwenn Monnier 2019-06-28 10:33:42 UTC
Re-assigned this bug to mozilla@ as www-client/firefox-bin maintainers.

Related discussion on gentoo-proxy-maint: https://archives.gentoo.org/gentoo-proxy-maint/message/0499bfa70428023c946bce49fee5b8b4
Comment 2 Jory A. Pratt gentoo-dev 2019-07-01 00:26:15 UTC
-bin packages are not generated by the mozilla project but are generated by upstream them self. All plugins should be using /usr/lib/mozilla on gentoo, there really is no need for any of them to be in a arch specific directory.
Comment 3 Haelwenn Monnier 2019-07-01 04:41:35 UTC
>All plugins should be using /usr/lib/mozilla on gentoo, there really is no need for any of them to be in a arch specific directory.

Yeah, it quite makes sense, then can www-client/firefox be fixed for this? (or maybe it is already ? I haven't compiled firefox the last months). As I had to do a modification fron "lib" to $(get_libdir) because it wouldn't work with www-client/firefox on no-symlink-lib in the first place.
Comment 4 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-07-01 07:48:41 UTC
For the record, we were historically multilib-ing browser plugins.  It was back when the 64-bit plugins were scarce, and 64-bit browsers needed to run 32-bit plugins.
Comment 5 Matt Turner gentoo-dev 2019-10-30 00:00:12 UTC
(In reply to Haelwenn Monnier from comment #3)
> >All plugins should be using /usr/lib/mozilla on gentoo, there really is no need for any of them to be in a arch specific directory.
> 
> Yeah, it quite makes sense, then can www-client/firefox be fixed for this?
> (or maybe it is already ? I haven't compiled firefox the last months). As I
> had to do a modification fron "lib" to $(get_libdir) because it wouldn't
> work with www-client/firefox on no-symlink-lib in the first place.

I can't make this work by installing to /usr/lib nor /usr/lib64. Haelwenn, are you still maintaining this?
Comment 6 Haelwenn Monnier 2019-11-01 17:02:13 UTC
(In reply to Matt Turner from comment #5)
> (In reply to Haelwenn Monnier from comment #3)
> > >All plugins should be using /usr/lib/mozilla on gentoo, there really is no need for any of them to be in a arch specific directory.
> > 
> > Yeah, it quite makes sense, then can www-client/firefox be fixed for this?
> > (or maybe it is already ? I haven't compiled firefox the last months). As I
> > had to do a modification fron "lib" to $(get_libdir) because it wouldn't
> > work with www-client/firefox on no-symlink-lib in the first place.
> 
> I can't make this work by installing to /usr/lib nor /usr/lib64. Haelwenn,
> are you still maintaining this?

Yes, firefox became my secondary browser (I switched to my own, www-client/badwolf::guru) but I still test that there is no regressions after www-client/firefox-bin updates (just tried and and it worked, using /usr/lib64), could check on www-client/firefox in few days (currently not at home).
Comment 7 Haelwenn Monnier 2019-11-01 19:06:44 UTC
btw I checked my news feeds and I found that Mozilla is discontinuing sideloaded extensions in Firefox 73.0[1], which will mean that I'll not be maintaining it once there is no <firefox{,-bin}-73.0 in the tree.

1: https://blog.mozilla.org/addons/2019/10/31/firefox-to-discontinue-sideloaded-extensions/
Comment 8 Georgy Yakovlev gentoo-dev 2020-01-26 11:06:23 UTC
is it still relevant or it's fixed in latest FF ebuilds?
I'm on 17.1 profile and it works with recent firefox.
Comment 9 Larry the Git Cow gentoo-dev 2020-02-12 06:35:09 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b29bf7bd1007ec4bdb62d45a1a62a0f4b9588fee

commit b29bf7bd1007ec4bdb62d45a1a62a0f4b9588fee
Author:     Lucian Poston <lucianposton@pm.me>
AuthorDate: 2020-02-11 22:26:58 +0000
Commit:     Georgy Yakovlev <gyakovlev@gentoo.org>
CommitDate: 2020-02-12 06:24:38 +0000

    www-plugins/passff-host: Install to firefox-bin dir
    
    Firefox's directory for native messaging hosts is a compile-time
    variable. www-client/firefox-bin is set to a directory under /usr/lib/,
    while www-client/firefox varies. This -r1 bump will install passff-host
    to both locations so that both firefox and firefox-bin are able to
    locate the plugin.
    
    Package-Manager: Portage-2.3.84, Repoman-2.3.20
    Signed-off-by: Lucian Poston <lucianposton@pm.me>
    Closes: https://bugs.gentoo.org/687746
    Closes: https://github.com/gentoo/gentoo/pull/14632
    Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>

 .../passff-host/passff-host-1.2.1-r1.ebuild        | 59 ++++++++++++++++++++++
 1 file changed, 59 insertions(+)
Comment 10 Larry the Git Cow gentoo-dev 2020-02-12 17:38:37 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e536cb3322bc9fd988349e8f1dcf169b3160c85b

commit e536cb3322bc9fd988349e8f1dcf169b3160c85b
Author:     Lucian Poston <lucianposton@pm.me>
AuthorDate: 2020-02-12 10:51:41 +0000
Commit:     Göktürk Yüksek <gokturk@gentoo.org>
CommitDate: 2020-02-12 17:37:17 +0000

    app-admin/lastpass-binary-component: Install to both firefox dirs
    
    Firefox's directory for native messaging hosts is a compile-time
    variable. www-client/firefox-bin is set to a directory under /usr/lib/,
    while www-client/firefox varies. This -r1 bump will install to both
    locations so that both firefox and firefox-bin are able to locate the
    plugin.
    
    Closes: https://bugs.gentoo.org/688104
    Closes: https://github.com/gentoo/gentoo/pull/14636
    Bug: https://bugs.gentoo.org/687746
    Package-Manager: Portage-2.3.84, Repoman-2.3.20
    Signed-off-by: Lucian Poston <lucianposton@pm.me>
    Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>

 .../lastpass-binary-component-4.19.0-r1.ebuild     | 116 +++++++++++++++++++++
 1 file changed, 116 insertions(+)
Comment 11 Larry the Git Cow gentoo-dev 2020-02-24 16:30:19 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d72f0a3b9556667c1369a29003c1231993fe9192

commit d72f0a3b9556667c1369a29003c1231993fe9192
Author:     Lucian Poston <lucianposton@pm.me>
AuthorDate: 2020-02-12 17:45:45 +0000
Commit:     Matt Turner <mattst88@gentoo.org>
CommitDate: 2020-02-24 16:30:09 +0000

    www-plugins/browserpass: Install to both firefox dirs
    
    Firefox's directory for native messaging hosts is a compile-time
    variable. www-client/firefox-bin is set to a directory under /usr/lib/,
    while www-client/firefox varies. This -r2 bump will install to both
    locations so that both firefox and firefox-bin are able to locate the
    plugin.
    
    Bug: https://bugs.gentoo.org/687746
    Closes: https://github.com/gentoo/gentoo/pull/14643
    Signed-off-by: Lucian Poston <lucianposton@pm.me>
    Signed-off-by: Matt Turner <mattst88@gentoo.org>

 .../browserpass/browserpass-3.0.6-r2.ebuild        | 50 ++++++++++++++++++++++
 1 file changed, 50 insertions(+)