Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 687356 - sys-apps/groff-1.22.4 : MiscXS.c: loadable library and perl binaries are mismatched (got handshake key <snip>, needed <snip>)
Summary: sys-apps/groff-1.22.4 : MiscXS.c: loadable library and perl binaries are mism...
Status: RESOLVED DUPLICATE of bug 638914
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-04 15:12 UTC by Toralf Förster
Modified: 2019-06-05 02:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,18.61 KB, text/plain)
2019-06-04 15:13 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,22.63 KB, text/plain)
2019-06-04 15:13 UTC, Toralf Förster
Details
environment (environment,45.88 KB, text/plain)
2019-06-04 15:13 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.82 KB, application/x-bzip)
2019-06-04 15:13 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,21.16 KB, application/x-bzip)
2019-06-04 15:13 UTC, Toralf Förster
Details
sys-apps:groff-1.22.4:20190603-214440.log (sys-apps:groff-1.22.4:20190603-214440.log,45.13 KB, text/plain)
2019-06-04 15:13 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,18.86 KB, application/x-bzip)
2019-06-04 15:13 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-06-04 15:12:59 UTC
LC_ALL=C \
makeinfo -o doc/groff.info --enable-encoding -I/var/tmp/portage/sys-apps/groff-1.22.4/work/groff-1.22.4/doc /var/tmp/portage/sys-apps/groff-1.22.4/work/groff-1.22.4/doc/groff.texi
MiscXS.c: loadable library and perl binaries are mismatched (got handshake key 0xc280000, needed 0xc180000)
make: *** [Makefile:11891: doc/groff.info] Error 1
 * ERROR: sys-apps/groff-1.22.4::gentoo failed (compile phase):
 *   emake failed

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-desktop_libressl-test_20190602-225504

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)





emerge -qpvO sys-apps/groff
[ebuild     U ] sys-apps/groff-1.22.4 [1.22.3] USE="X* -examples"
Comment 1 Toralf Förster gentoo-dev 2019-06-04 15:13:02 UTC
Created attachment 578708 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-06-04 15:13:05 UTC
Created attachment 578710 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2019-06-04 15:13:07 UTC
Created attachment 578712 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2019-06-04 15:13:11 UTC
Created attachment 578714 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-06-04 15:13:13 UTC
Created attachment 578716 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-06-04 15:13:16 UTC
Created attachment 578718 [details]
sys-apps:groff-1.22.4:20190603-214440.log
Comment 7 Toralf Förster gentoo-dev 2019-06-04 15:13:19 UTC
Created attachment 578720 [details]
temp.tbz2
Comment 8 Toralf Förster gentoo-dev 2019-06-04 16:44:43 UTC
FWIW "perl-cleaner --all" tells, that all is ok
There's another affected package at this tinderbox image, pls see bug #687226
Comment 9 Kent Fredric (IRC: kent\n) gentoo-dev 2019-06-04 18:56:25 UTC
This is not a bug in "groff" its either

a) A Bug in portage's build order handling
b) a bug in makeinfo which is provided by texinfo 

groff simply runs into it, because it runs texinfo code, and texinfo has a weird install path outside the standard perl @INC, and portage doesn't rebuild texinfo prior to executing makeinfo, (but it should)



Relevant context:


Mon Jun  3 05:24:18 2019 <<< dev-lang/perl-5.28.2-r1
Mon Jun  3 05:24:21 2019 >>> dev-lang/perl-5.30.0

*no subsequent texinfo rebuild*


This makes it a dupe of bug #638914

*** This bug has been marked as a duplicate of bug 638914 ***
Comment 10 Kent Fredric (IRC: kent\n) gentoo-dev 2019-06-04 18:58:20 UTC
See #585048 as well for the unreliable interaction between texinfo and perlcleaner
Comment 11 Toralf Förster gentoo-dev 2019-06-04 19:03:05 UTC
for the record:

So "perlcleaner --all" doesn't help, an explicit rebuild of texinfo after perl upgrade is needed - ok.
Comment 12 Kent Fredric (IRC: kent\n) gentoo-dev 2019-06-05 02:02:37 UTC
Yeah, that caveat about perl-cleaner not helping is expected. As I pointed out, there's oddities in its build system that trip up perl-cleaner, in that, it will either rebuild texinfo *every* time, it will never do it at all! :p