Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 687052 - app-admin/keepass[aot] - QA Notice: Files built without respecting CFLAGS have been detected: /usr/lib64/keepass/KeePass.exe.so
Summary: app-admin/keepass[aot] - QA Notice: Files built without respecting CFLAGS hav...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Alessandro Di Federico
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-31 09:06 UTC by Conrad Kostecki
Modified: 2019-11-05 06:21 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,35.16 KB, text/plain)
2019-08-04 16:01 UTC, Conrad Kostecki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Conrad Kostecki 2019-05-31 09:06:15 UTC
* QA Notice: Files built without respecting CFLAGS have been detected
 *  Please include the following list of files in your report:
 * /usr/lib64/keepass/KeePass.exe.so
Comment 1 Michael Palimaka (kensington) gentoo-dev 2019-08-04 08:52:21 UTC
Could you please attach the build log and emerge --info? I'm having trouble reproducing.
Comment 2 Conrad Kostecki 2019-08-04 16:01:41 UTC
Created attachment 585672 [details]
build.log

Sure, here we go.
Comment 3 Michael Palimaka (kensington) gentoo-dev 2019-09-19 09:44:32 UTC
This is caused by AOT, however I'm unsure if it's possible to fix. Looking through the mono source I don't see any way to specify CFLAGS (if that even makes sense).
Comment 4 Conrad Kostecki 2019-10-24 20:19:40 UTC
Otherwise, set on USE="aot" a QA_* option to disable in this case the warning?
Comment 5 Michael Palimaka (kensington) gentoo-dev 2019-11-05 06:20:52 UTC
Works for me, thanks!
Comment 6 Larry the Git Cow gentoo-dev 2019-11-05 06:21:02 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0382c685c01e9769755eb68f6bb11e56ec61e906

commit 0382c685c01e9769755eb68f6bb11e56ec61e906
Author:     Michael Palimaka <kensington@gentoo.org>
AuthorDate: 2019-11-05 06:17:49 +0000
Commit:     Michael Palimaka <kensington@gentoo.org>
CommitDate: 2019-11-05 06:20:42 +0000

    app-admin/keepass: avoid irrelevant warning when built with USE="aot"
    
    Closes: https://bugs.gentoo.org/687052
    Package-Manager: Portage-2.3.76, Repoman-2.3.17
    Signed-off-by: Michael Palimaka <kensington@gentoo.org>

 app-admin/keepass/keepass-2.43.ebuild | 4 ++++
 1 file changed, 4 insertions(+)