Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 686836 - media-libs/nv-codec-headers-9.0.18.1 blocks =x11-drivers/nvidia-drivers-340.107*
Summary: media-libs/nv-codec-headers-9.0.18.1 blocks =x11-drivers/nvidia-drivers-340.107*
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-27 06:59 UTC by John Blbec
Modified: 2019-12-16 11:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Blbec 2019-05-27 06:59:12 UTC
emerge -avuDN world always requires to install nv-codec-headers-9.0.18.1. i always has to add to package.keywords but the package is never installed. when i try to install it manually it requires nvidia-drivers-430.14 but i have an old nvidia card and has to use version 340.107-r1. there must be a wrong dependency somewhere...

# emerge -avuDN world
These are the packages that would be merged, in order:

Calculating dependencies... done!

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by media-video/ffmpeg-4.1.3::gentoo[video_cards_nvidia]
# required by @__auto_slot_operator_replace_installed__ (argument)
=media-libs/nv-codec-headers-9.0.18.1 ~amd64

Would you like to add these changes to your config files? [Yes/No] 

# emerge -1av nv-codec-headers
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U #] x11-drivers/nvidia-drivers-430.14:0/430::gentoo [340.107-r1:0/340::gentoo] USE="X acpi driver%* gtk3%* kms%* multilib static-libs tools -compat% -uvm% -wayland%" ABI_X86="32 (64) (-x32)" 109,392 KiB
[ebuild  N    ~] media-libs/nv-codec-headers-9.0.18.1::gentoo  ABI_X86="(64) -32 (-x32)" 58 KiB

Total: 2 packages (1 upgrade, 1 new), Size of downloads: 109,450 KiB

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by media-libs/nv-codec-headers-9.0.18.1::gentoo
# required by nv-codec-headers (argument)
# /etc/portage/package.mask/packages:
=x11-drivers/nvidia-drivers-430.14

Reproducible: Always
Comment 1 pogosyan 2019-06-07 19:22:15 UTC
Even stable nv-codec-headers-8.1.24.2

has requirement

>=x11-drivers/nvidia-drivers-390.25


which is a big problem for us with older nvidia cards, since now we cannot upgrade to ffmpeg-4, at least keeping VIDEO_CARDS="nvidia" flag.
Comment 2 Alexis Ballier gentoo-dev 2019-12-16 11:51:18 UTC
you need to disable video_cards_nvidia on ffmpeg -- new drivers are, sadly, required