Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 686598 - www-client/firefox-60.7.0 with sys-devel/clang-7.1.0 - .../work/firefox-60.7.0/ff/toolkit/library/release/build/rayon-core-99357d81218f242a/build-script-build` (signal: 11, SIGSEGV: invalid memory reference)
Summary: www-client/firefox-60.7.0 with sys-devel/clang-7.1.0 - .../work/firefox-60.7....
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-23 14:03 UTC by Akos Szalkai
Modified: 2019-09-04 22:51 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge log, issue starting at line 3164 (www-client:firefox-60.7.0:20190523-103718.log.xz,56.45 KB, application/x-xz)
2019-05-23 14:03 UTC, Akos Szalkai
Details
emerge info (emerge-info.txt,8.18 KB, text/plain)
2019-05-23 14:05 UTC, Akos Szalkai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Akos Szalkai 2019-05-23 14:03:36 UTC
Created attachment 577622 [details]
emerge log, issue starting at line 3164

Building firefox 60.7.0 with USE=clang (using clang 7.1.0) fails on a stable Gentoo system.  Previously, firefox 60.6.2 built correctly with clang 6.0.1 and now 60.7.0 also builds with gcc 8.3.0-r1.  The linker is BFD, because there is another issue with the gold linker.

The build fails with a SIGSEGV: invalid memory reference error.

The issue seems to be this one: https://bugzilla.redhat.com/show_bug.cgi?id=1668033 , but haven't had time yet to check it.

Attached the emerge.log and the emerge --info output.  The actual error starts from line 3164 in the emerge log.
Comment 1 Akos Szalkai 2019-05-23 14:05:23 UTC
Created attachment 577624 [details]
emerge info
Comment 2 Vasilis Lourdas 2019-08-17 18:59:23 UTC
I have a similar issue with building Thunderbird 60.8.0 with clang. Without the clang flag, it builds fine. The bug is #689792.
Comment 3 Thomas Deutschmann gentoo-dev Security 2019-09-04 22:51:11 UTC
Cannot reproduce with current stage3 builds (which are using 7.1.0).