I came across this package and wondered about its USE flags (being unclear from their brief names). Not only, the "kbd" stands from "kernel block device" instead of "keyboard" which one would assume, and indeed media-video/vdr assumes as well.
Please rename "kbd" to "kernel-block-device" (or else) in IUSE of sys-libs/libblockdev.
Nit: maybe the metadata.xml could be clearer and explain if kernel block device is needed for bcache?
$ euses -s kbd
media-video/vdr:kbd - enable keyboard support as remote device
sys-libs/libblockdev:kbd - Enable kernel block device support.
So what you want is to cause these *two* definitions to change a USE flag for one of them? Even if I widen the search it merely resolves into a single extra USE flag that includes the "kbd" string:
app-admin/passwordsafe:xvkbd - Install x11-misc/xvkbd on-screen keyboard
$ euses keyboard
dev-qt/qt-docs:virtualkeyboard - Install documentation for dev-qt/qtvirtualkeyboard
kde-apps/kmag:keyboardfocus - Enable keyboard focus tracking
media-sound/csound:keyboard - Build Virtual MIDI keyboard
wl-weekeyboard - Wayland virtual keyboard
keyboard - INPUT_DEVICES setting to build driver for keyboard input devices
> So what you want is to cause these *two* definitions to change a USE flag for
> one of them?
Yes, the reason is that "kbd" is so well known abbreviation for keyboard IMO that sys-libs/libblockdev is just misusing it. Personally I would not be happy if we (as a result of this discussion) invented distinction between USE=kbd and USE=keyboard. They would be confusing. I just think sys-libs/libblockdev should invent its own USE variable name. Whichever.
Probably configure will discover anyway if my kernel supports kernel block device, large block device, bcache, zswap or whatever the package eventually supports.
I do not think that "kbd" is useful abbreviation.
Since at least 1 other package has "keyboard" USE flag which sounds much clearer, I suggest that "kbd" USE flag of media-video/vdr be renamed to "keyboard".
Renaming "kbd" USE flag of sys-libs/libblockdev to "kernel-block-device" or "kernel_block_device" might be a good idea.
Another possibility is to unconditionally pass --with-kbd in sys-libs/libblockdev ebuilds since this option does not require any dependencies.
(In reply to Arfrever Frehtes Taifersar Arahesis from comment #4)
> I suggest that "kbd" USE flag of media-video/vdr be renamed to
> Renaming "kbd" USE flag of sys-libs/libblockdev to "kernel-block-device" or
> "kernel_block_device" might be a good idea.
> Another possibility is to unconditionally pass --with-kbd in
> sys-libs/libblockdev ebuilds since this option does not require any
Either would be fine for me.
The bug has been referenced in the following commit(s):
Author: Joerg Bornkessel <email@example.com>
AuthorDate: 2019-12-15 12:58:41 +0000
Commit: Joerg Bornkessel <firstname.lastname@example.org>
CommitDate: 2019-12-15 12:59:33 +0000
media-video/vdr: moved use flag
moved use flag kbd to keyboard
requested by wrt bug 685828
Package-Manager: Portage-2.3.81, Repoman-2.3.18
Signed-off-by: Joerg Bornkessel <email@example.com>
media-video/vdr/metadata.xml | 1 +
media-video/vdr/vdr-2.2.0-r5.ebuild | 301 ++++++++++++++++++++++++++++++++++++
2 files changed, 302 insertions(+)