Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 68527 - gcdmaster missing important menus
Summary: gcdmaster missing important menus
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: optical media herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-22 04:06 UTC by Dead Schorsch
Modified: 2005-06-10 09:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dead Schorsch 2004-10-22 04:06:23 UTC
Does anybody know, what's the deal with gcdmaster? It does not offer the most important menus mentioned in the man page. That is the "Tools" Menu, which allows inserting audio files and some entries below the "Edit" menu, for setting, editing and removing track marks.

My menu toolbar contains

File | Edit | Actions | Settings | Info

and when starting gcdmaster from shell, I see

(gcdmaster:1052): GnomeUI-WARNING **: gnome_app_insert_menus_custom: couldn't find insertion point for menus!

(gcdmaster:1052): GnomeUI-WARNING **: gnome_app_insert_menus_custom: couldn't find insertion point for menus!

Could it be that due to the errors above the most important menus are missing / incomplete, leaving gcdmaster totally useless?

Reproducible: Always
Steps to Reproduce:
1. gcdmaster
2. Create new AudioCD project
3.

Actual Results:  
Console output:

(gcdmaster:1052): GnomeUI-WARNING **: gnome_app_insert_menus_custom: couldn't
find insertion point for menus!

(gcdmaster:1052): GnomeUI-WARNING **: gnome_app_insert_menus_custom: couldn't
find insertion point for menus!


Portage 2.0.51-r2 (default-x86-2004.2, gcc-3.3.4, glibc-2.2.5-r2,glibc-2.3.4.200
41006-r0, 2.6.8-gentoo-r7 i686)
=================================================================
System uname: 2.6.8-gentoo-r7 i686 AMD Athlon(tm) XP 2200+
Gentoo Base System version 1.5.3
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.92.0.2-r1
Headers:  sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-mcpu=athlon-xp -O2 -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/s
hare/config /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dv
ipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config
/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-mcpu=athlon-xp -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs buildpkg ccache distcc distlocks fixpackages sandbox userpr
iv usersandbox"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://distro.ibiblio.org/pub/Linux/dis
tributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X aalib acpi alsa apm avi berkdb bitmap-fonts bonobo cdr crypt cups doc dvd
 dvdr encode esd f77 foomaticdb gd gdbm gimpprint gnome gpm gtk gtk2 gtkhtml gui
le hbci imagemagick imlib ipv6 java jpeg ldap libg++ libwww mad mozilla moznocom
pose moznoirc moznomail mpeg ncurses network nls nocardbus nptl nvidia oggvorbis
 opengl pam pda pdflib perl png python readline samba scanner sdl slang spell ss
l svga tcltk tcpd tetex tiff truetype usb vanilla x86 xml xml2 xmms xprint xv zl ib"
Comment 1 Andrej Kacian (RETIRED) gentoo-dev 2004-10-22 05:17:40 UTC
Please specify package where this happens.
Comment 2 Dead Schorsch 2004-10-22 06:03:09 UTC
at least with cdrdao-1.1.19, other versions might be affected as well, but they did not build with gnome support anyhow.
Comment 3 foser (RETIRED) gentoo-dev 2004-10-25 08:32:52 UTC
maybe abi breakage, you tried recompiling crdoa & the *mm deps ?
Comment 4 Dead Schorsch 2004-10-28 05:39:18 UTC
Yes, tried that recently, but didn't help. I re-emerged everything from the RDEPEND line of the ebuild, that ended with mm.

To be precise: "emerge gtkmm libgnomemm libgnomecanvasmm gconfmm libgnomeuimm cdrdao" didn't solve the problem.
Comment 5 foser (RETIRED) gentoo-dev 2004-10-28 05:58:28 UTC
you also have to specify exact versions, the *mm packages are often slotted.
Comment 6 Dead Schorsch 2004-10-28 06:40:17 UTC
The newest one's of course ...

king ~ # emerge -s cdrdao gtkmm libgnomemm libgnomecanvasmm gconfmm libgnomeuimm 
Searching...
[ Results for search key : cdrdao ]
[ Applications found : 1 ]

*  app-cdr/cdrdao
      Latest version available: 1.1.9
      Latest version installed: 1.1.9
      Size of downloaded files: 1,544 kB
      Homepage:    http://cdrdao.sourceforge.net/
      Description: Burn CDs in disk-at-once mode -- with optional GUI frontend
      License:     GPL-2


Searching...
[ Results for search key : gtkmm ]
[ Applications found : 1 ]

*  dev-cpp/gtkmm
      Latest version available: 2.4.5
      Latest version installed: 2.4.5
      Size of downloaded files: 3,843 kB
      Homepage:    http://gtkmm.sourceforge.net/
      Description: C++ interface for GTK+2
      License:     LGPL-2.1


Searching...
[ Results for search key : libgnomemm ]
[ Applications found : 1 ]

*  dev-cpp/libgnomemm
      Latest version available: 2.6.0
      Latest version installed: 2.6.0
      Size of downloaded files: 233 kB
      Homepage:    http://gtkmm.sourceforge.net/
      Description: C++ bindings for libgnome
      License:     LGPL-2.1
Searching...
[ Results for search key : libgnomecanvasmm ]
[ Applications found : 1 ]

*  dev-cpp/libgnomecanvasmm
      Latest version available: 2.6.1
      Latest version installed: 2.6.1
      Size of downloaded files: 299 kB
      Homepage:    http://gtkmm.sourceforge.net/
      Description: C++ bindings for libgnomecanvasmm
      License:     LGPL-2.1


Searching...
[ Results for search key : gconfmm ]
[ Applications found : 1 ]

*  dev-cpp/gconfmm
      Latest version available: 2.6.1
      Latest version installed: 2.6.1
      Size of downloaded files: 250 kB
      Homepage:    http://gtkmm.sourceforge.net/
      Description: C++ bindings for GConf
      License:     LGPL-2.1


Searching...
[ Results for search key : libgnomeuimm ]
[ Applications found : 1 ]

*  dev-cpp/libgnomeuimm
      Latest version available: 2.6.0
      Latest version installed: 2.6.0
      Size of downloaded files: 289 kB
      Homepage:    http://gtkmm.sourceforge.net/
      Description: C++ bindings for libgnomeui
      License:     LGPL-2.1
Comment 7 foser (RETIRED) gentoo-dev 2004-10-28 07:52:42 UTC
check the cdrdao ebuild for which *mm lib versions you should rebuild.
Comment 8 Dead Schorsch 2004-10-28 08:44:19 UTC
Sorry, I have no idea of portage's SLOT concept, i emerge every package matching the RDEPENDS section from the cdrdao ebuild by emerging the latest available ebuild for this version directly, like 

emerge /usr/portage/dev-cpp/libgnomeuimm/libgnomeuimm-2.0.0.ebuild

Still, emerge -s shows the newest versions, I guess I have to do it different?
Comment 9 Lars Weiler (RETIRED) gentoo-dev 2004-10-30 19:35:41 UTC
Slotting means that you can have more than one version installed on your system.  emerge -s will show only the latest version.  Tools like equery are more verbose.

So, make sure you have the right versions installed.  In the cdrdao-ebuild are = and a version numbers around the dependencies.
Comment 10 Dead Schorsch 2004-11-01 03:22:46 UTC
Okay, I jused equery to check and from what I read:

king ~ # for i in gtkmm libgnomemm libgnomecanvasmm gconfmm libgnomeuimm ; do equery list $i ; done

[ Searching for package 'gtkmm' in all categories among: ]
 * installed packages
[I--] [  ] dev-cpp/gtkmm-2.2.12 (2)
[I--] [  ] dev-cpp/gtkmm-1.2.9-r2 (1.2)
[I--] [  ] dev-cpp/gtkmm-2.4.1 (3)
[I--] [  ] dev-cpp/gtkmm-2.4.5 (2.4)
[ Searching for package 'libgnomemm' in all categories among: ]
 * installed packages
[I--] [  ] dev-cpp/libgnomemm-2.6.0 (2.6)
[I--] [  ] dev-cpp/libgnomemm-2.0.1 (2)
[ Searching for package 'libgnomecanvasmm' in all categories among: ]
 * installed packages
[I--] [  ] dev-cpp/libgnomecanvasmm-2.0.1 (2)
[I--] [  ] dev-cpp/libgnomecanvasmm-2.6.1 (2.6)
[ Searching for package 'gconfmm' in all categories among: ]
 * installed packages
[I--] [  ] dev-cpp/gconfmm-2.6.1 (0)
[I--] [  ] dev-cpp/gconfmm-2.0.2 (2)
[ Searching for package 'libgnomeuimm' in all categories among: ]
 * installed packages
[I--] [  ] dev-cpp/libgnomeuimm-2.6.0 (2.6)
[I--] [  ] dev-cpp/libgnomeuimm-2.0.0 (1.0)

the installed Status Quo fairly matches the requirements:

RDEPEND=">=media-sound/lame-3.90
        gnome? ( =dev-cpp/gtkmm-2.2*
                =dev-cpp/libgnomemm-2.0*
                =dev-cpp/libgnomecanvasmm-2.0*
                =dev-cpp/gconfmm-2.0*
                =dev-cpp/libgnomeuimm-2.0.0 )"

Doesn't it?
Comment 11 foser (RETIRED) gentoo-dev 2004-11-01 05:05:02 UTC
yes ofcourse it does, otherwise it wouldnt even run. What we're trying to get to here is that you rebuild the _right_ deps to see if it's some sort of ABI breakage, to finish what we started out with in comment #5 .
Comment 12 Dead Schorsch 2004-11-01 05:58:18 UTC
Well, looks like that state has been reached already. The packages are present at the precise versions (as precise as 2.0.* can be). Re-emerge cdrdao afterwards with no change whatsoever.

Only thing left to test, could be to actually _remove_ the more recent versions before rebuilding cdrdao, but I guess this would seriously wack up my system.
Comment 13 Dead Schorsch 2004-11-08 02:23:01 UTC
Anything else, I can provide?
Comment 14 Lars Weiler (RETIRED) gentoo-dev 2004-12-02 20:23:35 UTC
I can just verify that bug.  I get also the

GnomeUI-WARNING: **: gnome_app_insert_menu-custom: couldn't find insertion point for menus!

Probably cdrdao is broken...

If you look at the screenshot on http://cdrdao.sourceforge.net/gcdmaster/index.html I can't see a "Tools" menu there.
Comment 15 Lars Weiler (RETIRED) gentoo-dev 2005-01-08 09:10:08 UTC
Give bug to the media-optical herd.
Comment 16 Lars Weiler (RETIRED) gentoo-dev 2005-06-10 09:00:24 UTC
This is for sure an upstream bug.  Closing, as we can't fix it in Gentoo.