Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 685252 - app-text/pandoc: undefined references via dev-haskel/unix-compat library
Summary: app-text/pandoc: undefined references via dev-haskel/unix-compat library
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Haskell Language team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks:
 
Reported: 2019-05-07 08:48 UTC by Nikita Zlobin
Modified: 2020-01-26 00:22 UTC (History)
2 users (show)

See Also:
Package list:
=dev-haskell/unix-compat-0.4.3.1
Runtime testing required: ---
stable-bot: sanity-check+


Attachments
emerge --info pandoc (emerge-info-pandoc,14.31 KB, text/plain)
2019-05-07 08:48 UTC, Nikita Zlobin
no flags Details
pandoc build log (emerge-build-pandoc,19.90 KB, text/plain)
2019-05-07 20:47 UTC, Nikita Zlobin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Zlobin 2019-05-07 08:48:33 UTC
Created attachment 575454 [details]
emerge --info pandoc

I have two haskell packages, which fail to rebuild after upgrade to glibc-2.27 from glibc-2.26.

=app-text/pandoc-1.19.2.1-r1::gentoo
Linking dist/build/pandoc/pandoc ...
/usr/lib64/x86_64-linux-ghc-8.0.2/libHSunix-compat-0.4.1.3-DFX6G0Mjoz42Uy7ge5YAY-ghc8.0.2.so: undefined reference to `major'
/usr/lib64/x86_64-linux-ghc-8.0.2/libHSunix-compat-0.4.1.3-DFX6G0Mjoz42Uy7ge5YAY-ghc8.0.2.so: undefined reference to `makedev'
/usr/lib64/x86_64-linux-ghc-8.0.2/libHSunix-compat-0.4.1.3-DFX6G0Mjoz42Uy7ge5YAY-ghc8.0.2.so: undefined reference to `minor'
collect2: error: ld returned 1 exit status

=dev-vcs/darcs-2.12.5::gentoo
Linking dist/build/darcs/darcs ...
/usr/lib64/x86_64-linux-ghc-8.0.2/libHSunix-compat-0.4.1.3-DFX6G0Mjoz42Uy7ge5YAY-ghc8.0.2.so: undefined reference to `major'
/usr/lib64/x86_64-linux-ghc-8.0.2/libHSunix-compat-0.4.1.3-DFX6G0Mjoz42Uy7ge5YAY-ghc8.0.2.so: undefined reference to `makedev'
/usr/lib64/x86_64-linux-ghc-8.0.2/libHSunix-compat-0.4.1.3-DFX6G0Mjoz42Uy7ge5YAY-ghc8.0.2.so: undefined reference to `minor'
collect2: error: ld returned 1 exit status

First time I encountered it at darcs, during world rebuild.
I tried to fix it with haskell-updater, but it seems useless (these two were at the end of emerge list).

When I tried to find more packages, linking with libHSunix-compat:
# revdep-rebuild --library '/usr/lib64/x86_64-linux-ghc-8.0.2/libHSunix-compat-0.4.1.3-DFX6G0Mjoz42Uy7ge5YAY-ghc8.0.2.so' -- -av1

It gave only this libs, which rebuilds ok:
dev-haskell/filemanip:0/0.3.6.3
Comment 1 Nikita Zlobin 2019-05-07 08:51:32 UTC
I could not find anything about this bug, besides this, which seems similar:
https://www.bountysource.com/issues/67854359-ftbfs-stack-for-glibc
Comment 2 Jonas Stein gentoo-dev 2019-05-07 19:17:13 UTC
Thank you for the report. Please recompile and 
*attach* the logfiles and 
paste the emerge info as described on
https://wiki.gentoo.org/wiki/Attach_the_logs_to_the_bug_ticket
The logs must be part of the ticket, but not on external websites.
We need to have all information at hand before ticket assignment, so that the maintainer can look after it in one session with minimal number of callbacks.
Please reopen this ticket (Status:unconfirmed) afterwards.

Please write the full package name in the summary.
Comment 3 Nikita Zlobin 2019-05-07 20:47:06 UTC
Created attachment 575474 [details]
pandoc build log

Here is it.

This issue affects two packages with same problem. To satisfy some requirements I changed name to mention only certain affected package (pandoc) and added its uncut build log (initial post already showes striped useful part from build logs for both pandoc and darcs).

"emerge --info pandoc" output was presented from start.
Comment 4 Nikita Zlobin 2019-05-07 20:51:30 UTC
Sorry for initial flooding of thread with build log, but I assumed it enough compact for that, yet other part appeared redundant from my POV (tends to be wrong).
Comment 5 Sergei Trofimovich gentoo-dev 2019-05-08 22:48:10 UTC
Must be a fallout of glibc-2.28. We'll need to stable compatible version.

Try =dev-haskell/unix-compat-0.4.3.1 and see if it works for you.
Comment 6 Nikita Zlobin 2019-05-09 07:04:01 UTC
Yes, with unix-compat-0.4.3.1 all 3 dependants are built without troubles.
Btw, pandoc seems lacking unix-compat in dependencies, while really it depends.
Comment 7 Sergei Trofimovich gentoo-dev 2019-05-09 22:42:40 UTC
Arches, please stabilize =dev-haskell/unix-compat-0.4.3.1 for the following KEYWORDS:
    KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
Comment 8 Rolf Eike Beer 2019-05-11 08:11:46 UTC
I guess this needs bug 631138? I'm not able to get any ghc building on sparc, so don't expect any progress there.
Comment 9 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-05-11 11:09:17 UTC
amd64 stable
Comment 10 Thomas Deutschmann gentoo-dev Security 2019-05-19 13:19:39 UTC
x86 stable
Comment 11 Agostino Sarubbo gentoo-dev 2019-06-04 14:37:18 UTC
ppc64 stable
Comment 12 Agostino Sarubbo gentoo-dev 2019-06-05 07:13:36 UTC
ppc stable
Comment 13 Agostino Sarubbo gentoo-dev 2019-06-08 18:16:21 UTC
sparc stable