Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 68521 - Cannot emerge glibc-2.3.4-20041006 in ppc64
Summary: Cannot emerge glibc-2.3.4-20041006 in ppc64
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: PPC64 Linux
: High blocker (vote)
Assignee: ppc64 architecture team
Depends on:
Reported: 2004-10-22 03:25 UTC by Yang Dehua
Modified: 2011-10-30 22:54 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Yang Dehua 2004-10-22 03:25:05 UTC
I tried to emerge glibc-2.3.4-20041006 in my 2004.2 ppc64, but failed in the stage of install with:
"stat '/var/tmp/portage/glibc-2.3.4-20041006/temp/thread-backup/*': no such file or directory".
I have "nptlonly" in USE.
I tried to emerge it without "nptlonly" too, but also failed with complaining not existing in must_exist() function of ebuild.

Reproducible: Always
Steps to Reproduce:
1.ACCEPT_KEYWORDS="ppc64 ~ppc64" emerge glibc 

Actual Results:  
Failed in the stage of install

Expected Results:  
Emerged successfully
Comment 1 Tom Gall (RETIRED) gentoo-dev 2004-10-23 19:53:05 UTC
if you have your USE set to nptl  you should be fine.

But I did just fix a similiar bug in glibc-2.3.4-0808. I should see about moving that fix forward.
Comment 2 Yang Dehua 2004-10-29 04:58:08 UTC
No, not fine:
!!!ERROR: sys-libs/glibc- failed.
!!!Function must_exist,Line 817,Exitcode 1
!!!/lib// was not installed
When I had "nptl"(not nptlonly) in USE.
Comment 3 Joshua Root 2004-10-31 08:39:03 UTC
I get the same thing. Apparently is installed in /lib64 ...
Comment 4 Joshua Root 2004-11-02 02:52:46 UTC
20041021 seems to be fixed in portage now -- I just emerged it successfully.
Comment 5 Markus Rothe (RETIRED) gentoo-dev 2004-11-02 05:37:33 UTC
OK.. I'll close this bug then.

Comment 6 Markus Rothe (RETIRED) gentoo-dev 2004-11-02 05:37:49 UTC