Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 684970 - dev-python/matplotlib should depend on x11-libs/agg - The following required packages can not be built: gtk3agg
Summary: dev-python/matplotlib should depend on x11-libs/agg - The following required ...
Status: RESOLVED DUPLICATE of bug 643626
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-03 11:08 UTC by Ulenrich
Modified: 2019-05-03 11:46 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulenrich 2019-05-03 11:08:00 UTC
dev-python/matplotlib -wxwidgets 
misses a depend on x11-libs/agg
---
                        * The following required packages can not be built:
                        * gtk3agg
 * ERROR: dev-python/matplotlib-2.2.4::gentoo failed (compile phase):
 *   (no error message)
---
but when installing:
---
[ebuild  N     ] x11-libs/agg-2.5-r3::gentoo  USE="X gpc -sdl -static-libs truetype" 552 KiB

Total: 1 package (1 new), Size of downloads: 552 KiB

Would you like to merge these packages? [Yes/No] y
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) x11-libs/agg-2.5-r3::gentoo
>>> Installing (1 of 1) x11-libs/agg-2.5-r3::gentoo
---

dev-python/matplotlib-2.2.4::gentoo emerges successfully
Comment 1 Jeroen Roovers gentoo-dev 2019-05-03 11:42:57 UTC
Bug #456766: dev-python/matplotlib: bundles x11-libs/agg
Bug #581550: dev-python/matplotlib-2.0.2 : The following required packages can not be built: * qt4agg
Bug #643626: dev-python/matplotlib-2.1.0-r1 - required package gtk3agg can not be built

I smell at least one duplicate.
Comment 2 Jeroen Roovers gentoo-dev 2019-05-03 11:46:51 UTC

*** This bug has been marked as a duplicate of bug 643626 ***