Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 684964 - dev-util/apitrace-8.0 should depend on app-arch/brotli:=[${MULTILIB_USEDEP}] - ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../libbrotlidec.so when searching for -lbrotlidec
Summary: dev-util/apitrace-8.0 should depend on app-arch/brotli:=[${MULTILIB_USEDEP}] ...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2019-05-03 07:15 UTC by EoD
Modified: 2019-05-09 00:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Ebuild patch to fix multilib dependency (apitrace-8.0-fix-multlib.patch,496 bytes, patch)
2019-05-03 07:15 UTC, EoD
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description EoD 2019-05-03 07:15:21 UTC
Created attachment 574976 [details, diff]
Ebuild patch to fix multilib dependency

apitrace-8.0 pulls in app-arch/brotli without the respective mutlilib dependency:

> /usr/bin/x86_64-pc-linux-gnu-g++ -m32  -O2 -pipe -march=ivybridge -O2 -pipe -ggdb -O2 -pipe -fvisibility=hidden -std=gnu++11 -Wall -Wno-sign-compare -fno-strict-aliasing -fno-rtti -fno-exceptions -fmessage-length=0 -fno-omit-frame-pointer  -Wl,-O1 -Wl,--as-needed    -rdynamic lib/trace/CMakeFiles/trace_parser_flags_test.dir/trace_parser_flags_test.cpp.o  -o trace_parser_flags_test  -Wl,-rpath,/var/tmp/portage/dev-util/apitrace-8.0/work/apitrace-8.0-abi_x86_32.x86 libgtest.so lib/trace/libcommon.a -lpthread lib/guids/libguids.a lib/highlight/libhighlight.a lib/os/libos.a -ldl thirdparty/libbacktrace/libbacktrace.a -lbrotlidec -lbrotlienc && :
> /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../libbrotlidec.so when searching for -lbrotlidec
> /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libbrotlidec.so when searching for -lbrotlidec
> /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lbrotlidec
> /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../libbrotlienc.so when searching for -lbrotlienc
> /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libbrotlienc.so when searching for -lbrotlienc
> /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lbrotlienc
> collect2: error: ld returned 1 exit status

The attached patch fixes the issue.
Comment 1 Andreas Sturmlechner gentoo-dev 2019-05-03 07:34:55 UTC
This is going to be obsolete by bug 684830.
Comment 2 Matt Turner gentoo-dev 2019-05-09 00:02:13 UTC

*** This bug has been marked as a duplicate of bug 684830 ***