Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 683294 - media-video/vlc-3.0.6: VLSub fails to save subtitles
Summary: media-video/vlc-3.0.6: VLSub fails to save subtitles
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-14 11:37 UTC by Pacho Ramos
Modified: 2019-09-14 21:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2019-04-14 11:37:45 UTC
When I try to load subtitles, it simply downloads and gets stuck. I reported to:
https://trac.videolan.org/vlc/ticket/22186

And there are similar reports in internet (specially related with the upstream VLSub copy, that is a bit older than the VLC one)

For now I would change default in our ebuild to use "manual" download instead of broken "save". For that, we could simply change:
downloadBehaviour = 'save',

to:
downloadBehaviour = 'manual',

in share/lua/extensions/VLSub.lua

That way, at least, people won't get the broken behavior by default

Thanks
Comment 1 Andreas Sturmlechner gentoo-dev 2019-05-12 17:03:08 UTC
Sure, just do it.
Comment 2 Pacho Ramos gentoo-dev 2019-09-14 21:01:22 UTC
for some reason it seems to work currently with latest vlc