Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 681768 - sci-electronics/geda-1.9.2-r1(?) shows only the "About" menu
Summary: sci-electronics/geda-1.9.2-r1(?) shows only the "About" menu
Status: RESOLVED DUPLICATE of bug 643822
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: The Soldering-Iron Brotherhood
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-26 01:55 UTC by Jiang Yifeng
Modified: 2019-12-03 16:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiang Yifeng 2019-03-26 01:55:30 UTC
i build sci-electroincs/geda with cflags,then i click the menu,only show the about,others are disabled
Comment 1 Jeroen Roovers gentoo-dev 2019-03-26 05:48:22 UTC
Maybe you want to install sci-electronics/geda-suite, too?
Comment 2 Francois Chenier 2019-09-06 09:34:02 UTC
Same issue here. It seems this package don't play well with dev-scheme/guile-2.2

I downgraded to guile to version 2.0.14-r3 recompiled sci-electronics/geda and all is working fine now.
Comment 3 Stephen Cavilia 2019-12-03 16:05:18 UTC
I noticed the same behavior after my most recent install and realized after looking through old logs I had been using guile 2.0. Seems to be a duplicate of #643822

gEDA 1.10.0 has some official support for guile 2.2. I threw together a quick ebuild and was able to build it against guile 2.0 but the xorn component still has some issues building with 2.2.
Comment 4 Jeroen Roovers gentoo-dev 2019-12-03 16:41:31 UTC

*** This bug has been marked as a duplicate of bug 643822 ***