Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 68112 - Sound Broken in Mplayer-1.0_pre5-r4
Summary: Sound Broken in Mplayer-1.0_pre5-r4
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC64 Linux
: High major (vote)
Assignee: Chris White (RETIRED)
Depends on: 71119
  Show dependency tree
Reported: 2004-10-19 01:24 UTC by Yang Dehua
Modified: 2004-12-23 12:18 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

patch for mplayer-1.0_pre5-r4.ebuild (mplayer-1.0_pre5-r4.ebuild.patch,1.12 KB, patch)
2004-11-13 21:43 UTC, Yuta SATOH (RETIRED)
Details | Diff
patch for mplayer on ppc64 (mplayer-1.0_pre5-r4-ppc64.patch,596 bytes, patch)
2004-11-13 21:44 UTC, Yuta SATOH (RETIRED)
Details | Diff
patch for mplayer-1.0_pre5-r4.ebuild (mplayer-1.0_pre5-r4.ebuild.patch,1.08 KB, patch)
2004-11-13 21:55 UTC, Yuta SATOH (RETIRED)
Details | Diff
my mplayer.log (mplayer.log,4.11 KB, text/plain)
2004-11-15 07:16 UTC, Yuta SATOH (RETIRED)
My emerge info (emerge-info.txt,1.68 KB, text/plain)
2004-11-15 16:19 UTC, Yang Dehua
patch for mplayer-1.0_pre5-r4.ebuild (mplayer-1.0_pre5-r4.ebuild.patch,589 bytes, patch)
2004-11-20 01:37 UTC, Yuta SATOH (RETIRED)
Details | Diff
new patch for mplayer on ppc64 (mplayer-1.0_pre5-r4-ppc64.patch,2.64 KB, patch)
2004-11-20 01:41 UTC, Yuta SATOH (RETIRED)
Details | Diff
present "emerge info" (,1.80 KB, text/plain)
2004-11-21 07:23 UTC, Yuta SATOH (RETIRED)
my /etc/modules.d/alsa (alsa,416 bytes, text/plain)
2004-11-22 11:46 UTC, Yuta SATOH (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Yang Dehua 2004-10-19 01:24:50 UTC
I emerged Mplayer-1.0_pre5-r4 in my 2004.2 ppc64 successfully. But the sound was broken(almost just noise) when I played avi, mpeg ... files with it. The video was ok though. It's same with xine-1.0.

Reproducible: Always
Steps to Reproduce:
1.mplayer <video file>
Actual Results:  
Broken sound

Expected Results:  
Normal sound effect
Comment 1 Patrick Kursawe (RETIRED) gentoo-dev 2004-10-19 01:28:54 UTC
would be nice if you could list a few applications where the sound is ok.
Comment 2 Yang Dehua 2004-10-29 01:28:22 UTC
I emerged the latest xine-lib-r6, now the sound is ok for xine player and totem to play avi and mpeg movies. But not mplayer, the sound is still broken when I play with mplayer.
Comment 3 Chris White (RETIRED) gentoo-dev 2004-11-10 18:37:30 UTC
ppc64 herd,

Thoughts on this?
Comment 4 Markus Rothe (RETIRED) gentoo-dev 2004-11-10 22:20:33 UTC
yes, I've thought about this bug, but I have no sound card to test. Unfortunaly this *might* be a little endian/big endian problem as seen in mpg123.
Comment 5 Yuta SATOH (RETIRED) gentoo-dev 2004-11-13 21:29:05 UTC
The problem on which sound plays only a noise will be solved by Bug #71119.
Comment 6 Yuta SATOH (RETIRED) gentoo-dev 2004-11-13 21:43:57 UTC
Created attachment 43910 [details, diff]
patch for mplayer-1.0_pre5-r4.ebuild
Comment 7 Yuta SATOH (RETIRED) gentoo-dev 2004-11-13 21:44:56 UTC
Created attachment 43911 [details, diff]
patch for mplayer on ppc64

A file name is mplayer-1.0_pre5-r4-ppc64.patch .
Comment 8 Yuta SATOH (RETIRED) gentoo-dev 2004-11-13 21:46:00 UTC
In my environment, the following error occurs and fails to compile.

Detected operating system: Linux
Detected host architecture: UNKNOWN
Checking for gcc version ... 3.4.1, ok
The architecture of your CPU (UNKNOWN) is not supported by this configure script
It seems nobody has ported MPlayer to your OS or CPU type yet.

Error: unsupported architecture UNKNOWN

Check "configure.log" if you do not understand why it failed.

Also, when altivec is contained in the USE flag, fails to compile.

gcc -I../libvo -I../../libvo -I/usr/X11R6/include -O2 -pipe -fno-stack-protector
-I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -DHAVE_AV_C
esample.o imgresample.c
imgresample.c: In function `v_resample16_altivec':
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size
imgresample.c:309: error: can't convert between vector values of different size


imgresample.c:379: error: can't convert between vector values of different size
imgresample.c:379: error: can't convert between vector values of different size
imgresample.c:379: error: can't convert between vector values of different size
imgresample.c:379: error: can't convert between vector values of different size
imgresample.c:380: error: Cannot pass argument in vector register because altivec instructions are disabled, use -maltivec to enable them.
make[1]: *** [imgresample.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/mplayer-1.0_pre5-r4/work/MPlayer-1.0pre5/libavcodec'
make: *** [libavcodec/libavcodec.a] Error 2

These patches solve these problems.
Comment 9 Yuta SATOH (RETIRED) gentoo-dev 2004-11-13 21:48:07 UTC
emerge info output:

Portage 2.0.51-r2 (default-ppc64-2004.2, gcc-3.4.1, glibc-, 2.6.9-gentoo-r2 ppc64)
System uname: 2.6.9-gentoo-r2 ppc64 PPC970, altivec supported
Gentoo Base System version 1.4.16
distcc 2.16 powerpc64-unknown-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux-headers-2.4.22
Libtools: sys-devel/libtool-1.5.2-r5
CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -pipe"
FEATURES="autoaddcvs buildpkg ccache distlocks sandbox"
USE="X Xaw3d aalib alsa altivec apache2 arts berkdb bitmap-fonts cdr cjk crypt cups dga dvd dvdr emacs encode esd f77 flash foomaticdb fortran gdbm gif gnome gpm gtk gtk2 imap imlib joystick jpeg kde libwww mad mitshm motif mozilla mpeg mule ncurses nls nogcj oggvorbis opengl oss pam pdflib perl png ppc64 python qt quicktime readline samba sdl slang ssl tcpd tetex tiff truetype usb xml xml2 xmms xv zlib"
Comment 10 Yuta SATOH (RETIRED) gentoo-dev 2004-11-13 21:55:28 UTC
Created attachment 43912 [details, diff]
patch for mplayer-1.0_pre5-r4.ebuild
Comment 11 Markus Rothe (RETIRED) gentoo-dev 2004-11-14 01:51:27 UTC
I've verified that mplayer builds, but as I mentioned before I don't have a working soundcard :-/. As Nigoro has verified that the patch works I've added it to portage and marked mplayer ~ppc64.
Comment 12 Yang Dehua 2004-11-14 16:53:13 UTC
Thank you. With these patched mplayer builds, and works partly in my ppc64(G5) system, using SB mp3 sound card.
mpeg:  ok
dvd:   ok
avi:   video is ok, sound broken(distorted badly)
wmv:   video is ok, no sound
mp3:   sound is broken
Comment 13 Yuta SATOH (RETIRED) gentoo-dev 2004-11-15 07:10:44 UTC
Thank you for your test report.

In my environment, mp3 is also played normally.
I installed in the following procedure.

1. emerge sync
2. emerge -C mplayer
3. emerge linux-headers
4. emerge mplayer

And I'm using the following audio device.

$ cat /proc/asound/cards
0 [MP3            ]: USB-Audio - Sound Blaster MP3+
                     Creative Labs Sound Blaster MP3+ at usb-0001:02:0b.0-2, full speed

Would you add some information, in order to consider this problem?

1. result of "emerge info"
2. result of "emerge -ptv mplayer"
3. result of "mplayer -v -quiet hoge.mp3 &> /tmp/mplayer.log"
4. information of mp3 file (example: 44100Hz, 128 kbs, CBR, Joint Stereo)

Also, what is codec of avi?

Thank you.
Comment 14 Yuta SATOH (RETIRED) gentoo-dev 2004-11-15 07:16:21 UTC
Created attachment 43991 [details]
my mplayer.log

This is a result on my environment.
Comment 15 Yang Dehua 2004-11-15 16:16:17 UTC
Did you play mp3 music by gmplayer or mplayer?
In my case, mp3 files could be played normaly by mplayer, but distorted badly when opening the files in gmplayer interface. The same held for playing avi video. 
I use FFmpeg for avi video codec. Also I use the same sound card as you.
Comment 16 Yang Dehua 2004-11-15 16:19:14 UTC
Created attachment 44025 [details]
My emerge info
Comment 17 Yuta SATOH (RETIRED) gentoo-dev 2004-11-20 01:37:56 UTC
Created attachment 44334 [details, diff]
patch for mplayer-1.0_pre5-r4.ebuild

I'm very sorry.

When altivec was contained in the USE flag, the problem which fails to compile
was my misapprehension.
It was because -maltivec is not contained in CFLAGS.

I attach the patch that put back a portion about altivec.

any developer,
I am sorry to trouble you, but could you apply this patch?
Comment 18 Yuta SATOH (RETIRED) gentoo-dev 2004-11-20 01:40:12 UTC

In my environment, a mp3 file is normally played by both mplayer and gmplayer.
I have not reproduced yet the problem generated in your environment.

Would you disable ccache and try compile once again?
And please try the following patch, if it is unsolvable.
Comment 19 Yuta SATOH (RETIRED) gentoo-dev 2004-11-20 01:41:50 UTC
Created attachment 44335 [details, diff]
new patch for mplayer on ppc64

A part of patch of mpg123 was added to this new patch.
Comment 20 Yuta SATOH (RETIRED) gentoo-dev 2004-11-20 09:57:19 UTC
In my environment, I found the problem with which the video and sound of 
an avi file do not synchronize.
It seems that the play speed of video is quick a little.
Comment 21 Yang Dehua 2004-11-20 15:45:29 UTC
Thank you. I did just as you suggested; applying the new patch and, deleting the .ccache and reemerging mplayer. But the problem is just as same as before. May be something wrong with CFLAGS in my env? I'd a look at your emerge info, and guessed that could make a difference.
Comment 22 Yang Dehua 2004-11-20 17:35:06 UTC
BTW: Do you have the problem of
I have been frustrated with that for a long time.
Comment 23 Yuta SATOH (RETIRED) gentoo-dev 2004-11-21 07:15:00 UTC
Thank you for your try.

Although I re-installed Gentoo/PPC64 and tried it,
I have not reproduced the problem...

Would you add mad to USE flags and compile once again?

About the problem of Bug #64359, it reappeared also in my environment.
But, I don't know how to solve this problem now. I'm sorry.
Comment 24 Yuta SATOH (RETIRED) gentoo-dev 2004-11-21 07:23:14 UTC
Created attachment 44410 [details]
present "emerge info"

And, emerge -ptv mplayer output:

[ebuild   R   ] media-video/mplayer-1.0_pre5-r4  (-3dfx) (-3dnow) (-3dnowex) +X

+aalib +alsa +altivec +arts -bidi -cdparanoia -debug (-directfb) -divx4linux
c -dvb +dvd -dvdread -edl +encode +esd -fbcon -ggi +gif +gtk -i8x0 -ipv6 -jack
joystick +jpeg -libcaca -lirc -live -lzo +mad -matroska -matrox (-mmx) (-mmx2)
mpeg -mythtv -nas -network +nls -nvidia +oggvorbis +opengl +oss +png -real -rtc

+samba +sdl (-sse) (-svga) -tga +theora +truetype -v4l -v4l2 +xanim -xinerama
mms +xv +xvid -xvmc 0 kB
Comment 25 Yuta SATOH (RETIRED) gentoo-dev 2004-11-21 07:44:48 UTC
my bad... 

emerge -ptv mplayer output again:

[ebuild   R   ] media-video/mplayer-1.0_pre5-r4  (-3dfx) (-3dnow) (-3dnowex) +X +aalib +alsa +altivec +arts -bidi -cdparanoia -debug (-directfb) -divx4linux -doc -dvb +dvd -dvdread -edl +encode +esd -fbcon -ggi +gif +gtk -i8x0 -ipv6 -jack +joystick +jpeg -libcaca -lirc -live -lzo +mad -matroska -matrox (-mmx) (-mmx2) +mpeg -mythtv -nas -network +nls -nvidia +oggvorbis +opengl +oss +png -real -rtc +samba +sdl (-sse) (-svga) -tga +theora +truetype -v4l -v4l2 +xanim -xinerama +xmms +xv +xvid -xvmc 0 kB
Comment 26 Yang Dehua 2004-11-22 01:14:26 UTC
My mplayer info:
[ebuild   R   ] media-video/mplayer-1.0_pre5-r4  (-3dfx) (-3dnow) (-3dnowex) +X +aalib +alsa +altivec +arts -bidi -cdparanoia -debug (-directfb) -divx4linux -doc -dvb +dvd -dvdread -edl +encode +esd -fbcon -ggi +gif +gtk -i8x0 -ipv6 -jack -joystick +jpeg -libcaca -lirc -live -lzo +mad -matroska -matrox (-mmx) (-mmx2) -mpeg -mythtv -nas -network +nls -nvidia +oggvorbis +opengl +oss +png -real -rtc +samba +sdl (-sse) (-svga) -tga +theora +truetype -v4l -v4l2 +xanim -xinerama +xmms +xv +xvid -xvmc 0 kB 

I think that's exactly same with yours. But the sound is still broken. Weird!!!
Comment 27 Yuta SATOH (RETIRED) gentoo-dev 2004-11-22 11:43:51 UTC
I reproduced the problem which has probably occurred in your environment.

Sound seems not to play normally when using OSS for the audio driver.
Would you try ALSA?
When you have already used ALSA, I apologize for this wrong comment.

Thank you.
Comment 28 Yuta SATOH (RETIRED) gentoo-dev 2004-11-22 11:44:10 UTC
snip of menuconfig:
(Please disable USB Audio support in USB support.)
Device Drivers  --->
 Sound  --->
  <M> Sound card support
  Advanced Linux Sound Architecture  --->
   <M> Advanced Linux Sound Architecture
   <M> Sequencer support
   <M> OSS Mixer API
   <M> OSS PCM (digital audio) API
   [*] OSS Sequencer API
   <M> Emulation for 32-bit applications
   <M> RTC Timer support
    ALSA USB devices  --->
    <M> USB Audio/MIDI driver

 USB support  --->
  < >   USB Audio support

And, please see about a setup of ALSA, if necessary.

Comment 29 Yuta SATOH (RETIRED) gentoo-dev 2004-11-22 11:46:17 UTC
Created attachment 44485 [details]
my /etc/modules.d/alsa
Comment 30 Yang Dehua 2004-11-22 15:55:57 UTC
I tried to disable the alsa support in the kernel as you suggested, but system complained with not finding alsa usb audio driver. I tried to emerge the latest alsa driver, but failed. The alsa-driver-1.0.7 does not compile.
I tried both oss and alsa in gmplayer, the effect's same. Now only something wrong with the gui client, it's ok to use mplayer.
I am sorry that I made so much troube to you. Thank you. 
Comment 31 Yuta SATOH (RETIRED) gentoo-dev 2004-11-24 07:34:36 UTC
Don't worry about it!
I'm thankful to your ALL comment!

It seems that gmplayer is calling mplayer.
So, if the play of sound is normally possible at mplayer, I think that can play it normally also by gmplayer.
This problem is very weird!!

Would you delete ~/.mplayer directory and try again?
(Please backup, if necessary.)

Thank you.
Comment 32 Yang Dehua 2004-11-25 21:26:00 UTC
Thank you VERY MUCH! You are CERTAINLY right!
Everything went ok after I deleted ~/.mplayer directory. Now I am so pleased that I have a workable and great video player. 
Comment 33 Yuta SATOH (RETIRED) gentoo-dev 2004-11-26 00:53:51 UTC
I'm very happy to read your comment!
And, thank you for trying many things until now!
Comment 34 Markus Rothe (RETIRED) gentoo-dev 2004-12-23 12:18:46 UTC