Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 680872 - app-admin/mongo-tools-3.6.8 with dev-lang/go-1.12.1 - vendor/src/github.com/google/gopacket/pcap/pcap.go:173:7: identifier "_Ctype_struct_bpf_program" may conflict with identifiers generated by cgo
Summary: app-admin/mongo-tools-3.6.8 with dev-lang/go-1.12.1 - vendor/src/github.com/g...
Status: RESOLVED DUPLICATE of bug 680838
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Ultrabug
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-18 18:41 UTC by Urban
Modified: 2019-03-28 12:31 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,3.52 KB, text/plain)
2019-03-18 18:41 UTC, Urban
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Urban 2019-03-18 18:41:18 UTC
Created attachment 569612 [details]
build.log

After upgrading dev-lang/go from 1.11.5 to 1.12.1, rebuild of dev-db/mongodb-3.6.8 failed with:

Building mongoreplay...
# github.com/google/gopacket/pcap
vendor/src/github.com/google/gopacket/pcap/pcap.go:173:7: identifier "_Ctype_struct_bpf_program" may conflict with identifiers generated by cgo
vendor/src/github.com/google/gopacket/pcap/pcap.go:384:13: identifier "_Ctype_struct_pcap_stat" may conflict with identifiers generated by cgo
vendor/src/github.com/google/gopacket/pcap/pcap.go:421:49: identifier "_Ctype_struct_bpf_program" may conflict with identifiers generated by cgo
vendor/src/github.com/google/gopacket/pcap/pcap.go:444:10: identifier "_Ctype_struct_bpf_program" may conflict with identifiers generated by cgo
vendor/src/github.com/google/gopacket/pcap/pcap.go:462:41: identifier "_Ctype_struct_bpf_insn" may conflict with identifiers generated by cgo
vendor/src/github.com/google/gopacket/pcap/pcap.go:538:66: identifier "_Ctype_struct_bpf_program" may conflict with identifiers generated by cgo
vendor/src/github.com/google/gopacket/pcap/pcap.go:551:19: identifier "_Ctype_struct_bpf_insn" may conflict with identifiers generated by cgo
vendor/src/github.com/google/gopacket/pcap/pcap.go:659:34: identifier "_Ctype_struct_pcap_addr" may conflict with identifiers generated by cgo
vendor/src/github.com/google/gopacket/pcap/pcap.go:662:56: identifier "_Ctype_struct_pcap_addr" may conflict with identifiers generated by cgo
Error building mongoreplay
Comment 1 Michael Kefeder 2019-03-19 15:31:08 UTC
Bug #680838 has a quickfix for this problem.
Comment 2 Brian Evans Gentoo Infrastructure gentoo-dev 2019-03-28 12:31:04 UTC

*** This bug has been marked as a duplicate of bug 680838 ***