Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 680580 - net-libs/webkit-gtk-2.24.0: ENABLE_JIT conflicts with ENABLE_C_LOOP.
Summary: net-libs/webkit-gtk-2.24.0: ENABLE_JIT conflicts with ENABLE_C_LOOP.
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: ARM Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-16 08:50 UTC by takashi
Modified: 2019-04-19 11:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,16.27 KB, text/plain)
2019-03-16 08:51 UTC, takashi
Details
emerge --info (file_680580.txt,18.11 KB, text/plain)
2019-03-16 08:59 UTC, takashi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description takashi 2019-03-16 08:50:11 UTC
When trying to upgrade webkit-gtk from 2.22.7 to 2.24.0 on my armhfel Chromebook, I get the following error:

> ...
> -- Checking for module 'gl'
> --   Found gl, version 18.2.8
> -- Found OpenGL: /usr/include  
> -- Looking for include file GL/glx.h
> -- Looking for include file GL/glx.h - found
> CMake Error at Source/cmake/WebKitFeatures.cmake:275 (message):
>   ENABLE_JIT conflicts with ENABLE_C_LOOP.  You must disable one or the
>   other.
> Call Stack (most recent call first):
>   Source/cmake/WebKitFeatures.cmake:283 (_WEBKIT_OPTION_ENFORCE_CONFLICTS)
>   Source/cmake/WebKitFeatures.cmake:308 (_WEBKIT_OPTION_ENFORCE_ALL_CONFLICTS)
>   Source/cmake/OptionsGTK.cmake:161 (WEBKIT_OPTION_END)
>   Source/cmake/WebKitCommon.cmake:56 (include)
>   CMakeLists.txt:159 (include)
> 
> 
> -- Configuring incomplete, errors occurred!
> See also "/var/tmp/portage/net-libs/webkit-gtk-2.24.0/work/webkit-gtk-2.24.0_build/CMakeFiles/CMakeOutput.log".
> See also "/var/tmp/portage/net-libs/webkit-gtk-2.24.0/work/webkit-gtk-2.24.0_build/CMakeFiles/CMakeError.log".
>  * ERROR: net-libs/webkit-gtk-2.24.0::gentoo failed (configure phase):
>  *   cmake failed
> ...

My USE="X egl gnome-keyring gstreamer introspection jit jpeg2k jumbo-build libnotify opengl spell -aqua -coverage -doc -geolocation -gles2 -nsplugin -test -wayland -webgl"

I'm overwhelmed by all the different JIT options WebKit provides, so I don't know how to go forward from here.
Comment 1 takashi 2019-03-16 08:51:28 UTC
Created attachment 569276 [details]
build.log
Comment 2 takashi 2019-03-16 08:59:02 UTC
Created attachment 569278 [details]
emerge --info
Comment 3 tt_1 2019-03-17 15:36:34 UTC
I can confirm, happend for me on cross compile. 

This is caused most likely by changed behavior in Source/cmake/WebKitFeatures.cmake and how arm_thumbv2 is detected. 

Failed test for arm_thumbv2 meant to fall back to armv7_traditional for 2.22.x, now it means to go for ENABLE_C_LOOP

(exact values may differ, writing this away from my workstation with the code to look at)
Comment 4 tt_1 2019-03-18 17:48:29 UTC
seems to be this one? 

https://bugs.webkit.org/show_bug.cgi?id=182886
Comment 5 Mart Raudsepp gentoo-dev 2019-04-13 14:05:38 UTC
I'm starting to feel inclined to simply remove USE=jit now and let webkitgtk build system figure out if it's good to use JIT or not.
Especially with pax and hardened in the state it is now apparently.
Comment 6 Larry the Git Cow gentoo-dev 2019-04-13 19:05:58 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=08e02e08cb8befcf19ded8e1cee3dd32025bf4bd

commit 08e02e08cb8befcf19ded8e1cee3dd32025bf4bd
Author:     Mart Raudsepp <leio@gentoo.org>
AuthorDate: 2019-04-13 18:58:50 +0000
Commit:     Mart Raudsepp <leio@gentoo.org>
CommitDate: 2019-04-13 18:59:07 +0000

    net-libs/webkit-gtk: security bump to 2.24.1, drop JIT control
    
    JIT manual control is getting complicated for limited benefits, which
    mostly involve oneself shooting in the foot. Let upstream build system
    figure out whether it should do JIT or not and don't get in the way.
    May be revisited based on any fallout and relevant bug reports after
    discussions on such reports convince it's needed.
    
    Bug: https://bugs.gentoo.org/683234
    Bug: https://bugs.gentoo.org/680580
    Bug: https://bugs.gentoo.org/680464
    Package-Manager: Portage-2.3.52, Repoman-2.3.12
    Signed-off-by: Mart Raudsepp <leio@gentoo.org>

 net-libs/webkit-gtk/Manifest                 |   1 +
 net-libs/webkit-gtk/webkit-gtk-2.24.1.ebuild | 281 +++++++++++++++++++++++++++
 2 files changed, 282 insertions(+)
Comment 7 Mart Raudsepp gentoo-dev 2019-04-19 11:04:03 UTC
No follow-up issues reported so far, so closing this one as FIXED. If there are concerns about USE=jit going away (and having upstream figure out which to do), or other related or unrelated bugs, please file a new bug entry.