Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 6800 - emerge search shows that sylpheed-theme isn't installed although it is
Summary: emerge search shows that sylpheed-theme isn't installed although it is
Alias: None
Product: Gentoo Infrastructure
Classification: Unclassified
Component: Bugzilla (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: John Davis (zhen) (RETIRED)
Depends on:
Reported: 2002-08-20 16:53 UTC by Yariv Ido
Modified: 2011-10-30 23:16 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Yariv Ido 2002-08-20 16:53:39 UTC
Maybe this is a really minor bug in sylpheed-theme's ebuild, or a minor bug in
portage. I just don't know how the portage system calculates what packages are
installed and what aren't, when using emerge search.

emerge search sylpheed-theme:
*  x11-themes/sylpheed-theme
      Latest version Available: 3
      Latest version Installed: [ Not Installed ]
      Description: Theme packs for sylpheed and sylpheed-claws and sylpheed-claws-nc

emerge sylpheed-theme -p:
These are the packages that I would merge, in order.

Calculating dependencies ...done!
[ebuild   R  ] x11-themes/sylpheed-theme-3 to /

I tried remeging sylpheed-theme, but it still showed as 'Not Installed'.
Comment 1 Seemant Kulleen (RETIRED) gentoo-dev 2002-08-22 22:21:51 UTC
portage bug :/
Comment 2 Yariv Ido 2002-08-27 16:33:14 UTC
You've probably found the small bug, but just in case - I did a little
experiment and it seems that the problem is with short package versions ( '3' in
this case ). I've tried to merge package xt ( xt-1.ebuild ), and the same bug

emerge is the first python program I ever saw, so forgive me if I'm totally off
track... It seems that changing line 448 ( portage 2.0.28 ) from:
		if len(version) > 1:
		if len(version) >= 1:

did the trick.
Comment 3 Daniel Robbins (RETIRED) gentoo-dev 2002-08-28 18:54:14 UTC
OK, will be fixed in 2.0.30 final.