Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 67967 - eog inappropriately locks input when displaying an image full-screen
Summary: eog inappropriately locks input when displaying an image full-screen
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High critical (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-17 22:23 UTC by P Nienaber
Modified: 2006-12-03 02:00 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description P Nienaber 2004-10-17 22:23:34 UTC
Well, as I found out after SSH'ing in and killing xscreensaver, I had Eye of Gnome (media-gfx/eog) running with an image fullscreened, and then wandered off for a bit.  Upon coming back, I found that xscreensaver didn't respond to the keyboard AT ALL.  Mouse input woke it up and it prompted me for my password, but I couldn't type it.  Neat.

Reproducible: Didn't try
Steps to Reproduce:
1. eog /path/to/file.jpg
2. hit F11
3. wait for xscreensaver to do its thing

Actual Results:  
see details

Expected Results:  
well, um, let me unlock my screen.  good thing I have sshd on all my boxes even
the workstations...
Comment 1 Markus Nigbur (RETIRED) gentoo-dev 2004-11-07 02:38:46 UTC
Not reproduceable.
Comment 2 P Nienaber 2004-11-07 11:05:26 UTC
Attempted to and successfully reproduced.  Just open something in EOG (I was using the collection view feature, where you just run 'eog /path/to/someimages/ &'), press F11 so it fullscreens, and wait for xscreensaver to do its thing.  You'll also notice that eog is obnoxious and captures other useful input, like virtually anything I have bound to various functions via my windowmanager (fluxbox).  Of course, xscreensaver should be able to cope with this, as it should be capable of doing to eog exactly whatever eog is doing to the rest of my workspace.
Comment 3 P Nienaber 2004-11-19 14:01:41 UTC
Reopening.
Comment 4 P Nienaber 2004-11-19 14:02:55 UTC
also understand that "fullscreened" = hitting F11, not maximizing the eog window.  sorry if that caused any confusion before.
Comment 5 Drakos7 /Greg Wilson/ 2004-12-14 11:06:07 UTC
reproduced here as well. ssh in and killed eog which gave me my desktop back but still no mouse or keyboard. Only killing xscreensaver gave me control back. FWIW, I am using my ebuild of xscreensaver 4.18.
Comment 6 Donnie Berkholz (RETIRED) gentoo-dev 2005-01-19 23:55:59 UTC
Potentially a problem with eog not releasing the keyboard, CC'ing gnome team.
Comment 7 Alastair Tse (RETIRED) gentoo-dev 2005-01-24 03:43:57 UTC
taking over, but i think it might be eog or a windowmanager thing
Comment 8 P Nienaber 2005-01-24 11:49:26 UTC
It's sort of an EOG thing, but at this point I've seen xscreensaver specifically say that it can't grab the keyboard, which would be *pretty good* criteria for doing something other than locking the screen w/ password.  Obviously, xscreensaver's functionality should probably become part of x.org so that it's not fighting for control at the normal X11 client level.
Comment 9 Don Seiler (RETIRED) gentoo-dev 2005-02-24 13:57:22 UTC
xscreensaver 4.17 introduced this fix:

* I give up: don't blank or lock the screen if we can't get a keyboard grab. In that case, both choices are bad.

Perhaps that has fixed your issue.  I just added 4.20 to portage, please try and let us know what you find.
Comment 10 P Nienaber 2005-02-24 14:24:14 UTC
Yup, it refuses to even blank now, so there's no longer a CRI bug on xscreensaver's part.  However, when I tested it this time around (I'll see if I can find time to do a bit more and see what I can nail down..) eog locked my mouse + keyboard, so I couldn't do anything (which, without VC or SSH support forces a user to kill X and lose data).  This bug should probably become one to get upstreamed to the Gnome people, as I don't think any of their other apps do anything quite this stupid.  Leaving as CRI; reassigning to gnome@.

As for the EOG bug:  Clearly this is something that should also be upstreamed to x.org, as they seem to care about problems with X... not being able to interact with your windowmanager/anything else because of an app (even after killing it) is not a good behavior.  Still, IMO, this should get fixed in EOG, as the fewer applications we have that trigger the greater problem at hand the less damage it's going to cause.  Gthumb, for example, does the same thing without locking KB/mouse input.

Also CC:ing x11@ for their input... perhaps the suggestion upstream should be that DPMI be disabled a-la-XINE/etc whenever input is grabbed so this doesn't happen?  I may go file a bug w/ xorg once I've looked into the issues involved a bit more.
Comment 11 Rémi Cardona gentoo-dev 2006-12-03 02:00:12 UTC
To all here,

Is this bug still an issue 22 months later ? :) Don't hesitate to reopen with new version info if it's still happening.

Thanks