Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 679412 - dev-util/nvidia-cuda-sdk-10.1.105 version bump
Summary: dev-util/nvidia-cuda-sdk-10.1.105 version bump
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 3 votes (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-04 16:32 UTC by Oleg
Modified: 2019-06-09 16:59 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Not working ebuild (nvidia-cuda-toolkit-10.1.105.ebuild,3.28 KB, text/plain)
2019-03-04 16:32 UTC, Oleg
Details
dev-util/nvidia-cuda-sdk-10.1.105 ebuild (nvidia-cuda-toolkit-10.1.105.ebuild,3.43 KB, text/plain)
2019-03-26 18:03 UTC, Oleg
Details
dev-util/nvidia-cuda-sdk-10.1.105 ebuild (nvidia-cuda-sdk-10.1.105.ebuild,3.67 KB, text/plain)
2019-03-29 09:30 UTC, Brian Munro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg 2019-03-04 16:32:33 UTC
Created attachment 567746 [details]
Not working ebuild

nvidia-cuda-sdk-10.1 has support for gcc-8.2:

https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#system-requirements

I've tried to update existing ebuild but it fails on ./doc/pdf/
Comment 1 Jeroen Roovers gentoo-dev 2019-03-04 17:41:58 UTC
Comment on attachment 567746 [details]
Not working ebuild

Why did you attach an ebuild that is "[n]ot working"?
Comment 2 Oleg 2019-03-04 17:43:58 UTC
(In reply to Jeroen Roovers from comment #1)
> Comment on attachment 567746 [details]
> Not working ebuild
> 
> Why did you attach an ebuild that is "[n]ot working"?

There is a corrected URL to archive.
Comment 3 Jan Vesely 2019-03-23 06:49:22 UTC
I've started a new nvidia-cuda-toolkit-10.1.105 ebuild [0]
It works well enough to get pycuda running, but the useflag based removals can use an update. Perhaps similar changes are needed for the SDK.


[0] https://github.com/jvesely/gentoo/commit/90c0ffbd7bbe67c8ddb2a92f6d71d0578b3844a1
Comment 4 Oleg 2019-03-23 07:11:50 UTC
Could you test it with doc use flag? I get error :

>>> Install nvidia-cuda-toolkit-10.1.105 into /tmp/portage/dev-util/nvidia-cuda-toolkit-10.1.105/image category dev-util
Traceback (most recent call last):
  File "/usr/lib/portage/python3.6/doins.py", line 611, in <module>
    sys.exit(main(sys.argv[1:]))
  File "/usr/lib/portage/python3.6/doins.py", line 602, in main
    os.path.dirname(source)):
  File "/usr/lib/portage/python3.6/doins.py", line 450, in _doins
    return install_runner.install_file(source, os.path.dirname(dest))
  File "/usr/lib/portage/python3.6/doins.py", line 386, in install_file
    return self._ins_runner.run(source, dest_dir)
  File "/usr/lib/portage/python3.6/doins.py", line 195, in run
    sstat = os.stat(source)
FileNotFoundError: [Errno 2] No such file or directory: b'doc/pdf/.'
Comment 6 Jan Vesely 2019-03-24 04:19:06 UTC
(In reply to Oleg from comment #4)
> Could you test it with doc use flag? I get error :
> 
> >>> Install nvidia-cuda-toolkit-10.1.105 into /tmp/portage/dev-util/nvidia-cuda-toolkit-10.1.105/image category dev-util
> Traceback (most recent call last):
>   File "/usr/lib/portage/python3.6/doins.py", line 611, in <module>
>     sys.exit(main(sys.argv[1:]))
>   File "/usr/lib/portage/python3.6/doins.py", line 602, in main
>     os.path.dirname(source)):
>   File "/usr/lib/portage/python3.6/doins.py", line 450, in _doins
>     return install_runner.install_file(source, os.path.dirname(dest))
>   File "/usr/lib/portage/python3.6/doins.py", line 386, in install_file
>     return self._ins_runner.run(source, dest_dir)
>   File "/usr/lib/portage/python3.6/doins.py", line 195, in run
>     sstat = os.stat(source)
> FileNotFoundError: [Errno 2] No such file or directory: b'doc/pdf/.'

Right, we should move to builds/cuda-toolkit before considering docs. Should be fixed in the new version. [0] 


[0] https://github.com/jvesely/gentoo/blob/cuda-toolkit/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-10.1.105.ebuild
Comment 7 Oleg 2019-03-24 08:38:45 UTC
(In reply to Jan Vesely from comment #6)
> (In reply to Oleg from comment #4)
> > Could you test it with doc use flag? I get error :
> > 
> > >>> Install nvidia-cuda-toolkit-10.1.105 into /tmp/portage/dev-util/nvidia-cuda-toolkit-10.1.105/image category dev-util
> > Traceback (most recent call last):
> >   File "/usr/lib/portage/python3.6/doins.py", line 611, in <module>
> >     sys.exit(main(sys.argv[1:]))
> >   File "/usr/lib/portage/python3.6/doins.py", line 602, in main
> >     os.path.dirname(source)):
> >   File "/usr/lib/portage/python3.6/doins.py", line 450, in _doins
> >     return install_runner.install_file(source, os.path.dirname(dest))
> >   File "/usr/lib/portage/python3.6/doins.py", line 386, in install_file
> >     return self._ins_runner.run(source, dest_dir)
> >   File "/usr/lib/portage/python3.6/doins.py", line 195, in run
> >     sstat = os.stat(source)
> > FileNotFoundError: [Errno 2] No such file or directory: b'doc/pdf/.'
> 
> Right, we should move to builds/cuda-toolkit before considering docs. Should
> be fixed in the new version. [0] 
> 
> 
> [0]
> https://github.com/jvesely/gentoo/blob/cuda-toolkit/dev-util/nvidia-cuda-
> toolkit/nvidia-cuda-toolkit-10.1.105.ebuild

Thanks, this version works.
Comment 8 Oleg 2019-03-26 18:03:17 UTC
Created attachment 570856 [details]
dev-util/nvidia-cuda-sdk-10.1.105 ebuild

There is SDK ebuild for this version.
Comment 9 Brian Munro 2019-03-29 09:30:46 UTC
Created attachment 571140 [details]
dev-util/nvidia-cuda-sdk-10.1.105 ebuild

The attachment before was for the toolkit, here is a working ebuild for the SDK that I was able to build on my test machine.

i have attached the working nvidia-cuda-toolkit-10.1.105 to the relevant bug (https://bugs.gentoo.org/681694)